CVE-2004-0678
CVSS4.3
发布时间 :2004-08-06 00:00:00
修订时间 :2016-10-17 22:47:42
NMCOES    

[原文]Cross-site scripting (XSS) in one2planet.infolet.InfoServlet in 12Planet Chat Server 2.9 allows remote attackers to execute arbitrary script as other users via the page parameter.


[CNNVD]12Planet Chat Server跨站脚本漏洞(CNNVD-200408-112)

        12Planet Chat Server 2.9 版本中的one2planet.infolet.InfoServlet 存在跨站脚本(XSS)漏洞。远程攻击者可以和其他用户一样通过page参数执行任意脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0678
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0678
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-112
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108904648728706&w=2
(UNKNOWN)  BUGTRAQ  20040705 XSS in 12Planet Chat Server 2.9
http://www.securityfocus.com/bid/10659
(VENDOR_ADVISORY)  BID  10659
http://xforce.iss.net/xforce/xfdb/16605
(VENDOR_ADVISORY)  XF  12planet-chat-server-xss(16605)

- 漏洞信息

12Planet Chat Server跨站脚本漏洞
中危 跨站脚本
2004-08-06 00:00:00 2007-01-02 00:00:00
远程  
        12Planet Chat Server 2.9 版本中的one2planet.infolet.InfoServlet 存在跨站脚本(XSS)漏洞。远程攻击者可以和其他用户一样通过page参数执行任意脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (24253)

12Planet Chat Server 2.9 Cross-Site Scripting Vulnerability (EDBID:24253)
multiple remote
2004-07-05 Verified
0 Donato Ferrante
N/A [点击下载]
source: http://www.securityfocus.com/bid/10659/info

It is reported that 12Planet Chat Server is prone to a cross-site scripting vulnerability. This issue is due to a lack of sanitization of user-supplied data.

The problem presents itself when malicious HTML or script code is passed in a URI argument to one of the servlets in the application.

A remote attacker can exploit this issue by creating a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed by an unsuspecting user, the hostile code may be rendered in the their web browser. This would occur in the security context of the web server and may allow for theft of cookie-based authentication credentials or other attacks.

Although version 2.9 of the software was reported vulnerable, other versions may also be affected.

http://www.example.com:8080/servlet/one2planet.infolet.InfoServlet?page=<script>alert("hy")</script>		

- 漏洞信息

7464
12Planet Chat Server one2planet.infolet.InfoServlet XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

12Planet Chat Server contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate page variables upon submission to the one2planet.infolet.InfoServlet CGI applet. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-07-05 Unknow
2004-07-05 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

12Planet Chat Server Cross-Site Scripting Vulnerability
Input Validation Error 10659
Yes No
2004-07-05 12:00:00 2009-07-12 06:16:00
"Donato Ferrante" <fdonato@autistici.org> disclosed this vulnerability.

- 受影响的程序版本

SGI ProPack 3.0
12Planet Chat Server 2.9

- 漏洞讨论

It is reported that 12Planet Chat Server is prone to a cross-site scripting vulnerability. This issue is due to a lack of sanitization of user-supplied data.

The problem presents itself when malicious HTML or script code is passed in a URI argument to one of the servlets in the application.

A remote attacker can exploit this issue by creating a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed by an unsuspecting user, the hostile code may be rendered in the their web browser. This would occur in the security context of the web server and may allow for theft of cookie-based authentication credentials or other attacks.

Although version 2.9 of the software was reported vulnerable, other versions may also be affected.

- 漏洞利用

No exploit is required. An example URI has been provided:

http://www.example.com:8080/servlet/one2planet.infolet.InfoServlet?page=&lt;script&gt;alert("hy")&lt;/script&gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站