CVE-2004-0675
CVSS6.8
发布时间 :2004-08-06 00:00:00
修订时间 :2016-10-17 22:47:38
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in (1) cart32.exe or (2) c32web.exe in Cart32 shopping cart allows remote attackers to execute arbitrary web script via the cart32 parameter to a GetLatestBuilds command.


[CNNVD]McMurtrey/Whitaker & Associates Cart32 GetLatestBuilds脚本跨站脚本攻击漏洞(CNNVD-200408-019)

        Cart32网上购物系统里的(1) cart32.exe或(2) c32web.exe存在跨站脚本攻击(XSS)漏洞。远程攻击者借助GetLatestBuilds命令的cart32参数执行任意web脚本。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:mcmurtrey_whitaker_and_associates:cart32:5.0
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:2.6
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:3.5
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:4.4
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:3.0
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:3.5a_build710
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:3.1
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:3.5a
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:2.5a
cpe:/a:mcmurtrey_whitaker_and_associates:cart32:3.5_build619

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0675
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0675
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-019
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108887778628398&w=2
(UNKNOWN)  BUGTRAQ  20040703 Cart32 Input Validation Flaw in 'GetLatestBuilds?cart32=' Permits Remote Cross-Site Scripting Attacks
http://www.securityfocus.com/bid/10617
(UNKNOWN)  BID  10617
http://xforce.iss.net/xforce/xfdb/16535
(UNKNOWN)  XF  cart32-getlatestbuilds-xss(16535)

- 漏洞信息

McMurtrey/Whitaker & Associates Cart32 GetLatestBuilds脚本跨站脚本攻击漏洞
中危 跨站脚本
2004-08-06 00:00:00 2007-01-02 00:00:00
远程  
        Cart32网上购物系统里的(1) cart32.exe或(2) c32web.exe存在跨站脚本攻击(XSS)漏洞。远程攻击者借助GetLatestBuilds命令的cart32参数执行任意web脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (24236)

McMurtrey/Whitaker & Associates Cart32 2-5 GetLatestBuilds Script Cross-Site Scripting Vulnerability (EDBID:24236)
cgi webapps
2004-06-28 Verified
0 Dr.Ponidi Haryanto
N/A [点击下载]
source: http://www.securityfocus.com/bid/10617/info

Cart32 is reported prone to a cross-site scripting vulnerability. This issue presents itself due to insufficient sanitization of user-supplied data.

A remote attacker can exploit this issue by creating a malicious link to the vulnerable application that includes hostile HTML and script code. If a user follows this link, the hostile code renders in the web browser of the victim user. Theft of cookie-based authentication credentials and other attacks is possible.

Cart32 version 5.0 and prior are considered prone to this issue. 

http://www.example.com/scripts/cart32.exe/GetLatestBuilds?cart32=<script>alert('XSS')</script> 		

- 漏洞信息

7279
Cart32 cart32.exe GetLatestBuilds XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Cart32 contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "GetLatestBuilds?cart32" variable upon submission to the cart32.exe script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-06-29 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

McMurtrey/Whitaker & Associates Cart32 GetLatestBuilds Script Cross-Site Scripting Vulnerability
Input Validation Error 10617
Yes No
2004-06-28 12:00:00 2009-07-12 05:16:00
Discovery is credited to Dr.Ponidi Haryanto <drponidi@hackermail.com>.

- 受影响的程序版本

McMurtrey/Whitaker & Associates Cart32 5.0
McMurtrey/Whitaker & Associates Cart32 4.4
McMurtrey/Whitaker & Associates Cart32 3.5 a Build 710
McMurtrey/Whitaker & Associates Cart32 3.5 a
McMurtrey/Whitaker & Associates Cart32 3.5 Build 619
McMurtrey/Whitaker & Associates Cart32 3.5
McMurtrey/Whitaker & Associates Cart32 3.1
McMurtrey/Whitaker & Associates Cart32 3.0
McMurtrey/Whitaker & Associates Cart32 2.6
McMurtrey/Whitaker & Associates Cart32 2.5 a

- 漏洞讨论

Cart32 is reported prone to a cross-site scripting vulnerability. This issue presents itself due to insufficient sanitization of user-supplied data.

A remote attacker can exploit this issue by creating a malicious link to the vulnerable application that includes hostile HTML and script code. If a user follows this link, the hostile code renders in the web browser of the victim user. Theft of cookie-based authentication credentials and other attacks is possible.

Cart32 version 5.0 and prior are considered prone to this issue.

- 漏洞利用

No exploit is required.

The following proof of concept is available:
http://www.example.com/scripts/cart32.exe/GetLatestBuilds?cart32=&amp;lt;script&amp;gt;alert('XSS')&amp;lt;/script&amp;gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站