CVE-2004-0660
CVSS6.8
发布时间 :2004-08-06 00:00:00
修订时间 :2016-10-17 22:47:19
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in (1) show_archives.php, (2) show_news.php, and possibly other php files in CuteNews 1.3.1 allows remote attackers to inject arbitrary script or HTML via the id parameter.


[CNNVD]CuteNews多个跨站脚本攻击漏洞(CNNVD-200408-063)

        CuteNews 1.3.1版本的(1) show_archives.php, (2) show_news.php和可能其他的php文件存在跨站脚本攻击(XSS)漏洞。远程攻击者借助id参数注入任意脚本或HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:cutephp:cutenews:0.88
cpe:/a:cutephp:cutenews:1.3
cpe:/a:cutephp:cutenews:1.3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0660
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0660
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-063
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108844000409449&w=2
(UNKNOWN)  BUGTRAQ  20040628 Cross-Site Scripting CuteNews
http://xforce.iss.net/xforce/xfdb/16525
(UNKNOWN)  XF  cutenews-id-xss(16525)

- 漏洞信息

CuteNews多个跨站脚本攻击漏洞
中危 跨站脚本
2004-08-06 00:00:00 2006-12-27 00:00:00
远程  
        CuteNews 1.3.1版本的(1) show_archives.php, (2) show_news.php和可能其他的php文件存在跨站脚本攻击(XSS)漏洞。远程攻击者借助id参数注入任意脚本或HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (24238)

CuteNews 0.88/1.3 example1.php id Parameter XSS (EDBID:24238)
php webapps
2004-06-28 Verified
0 DarkBicho
N/A [点击下载]
source: http://www.securityfocus.com/bid/10620/info

It is reported that CuteNews is affected by multiple cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.

The problems present themselves when malicious HTML and script code is sent to the application through the 'id' parameter of the multiple scripts.

These issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. 

http://www.example.com/example1.php?subaction=showfull&id=<script>alert(document.cookie);</script>		

- 漏洞信息 (24239)

CuteNews 0.88/1.3 example2.php id Parameter XSS (EDBID:24239)
php webapps
2004-06-28 Verified
0 DarkBicho
N/A [点击下载]
source: http://www.securityfocus.com/bid/10620/info
 
It is reported that CuteNews is affected by multiple cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.
 
The problems present themselves when malicious HTML and script code is sent to the application through the 'id' parameter of the multiple scripts.
 
These issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. 

http://www.example.com/example2.php?subaction=showfull&id=<script>alert(document.cookie);</script> 		

- 漏洞信息 (24240)

CuteNews 0.88/1.3 show_archives.php id Parameter XSS (EDBID:24240)
php webapps
2004-06-28 Verified
0 DarkBicho
N/A [点击下载]
source: http://www.securityfocus.com/bid/10620/info
  
It is reported that CuteNews is affected by multiple cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.
  
The problems present themselves when malicious HTML and script code is sent to the application through the 'id' parameter of the multiple scripts.
  
These issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. 

http://www.example.com/show_archives.php?subaction=showcomments&id=<script>alert(document.cookie);</script>&archive=&start_from=&ucat=&&archive=&start_from=&ucat=&		

- 漏洞信息 (24290)

CuteNews 1.3 Comment HTML Injection Vulnerability (EDBID:24290)
php webapps
2004-07-19 Verified
0 DarkBicho
N/A [点击下载]
source: http://www.securityfocus.com/bid/10750/info

CutePHP is reported prone to an HTML injection vulnerability.

The vulnerability exists due to insufficient sanitization of user-supplied input. Specifically, user-supplied input to comment posts are not sufficiently sanitized of malicious HTML code.

An attacker can exploit this vulnerability by adding HTML code within URI arguments. The hostile code may be rendered in the user's browser when the user views the entry.

Exploitation could permit an attacker to steal cookie-based authentication credentials or launch other attacks.

http://www.example.com/show_news.php?subaction=addcomment&name=UserName&comments=http://www.example.com&id=1078525267||1090074219|UserName|none|127.0.0.1|<script>alert("example");</script>|| 		

- 漏洞信息 (24372)

CuteNews 1.3.1 show_archives.php archive Parameter XSS (EDBID:24372)
php webapps
2004-07-16 Verified
0 Debasis Mohanty
N/A [点击下载]
source: http://www.securityfocus.com/bid/10948/info

It is reported that CuteNews is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

This vulnerability is reported to exist in version 1.3.1 of CuteNews. Other versions may also be affected.

http://www.example.com/show_archives.php?archive=[code]&subaction=list-archive&		

- 漏洞信息

7283
CuteNews show_archives.php id Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

CuteNews contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "id" variable upon submission to the show_archives.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-06-28 Unknow
2004-06-28 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CuteNews 'show_archives.php' Cross-Site Scripting Vulnerability
Input Validation Error 10948
Yes No
2004-08-16 12:00:00 2009-07-12 06:16:00
Debasis Mohanty is credited with the discovery of this vulnerability.

- 受影响的程序版本

CutePHP CuteNews 1.3.1

- 漏洞讨论

It is reported that CuteNews is affected by a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied URI input.

This issue could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were to be followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

This vulnerability is reported to exist in version 1.3.1 of CuteNews. Other versions may also be affected.

- 漏洞利用

An exploit is not required. An example URI sufficient to exploit this vulnerability has been provided:

http://www.example.com/show_archives.php?archive=[code]&amp;subaction=list-archive&amp;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站