CVE-2004-0654
CVSS2.1
发布时间 :2004-08-06 00:00:00
修订时间 :2008-09-10 15:27:09
NMCOS    

[原文]Unknown vulnerability in the Basic Security Module (BSM), when configured to audit either the Administrative (ad) or the System-Wide Administration (as) audit class in Solaris 7, 8, and 9, allows local users to cause a denial of service (kernel panic).


[CNNVD]Sun Solaris基本安全模块审核本地拒绝服务漏洞(CNNVD-200408-086)

        
        Solaris是一款由Sun Microsystems公司开发和维护的商业性质UNIX操作系统。
        Solaris系统包含的基本安全模块( Basic Security Module )存在未明问题,本地攻击者可以利用这个漏洞使系统崩溃。
        此漏洞发生在系统的BSM配置为Administrative audit class "ad"或System-Wide Administration audit class "as"审核的情况下。目前没有详细漏洞细节提供。
        <*链接:http://sunsolve.sun.com/pub-cgi/retrieve.pl?doc=fsalert%2F57497
        *>

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:solaris:9.0::sparc
cpe:/o:sun:solaris:8.0
cpe:/o:sun:solaris:7.0::x86
cpe:/o:sun:solaris:7.0
cpe:/o:sun:solaris:9.0::x86
cpe:/o:sun:solaris:8.0::x86
cpe:/o:sun:solaris:9.0:x86_update_2

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:2426BSM Audit Kernel Panic
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0654
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0654
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-086
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/901582
(VENDOR_ADVISORY)  CERT-VN  VU#901582
http://xforce.iss.net/xforce/xfdb/16483
(VENDOR_ADVISORY)  XF  solaris-bsm-audit-dos(16483)
http://www.securityfocus.com/bid/10594
(UNKNOWN)  BID  10594
http://sunsolve.sun.com/pub-cgi/retrieve.pl?doc=fsalert/57497
(UNKNOWN)  SUNALERT  57497
http://secunia.com/advisories/11930/
(UNKNOWN)  SECUNIA  11930

- 漏洞信息

Sun Solaris基本安全模块审核本地拒绝服务漏洞
低危 未知
2004-08-06 00:00:00 2005-10-20 00:00:00
本地  
        
        Solaris是一款由Sun Microsystems公司开发和维护的商业性质UNIX操作系统。
        Solaris系统包含的基本安全模块( Basic Security Module )存在未明问题,本地攻击者可以利用这个漏洞使系统崩溃。
        此漏洞发生在系统的BSM配置为Administrative audit class "ad"或System-Wide Administration audit class "as"审核的情况下。目前没有详细漏洞细节提供。
        <*链接:http://sunsolve.sun.com/pub-cgi/retrieve.pl?doc=fsalert%2F57497
        *>

- 公告与补丁

        厂商补丁:
        Sun
        ---
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Sun Solaris 7.0 _x86:
        Sun Patch 106542-34
        
        http://sunsolve.sun.com/pub-cgi/106542-34.zip

        Sun Solaris 7.0:
        Sun Patch 106541-34
        https://sunsolve.sun.com/pub-cgi/106541-34.tar
        Sun Solaris 8.0 _x86:
        Sun Patch 109008-18
        
        http://sunsolve.sun.com/pub-cgi/109008-18.zip

        Sun Solaris 8.0:
        Sun Patch 109007-18
        
        http://sunsolve.sun.com/pub-cgi/109007-18.zip

        Sun Solaris 9.0 _x86:
        Sun Patch 116558-01
        
        http://sunsolve.sun.com/pub-cgi/116558-01.zip

        Sun Solaris 9.0:
        Sun Patch 114332-12
        
        http://sunsolve.sun.com/pub-cgi/114332-12.zip

- 漏洞信息

7240
Solaris Basic Security Module (BSM) Local DoS
Local Access Required Denial of Service
Loss of Availability
Exploit Unknown

- 漏洞描述

Sun Microsystems Solaris contains a flaw that may allow a local denial of service. The issue is triggered when its Basic Security Module (BSM) has been configured to audit the Administrative audit class "ad" or the System-Wide Administration audit class "as", and will result in loss of availability for the platform.

- 时间线

2004-06-22 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Sun Microsystems has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Sun Solaris Basic Security Module Auditing Denial Of Service Vulnerability
Unknown 10594
No Yes
2004-06-22 12:00:00 2009-07-12 05:16:00
This issue was disclosed in the referenced vendor advisory.

- 受影响的程序版本

Sun Solaris 9_x86 Update 2
Sun Solaris 9_x86
Sun Solaris 9
Sun Solaris 8_x86
Sun Solaris 8_sparc
Sun Solaris 7.0_x86
Sun Solaris 7.0

- 漏洞讨论

Sun Solaris Basic Security Module is reportedly affected by a denial of service vulnerability.

This issue will allow an attacker to cause the affected kernel to panic, requiring a reboot of the system, and denying service to legitimate users.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Sun has released Security Alert 57497 dealing with this issue.


Sun Solaris 7.0_x86

Sun Solaris 9_x86

Sun Solaris 7.0

Sun Solaris 8_x86

Sun Solaris 8_sparc

Sun Solaris 9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站