CVE-2004-0640
CVSS10.0
发布时间 :2004-08-06 00:00:00
修订时间 :2008-09-10 15:27:05
NMCOPS    

[原文]Format string vulnerability in the SSL_set_verify function in telnetd.c for SSLtelnet daemon (SSLtelnetd) 0.13 allows remote attackers to execute arbitrary code.


[CNNVD]SSLTelnetd远程syslog格式串处理漏洞(CNNVD-200408-108)

        SSLtelnetd是一款加密通信的telnetd替代品。
        SSLtelnet daemon (SSLtelnetd) 0.13版本包含一个格式串问题,远程攻击者可以利用这个漏洞以SSLtelnetd进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:netkit:linux_netkit:0.17.17
cpe:/a:ssltelnetd:secure_telnet:0.13.1
cpe:/a:netkit:linux_netkit:0.17

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0640
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0640
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-108
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2004/dsa-529
(VENDOR_ADVISORY)  DEBIAN  DSA-529
http://xforce.iss.net/xforce/xfdb/16653
(VENDOR_ADVISORY)  XF  ssltelnetd-format-string(16653)
http://www.idefense.com/application/poi/display?id=114&type=vulnerabilities
(UNKNOWN)  MISC  http://www.idefense.com/application/poi/display?id=114&type=vulnerabilities

- 漏洞信息

SSLTelnetd远程syslog格式串处理漏洞
危急 设计错误
2004-08-06 00:00:00 2012-12-07 00:00:00
远程  
        SSLtelnetd是一款加密通信的telnetd替代品。
        SSLtelnet daemon (SSLtelnetd) 0.13版本包含一个格式串问题,远程攻击者可以利用这个漏洞以SSLtelnetd进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        SSLtelnetd
        ----------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.freebsd.org/ports/security.html

- 漏洞信息 (F33752)

iDEFENSE Security Advisory 2004-07-08.t (PacketStormID:F33752)
2004-07-08 00:00:00
iDefense Labs  idefense.com
advisory,remote,code execution
CVE-2004-0640
[点击下载]

iDEFENSE Security Advisory 07.08.04: SSLtelnet contains a format string vulnerability that could allow remote code execution. The problem specifically exists within telnetd.c, on line 530 where an argument deficient call is made to syslog().

SSLTelnet Remote Format String Vulnerability

iDEFENSE Security Advisory 07.08.04:

*I. BACKGROUND*

SSLtelnetd is a replacement for telnetd available as part of the FreeBSD
ports collection at http://www.freebsd.org/ports/security.html. It
implements the telnet protocol over SSL.

*II. DESCRIPTION*

SSLtelnet contains a format string vulnerability that could allow remote
code execution. 

The problem specifically exists within telnetd.c, on line 530 where an
argument deficient call is made to syslog(). The following snippet
reveals the vulnerable code:

SSL_set_verify(ssl_con,ssl_verify_flag,NULL);


    if (SSL_accept(ssl_con) <= 0) {
        static char errbuf[1024];


        sprintf(errbuf,"SSL_accept error %s\n",
        ERR_error_string(ERR_get_error(),NULL));


        syslog(LOG_WARNING, errbuf);  // vulnerable call


        BIO_printf(bio_err,errbuf);


        /* go to sleep to make sure we are noticed */
        sleep(10);
        SSL_free(ssl_con);


        _exit(1);
    } else {
        ssl_active_flag=1;
    }

*III. ANALYSIS*

This vulnerability could be remotely exploitable under certain
conditions. If exploitation is successful, gaining root access is
possible as the process runs as root.

*IV. DETECTION*

iDEFENSE has confirmed the existence of this vulnerability against
the current release, SSLTelnet version 0.13-1.

*V. WORKAROUND*

This project does not appear to be actively maintained and has now been
marked FORBIDDEN and DEPRECATED. End users should consider implementing
an alternate telnet/SSL solution.

*VI. CVE INFORMATION*

The Common Vulnerabilities and Exposures (CVE) project has assigned the
name CAN-2004-0640 to this issue. This is a candidate for inclusion in
the CVE list (http://cve.mitre.org <http://cve.mitre.org/>), which
standardizes names for
security problems.

*VII. DISCLOSURE TIMELINE*

04/03/2003   Vulnerability acquired by iDEFENSE
06/29/2004   Initial vendor contact
07/02/2004   Secondary vendor contact
07/08/2004   Public disclosure

*VIII. CREDIT*

 b0f is credited with this discovery.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

*IX. LEGAL NOTICES*

Copyright (c) 2004 iDEFENSE, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com <mailto:customerservice@idefense.com>
for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.
    

- 漏洞信息

7594
SSLTelnet Error Logging Remote Format String
Remote / Network Access, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity

- 漏洞描述

SSLTelnet contains a flaw that may allow a malicious user to execute code remotely. The issue is triggered when a call is made to the syslog() function without any arguments. Under some circumstances this may be exploited remotely resulting in a loss of integrity.

- 时间线

2004-07-08 2003-04-03
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

SSLTelnetd Remote Syslog Format String Vulnerability
Design Error 10684
Yes No
2004-07-09 12:00:00 2009-07-12 06:16:00
The individual responsible for disclosure of this issue is currently unknown; this issue was disclosed in the referenced iDEFENSE security advisory. b0f is credited with discovering this issue in netkit-telnet-ssl.

- 受影响的程序版本

SSLtelnetd Secure Telnet 0.13 -1
Netkit Linux Netkit 0.17.17
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
Netkit Linux Netkit 0.17
+ Caldera OpenLinux 2.4
+ Caldera OpenLinux 2.3
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Gentoo Linux
+ Red Hat Enterprise Linux AS 4
+ Red Hat Enterprise Linux AS 3
+ Red Hat Enterprise Linux AS 2.1 IA64
+ Red Hat Enterprise Linux AS 2.1
+ RedHat Desktop 4.0
+ RedHat Desktop 3.0
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux ES 3
+ RedHat Enterprise Linux ES 2.1 IA64
+ RedHat Enterprise Linux ES 2.1
+ RedHat Enterprise Linux WS 4
+ RedHat Enterprise Linux WS 3
+ RedHat Enterprise Linux WS 2.1 IA64
+ RedHat Enterprise Linux WS 2.1
+ RedHat Linux 7.1 i386
+ RedHat Linux 7.1 alpha
+ RedHat Linux 7.1
+ RedHat Linux 7.0 sparc
+ RedHat Linux 7.0 i386
+ RedHat Linux 7.0 alpha
+ RedHat Linux 7.0
+ SCO eDesktop 2.4
+ SCO eServer 2.3.1
+ Sun Solaris 9_x86 Update 2
+ Sun Solaris 9_x86
+ Sun Solaris 9
+ Sun Solaris 8_x86
+ Sun Solaris 8_sparc
+ Sun Solaris 7.0_x86
+ Sun Solaris 7.0
+ Sun Solaris 10
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32

- 漏洞讨论

Reportedly SSLTelnetd, which is available as a FreeBSD port, is affected by a remote format string vulnerability. This issue is due to an improper implementation of the 'syslog()' formatted string function.

As a result of this issue, malicious log entries containing format specifiers will be interpreted literally when logs are written; this may result in attacker-specified memory being corrupted or disclosed, leading to arbitrary code execution.

Linux Netkit netkit-telnet-ssl is affected by this issue as well.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Debian has released advisory DSA 529-1 to address this issue. Please see the attached advisory for details about obtaining and applying fixes.


Netkit Linux Netkit 0.17.17

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站