CVE-2004-0638
CVSS8.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 00:00:00
NMCOS    

[原文]Buffer overflow in the KSDWRTB function in the dbms_system package (dbms_system.ksdwrt) for Oracle 9i Database Server Release 2 9.2.0.3 and 9.2.0.4, 9i Release 1 9.0.1.4 and 9.0.1.5, and 8i Release 1 8.1.7.4, allows remote authorized users to execute arbitrary code via a long second argument.


[CNNVD]Oracle 8i/9i DBMS_SYSTEM.KSDWRT()缓冲区溢出漏洞(CNNVD-200412-755)

        
        Oracle Database是一款商业性质大型数据库系统。
        Oracle Database的KSDWRT()函数对参数检查缺少充分编辑缓冲区检查,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以进程权限执行任意指令。
        拥有执行dbms_system包权限的Oracle用户可以通过使用特殊构建的参数给KSDWRT()处理,可触发缓冲区溢出,精心构建提交数据可能以进程权限执行任意指令。
        默认情况下DBA用户拥有对此包的访问权限。
        

- CVSS (基础分值)

CVSS分值: 8.5 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: SINGLE_INSTANCE [--]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:oracle:oracle9i:enterprise_9.0.1.5
cpe:/a:oracle:oracle9i:personal_9.2.0.4
cpe:/a:oracle:oracle9i:personal_9.0.1.5
cpe:/a:oracle:oracle9i:standard_9.2.0.4
cpe:/a:oracle:oracle9i:personal_9.2.0.3
cpe:/a:oracle:oracle9i:standard_9.2.0.3
cpe:/a:oracle:oracle8i:standard_8.1.7.4
cpe:/a:oracle:oracle9i:standard_9.0.1.4
cpe:/a:oracle:oracle9i:enterprise_9.2.0.4
cpe:/a:oracle:oracle9i:enterprise_9.0.1.4
cpe:/a:oracle:oracle9i:enterprise_9.2.0.3
cpe:/a:oracle:oracle9i:standard_9.0.1.5
cpe:/a:oracle:oracle8i:enterprise_8.1.7.4
cpe:/a:oracle:oracle9i:personal_9.0.1.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0638
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0638
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-755
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17254
(VENDOR_ADVISORY)  XF  oracle-dbmssystem-bo(17254)
http://www.securityfocus.com/bid/11100
(PATCH)  BID  11100
http://www.red-database-security.com/advisory/advisory_20040903_3.htm
(VENDOR_ADVISORY)  MISC  http://www.red-database-security.com/advisory/advisory_20040903_3.htm
http://www.idefense.com/application/poi/display?id=135&type=vulnerabilities&flashstatus=false
(VENDOR_ADVISORY)  IDEFENSE  20040902 Oracle Database Server dbms_system.ksdwrt Buffer Overflow Vulnerability
http://archives.neohapsis.com/archives/fulldisclosure/2004-09/0178.html
(VENDOR_ADVISORY)  FULLDISC  20040905 Buffer Overflow in DBMS_SYSTEM.KSDWRT() in Oracle8i - 9i
http://www.oracle.com/technology/deploy/security/pdf/2004alert68.pdf
(VENDOR_ADVISORY)  CONFIRM  http://www.oracle.com/technology/deploy/security/pdf/2004alert68.pdf

- 漏洞信息

Oracle 8i/9i DBMS_SYSTEM.KSDWRT()缓冲区溢出漏洞
高危 边界条件错误
2004-12-31 00:00:00 2006-04-21 00:00:00
远程  
        
        Oracle Database是一款商业性质大型数据库系统。
        Oracle Database的KSDWRT()函数对参数检查缺少充分编辑缓冲区检查,远程攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以进程权限执行任意指令。
        拥有执行dbms_system包权限的Oracle用户可以通过使用特殊构建的参数给KSDWRT()处理,可触发缓冲区溢出,精心构建提交数据可能以进程权限执行任意指令。
        默认情况下DBA用户拥有对此包的访问权限。
        

- 公告与补丁

        厂商补丁:
        Oracle
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=281189.1

- 漏洞信息

9817
Oracle Database Server dbms_system.ksdwrt() Function Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Oracle Database Server contains a flaw that may allow a remote attacker to execute arbitrary code. The issue is due to the dbms_system.ksdwrt() function not properly sanitizing user input. If an attacker provides a specially crafted argument for the second argument of this function, a buffer overflow occurs potentially allowing code execution.

- 时间线

2004-09-10 Unknow
Unknow Unknow

- 解决方案

Upgrade to version R1 10.1.0.3 or higher, as it has been reported to fix this vulnerability. Additionally, Oracle has provided a patch (9ir2 Patchset 4 (9.2.0.5)) to address this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Oracle Database Server dbms_system.ksdwrt Remote Buffer Overflow Vulnerability
Boundary Condition Error 11100
Yes No
2004-09-03 12:00:00 2009-07-12 07:06:00
Discovery is credited to Alexander Kornbrust.

- 受影响的程序版本

Oracle Oracle9i Standard Edition 9.2 .0.3
Oracle Oracle9i Standard Edition 9.0.1 .5
Oracle Oracle9i Standard Edition 9.0.1 .4
Oracle Oracle9i Standard Edition 9.0 .2.4
Oracle Oracle9i Personal Edition 9.2 .0.3
Oracle Oracle9i Personal Edition 9.0.1 .5
Oracle Oracle9i Personal Edition 9.0.1 .4
Oracle Oracle9i Personal Edition 9.0 .2.4
Oracle Oracle9i Enterprise Edition 9.2 .0.3
Oracle Oracle9i Enterprise Edition 9.0.1 .5
Oracle Oracle9i Enterprise Edition 9.0.1 .4
Oracle Oracle9i Enterprise Edition 9.0 .2.4
Oracle Oracle8i Standard Edition 8.1.7 .4
Oracle Oracle8i Enterprise Edition 8.1.7 .4.0

- 漏洞讨论

A remotely exploitable buffer overflow exists in Oracle Database Server.

The issue can be triggered when an overly long string is passed to an internal logging function. Authorized users could exploit this issue to execute arbitrary code in the context of the server process or to cause a denial of service.

This issue corresponds to one of the unspecified vulnerabilities mentioned in BID 10871 and addressed by Oracle Alert #68.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Oracle has released an alert (#68) and a patch to address these issues. Information regarding obtaining and applying an appropriate patch can be found at the following location:
http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=281189.1

It should be noted that a valid subscription to the metalink service is required in order to view this document.

It is reported that software conflicts may arise when these patches are installed against binaries that have already had patches installed. Additionally, although Oracle 9i 9.2.x.x database server is supported, it is reported that customers may be required to update to versions 9.2.0.4/9.2.0.5 prior to applying these patches. This action might also be required for other releases and products. Customers are advised to contact the vendor for further information and support in regards to the installation of appropriate updates.

A message from "David Litchfield" <davidl@ngssoftware.com> is available that states that some of the vulnerabilities in alert #68 may not have been successfully fixed by Oracle. Users of affected packages should refer to the referenced message, and contact their vendor for further information on the status of fixes.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站