CVE-2004-0637
CVSS6.5
发布时间 :2004-09-02 00:00:00
修订时间 :2008-09-10 00:00:00
NMCOES    

[原文]Oracle Database Server 8.1.7.4 through 9.2.0.4 allows local users to execute commands with additional privileges via the ctxsys.driload package, which is publicly accessible.


[CNNVD]Oracle数据库服务器ctxsys.driload访问验证漏洞(CNNVD-200409-009)

        Oracle数据库服务器8.1.7.4 到9.2.0.4版本存在漏洞。本地用户借助可以被公开访问的ctxsys.driload数据包执行有附加权限的命令。

- CVSS (基础分值)

CVSS分值: 6.5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: SINGLE_INSTANCE [--]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:oracle:oracle8i:standard_8.1.7_.4
cpe:/a:oracle:oracle9i:personal_9.2.0.4
cpe:/a:oracle:oracle9i:standard_9.2.0.4
cpe:/a:oracle:oracle9i:standard_9.0.1.3
cpe:/a:oracle:oracle8i:enterprise_8.1.7_.4
cpe:/a:oracle:oracle9i:enterprise_9.2.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0637
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0637
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200409-009
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/316206
(VENDOR_ADVISORY)  CERT-VN  VU#316206
http://www.idefense.com/application/poi/display?id=136&type=vulnerabilities&flashstatus=true
(VENDOR_ADVISORY)  IDEFENSE  20040902 Oracle Database Server ctxsys.driload Access Validation Vulnerability
http://secunia.com/advisories/12409/
(VENDOR_ADVISORY)  SECUNIA  12409
http://www.securityfocus.com/bid/11099
(UNKNOWN)  BID  11099

- 漏洞信息

Oracle数据库服务器ctxsys.driload访问验证漏洞
中危 访问验证错误
2004-09-02 00:00:00 2006-05-01 00:00:00
远程  
        Oracle数据库服务器8.1.7.4 到9.2.0.4版本存在漏洞。本地用户借助可以被公开访问的ctxsys.driload数据包执行有附加权限的命令。

- 公告与补丁

        Oracle has released an alert (#68) and a patch to address these issues. Information regarding obtaining and applying an appropriate patch can be found at the following location:
        http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=281189.1
        It should be noted that a valid subscription to the metalink service is required in order to view this document.
        It is reported that software conflicts may arise when these patches are installed against binaries that have already had patches installed. Additionally, although Oracle 9i 9.2.x.x database server is supported, it is reported that customers may be required to update to versions 9.2.0.4/9.2.0.5 prior to applying these patches. This action might also be required for other releases and products. Customers are advised to contact the vendor for further information and support in regards to the installation of appropriate updates.
        A message from "David Litchfield" is available that states that some of the vulnerabilities in alert #68 may not have been successfully fixed by Oracle. Users of affected packages should refer to the referenced message, and contact their vendor for further information on the status of fixes.
        A message from "NGSSoftware Insight Security Research" (Oracle October 2005 CPU Problems) states that there is a flaw in the fix for the CTXSYS component of Oracle 8.1.7.4 on all platforms. Please see the referenced message for further details on this issue.

- 漏洞信息 (24567)

Oracle Database Server 8.1.7/9.0.x ctxsys.driload Access Validation Vulnerability (EDBID:24567)
multiple remote
2004-09-03 Verified
0 Alexander Kornbrust
N/A [点击下载]
source: http://www.securityfocus.com/bid/11099/info

Oracle Database Server is prone to an access validation vulnerability that may permit unprivileged users to execute commands as the DBA. This could compromise the database.

SQL> exec ctxsys.driload.validate_stmt
('create user hacker identified by hacker');
SQL> exec ctxsys.driload.validate_stmt('grant dba, connect to hacker');		

- 漏洞信息

9819
Oracle CTXSYS Package DRILOAD SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Vendor Verified

- 漏洞描述

Oracle Database Server contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that unprivilege users (including default accounts) may execute arbitrary SQL queries via the "ctxsys.driload" module. The server does not require any additional authentication and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-09-04 Unknow
2004-09-03 Unknow

- 解决方案

Upgrade to version R1 10.1.0.3 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workarounds: 1. Remove the ctxsys account if it is not needed: SQL> Drop user ctxsys 2. Revoke privileges to the ctxsys.driload object: SQL> revoke grant ctxsys.driload from public

- 相关参考

- 漏洞作者

- 漏洞信息

Oracle Database Server ctxsys.driload Access Validation Vulnerability
Access Validation Error 11099
Yes No
2004-09-03 12:00:00 2009-07-12 07:06:00
Discovery is credited to Alexander Kornbrust.

- 受影响的程序版本

Oracle Oracle9i Standard Edition 9.0.1 .3
Oracle Oracle9i Standard Edition 9.0 .2.4
Oracle Oracle9i Personal Edition 9.0 .2.4
Oracle Oracle9i Enterprise Edition 9.0 .2.4
Oracle Oracle8i Standard Edition 8.1.7 .4
Oracle Oracle8i Enterprise Edition 8.1.7 .4.0

- 漏洞讨论

Oracle Database Server is prone to an access validation vulnerability that may permit unprivileged users to execute commands as the DBA. This could compromise the database.

This issue corresponds to one of the unspecified vulnerabilities mentioned in BID 10871 and addressed by Oracle Alert #68.

- 漏洞利用

The following example was provided:

SQL> exec ctxsys.driload.validate_stmt
('create user hacker identified by hacker');
SQL> exec ctxsys.driload.validate_stmt('grant dba, connect to hacker');

- 解决方案

Oracle has released an alert (#68) and a patch to address these issues. Information regarding obtaining and applying an appropriate patch can be found at the following location:
http://metalink.oracle.com/metalink/plsql/ml2_documents.showDocument?p_database_id=NOT&p_id=281189.1

It should be noted that a valid subscription to the metalink service is required in order to view this document.

It is reported that software conflicts may arise when these patches are installed against binaries that have already had patches installed. Additionally, although Oracle 9i 9.2.x.x database server is supported, it is reported that customers may be required to update to versions 9.2.0.4/9.2.0.5 prior to applying these patches. This action might also be required for other releases and products. Customers are advised to contact the vendor for further information and support in regards to the installation of appropriate updates.

A message from "David Litchfield" <davidl@ngssoftware.com> is available that states that some of the vulnerabilities in alert #68 may not have been successfully fixed by Oracle. Users of affected packages should refer to the referenced message, and contact their vendor for further information on the status of fixes.

A message from "NGSSoftware Insight Security Research" <nisr@nextgenss.com> (Oracle October 2005 CPU Problems) states that there is a flaw in the fix for the CTXSYS component of Oracle 8.1.7.4 on all platforms. Please see the referenced message for further details on this issue.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站