CVE-2004-0634
CVSS5.0
发布时间 :2004-12-06 00:00:00
修订时间 :2010-08-21 00:20:54
NMCOP    

[原文]The SMB SID snooping capability in Ethereal 0.9.15 to 0.10.4 allows remote attackers to cause a denial of service (process crash) via a handle without a policy name, which causes a null dereference.


[CNNVD]Ethereal多个未明iSNS/SMB/SNMP协议解析器安全漏洞(CNNVD-200412-043)

        
        Ethereal是一款免费开放源代码的网络协议分析程序。
        Ethereal包含的iSNS、SMB、SNMP协议解析器存在未明问题,远程攻击者可以利用这些漏洞进行拒绝服务攻击,或以进程权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:mandrakesoft:mandrake_linux:9.2MandrakeSoft Mandrake Linux 9.2
cpe:/o:gentoo:linuxGentoo Linux
cpe:/o:redhat:enterprise_linux:3.0::enterprise_server
cpe:/a:ethereal_group:ethereal:0.9.15
cpe:/o:redhat:enterprise_linux:2.1::workstation
cpe:/a:ethereal_group:ethereal:0.10.4
cpe:/o:redhat:enterprise_linux:3.0::advanced_server
cpe:/o:redhat:enterprise_linux:2.1::advanced_server
cpe:/o:mandrakesoft:mandrake_linux:10.0MandrakeSoft Mandrake Linux 10.0
cpe:/o:redhat:enterprise_linux:2.1::enterprise_server
cpe:/o:redhat:linux_advanced_workstation:2.1::as
cpe:/o:redhat:enterprise_linux:3.0::workstation_server

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10252The SMB SID snooping capability in Ethereal 0.9.15 to 0.10.4 allows remote attackers to cause a denial of service (process crash) via a hand...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0634
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0634
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-043
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/518782
(UNKNOWN)  CERT-VN  VU#518782
http://xforce.iss.net/xforce/xfdb/16631
(VENDOR_ADVISORY)  XF  ethereal-smb-sid-dos(16631)
http://www.redhat.com/archives/fedora-announce-list/2004-July/msg00014.html
(VENDOR_ADVISORY)  FEDORA  FEDORA-2004-220
http://www.redhat.com/archives/fedora-announce-list/2004-July/msg00013.html
(VENDOR_ADVISORY)  FEDORA  FEDORA-2004-219
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:067
(VENDOR_ADVISORY)  MANDRAKE  MDKSA-2004:067
http://www.gentoo.org/security/en/glsa/glsa-200407-08.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200407-08
http://www.redhat.com/support/errata/RHSA-2004-378.html
(UNKNOWN)  REDHAT  RHSA-2004:378
http://www.ethereal.com/appnotes/enpa-sa-00015.html
(UNKNOWN)  CONFIRM  http://www.ethereal.com/appnotes/enpa-sa-00015.html
http://securitytracker.com/id?1010655
(UNKNOWN)  SECTRACK  1010655
http://secunia.com/advisories/12024
(UNKNOWN)  SECUNIA  12024
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=127381
(UNKNOWN)  CONFIRM  http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=127381
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000916
(UNKNOWN)  CONECTIVA  CLA-2005:916

- 漏洞信息

Ethereal多个未明iSNS/SMB/SNMP协议解析器安全漏洞
中危 其他
2004-12-06 00:00:00 2005-10-20 00:00:00
远程  
        
        Ethereal是一款免费开放源代码的网络协议分析程序。
        Ethereal包含的iSNS、SMB、SNMP协议解析器存在未明问题,远程攻击者可以利用这些漏洞进行拒绝服务攻击,或以进程权限在系统上执行任意指令。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Ethereal Group
        --------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Ethereal Group Upgrade Ethereal 0.10.5
        
        http://www.ethereal.com/download.html

- 漏洞信息 (F33738)

Ethereal Security Advisory 15 (PacketStormID:F33738)
2004-07-06 00:00:00
Ethereal  ethereal.com
advisory,arbitrary
CVE-2004-0633,CVE-2004-0634,CVE-2004-0635
[点击下载]

Ethereal Security Advisory Enpa-sa-00015 - It may be possible to make Ethereal crash or run arbitrary code by injecting a purposefully malformed packet onto the wire or by convincing someone to read a malformed packet trace file due to three flaws. Versions affected: 0.8.15 up to and including 0.10.4.

*Name:* Multiple problems in Ethereal 0.10.4

*Docid:* enpa-sa-00015

*Date:* July 6, 2004

*Versions affected:* 0.8.15 up to and including 0.10.4

*Severity:* *High*


    Details

*Description:*

Issues have been discovered in the following protocol dissectors:

    * The iSNS dissector could make Ethereal abort in some cases.
      (0.10.3 - 0.10.4) CAN-2004-0633
      <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0633>
    * SMB SID snooping could crash if there was no policy name for a
      handle. (0.9.15 - 0.10.4) CAN-2004-0634
      <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0634>
    * The SNMP dissector could crash due to a malformed or missing
      community string. (0.8.15 - 0.10.4) CAN-2004-0635
      <http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0635>

*Impact:*

It may be possible to make Ethereal crash or run arbitrary code by
injecting a purposefully malformed packet onto the wire or by convincing
someone to read a malformed packet trace file.

*Resolution:*

Upgrade to 0.10.5.

If you are running a version prior to 0.10.5 and you cannot upgrade, you
can disable all of the protocol dissectors listed above by selecting
/Analyze->Enabled Protocols.../ and deselecting them from the list. For
SMB, you can alternatively disable SID snooping in the SMB protocol
preferences. However, it is strongly recommended that you upgrade to
0.10.5.

Please send support questions about Ethereal to the
ethereal-users[AT]ethereal.com <mailto:ethereal-users[AT]ethereal.com>
mailing list.
For corrections/additions/suggestions for this web page (and *not*
Ethereal support questions), please send email to
ethereal-web[AT]ethereal.com <mailto:ethereal-web[AT]ethereal.com> .
Last modified: Thu, July 08 2004.
    

- 漏洞信息

7537
Ethereal SMB SID Snooping No Policy Handle DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Unknown

- 漏洞描述

Ethereal contains a flaw that may allow a remote denial of service. The issue is triggered when SMB SID snooping is used and there is no policy name for a handle, which will result in loss of availability for the service.

- 时间线

2004-07-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.10.5 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround(s): disable SID snooping in the SMB protocol preferences.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站