CVE-2004-0606
CVSS6.8
发布时间 :2004-12-06 00:00:00
修订时间 :2016-10-17 22:46:38
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in Infoblox DNS One running firmware 2.4.0-8 and earlier allows remote attackers to execute arbitrary scripts as other users via the (1) CLIENTID or (2) HOSTNAME option of a DHCP request.


[CNNVD]Infoblox DNS One脚本注入漏洞(CNNVD-200412-024)

        Infoblox DNS One运行固件2.4.0-8及其早期版本时存在跨站点脚本漏洞。远程攻击者像其他用户一样借助(1)CLIENTID或者(2)DHCP请求的HOSTNAME选项执行任意脚本。
        

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/h:infoblox:dns_one_appliance:2.4.0.8
cpe:/h:infoblox:dns_one_appliance:2.4.0.8a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0606
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0606
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-024
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108769996925349&w=2
(UNKNOWN)  BUGTRAQ  20040619 Script injection in DNSONE appliance
http://www.securityfocus.com/bid/10573
(VENDOR_ADVISORY)  BID  10573
http://xforce.iss.net/xforce/xfdb/16456
(VENDOR_ADVISORY)  XF  dnsone-dhcp-report-xss(16456)

- 漏洞信息

Infoblox DNS One脚本注入漏洞
中危 跨站脚本
2004-12-06 00:00:00 2005-10-20 00:00:00
远程  
        Infoblox DNS One运行固件2.4.0-8及其早期版本时存在跨站点脚本漏洞。远程攻击者像其他用户一样借助(1)CLIENTID或者(2)DHCP请求的HOSTNAME选项执行任意脚本。
        

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .
        It has been reported that this issue has been addressed in versions 2.4.0-9 and 2.4.0-9A of the device firmware. This has not been confirmed by Symantec.

- 漏洞信息

7186
Infoblox DNS One Log Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Infoblox DNS One contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate two DHCP options, HOSTNAME and CLIENTID upon receiving DHCP requests. This could allow a user to create a specially crafted request that would execute scripting code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-06-21 2004-05-28
Unknow Unknow

- 解决方案

Upgrade to version 2.4.0-9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Infoblox DNS One Script Injection Vulnerability
Input Validation Error 10573
Yes No
2004-06-19 12:00:00 2009-07-12 05:16:00
Discovery is credited to c3rb3r <c3rb3r@sympatico.ca>.

- 受影响的程序版本

Infoblox DNS One Appliance 2.4 .0-8A
Infoblox DNS One Appliance 2.4 .0-8

- 漏洞讨论

The Infoblox DNS One appliance has been reported prone to a script injection vulnerability. A remote attacker could potentially gain access to the vulnerable device or potentially execute script on the computer used to access the device. The issue is only present if the device is being used for DHCP.

- 漏洞利用

There is no exploit code required.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

It has been reported that this issue has been addressed in versions 2.4.0-9 and 2.4.0-9A of the device firmware. This has not been confirmed by Symantec.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站