CVE-2004-0604
CVSS5.0
发布时间 :2004-12-06 00:00:00
修订时间 :2008-09-05 16:38:52
NMCOS    

[原文]The HTTP client and server in giFT-FastTrack 0.8.6 and earlier allows remote attackers to cause a denial of service (crash), possibly via an empty search query, which triggers a NULL dereference.


[CNNVD]giFT-FastTrack HTTP Header Parser远程服务拒绝漏洞(CNNVD-200412-055)

        giFT-FastTrack 0.8.6及其早期版本的HTTP客户端和服务器存在漏洞。远程攻击者可能借助空搜索查询导致服务拒绝(崩溃),从而引发一个NULL取值。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gift-fasttrack:gift-fasttrack:0.8.0
cpe:/a:gift-fasttrack:gift-fasttrack:0.8.3
cpe:/a:gift-fasttrack:gift-fasttrack:0.8.2
cpe:/o:gentoo:linux:1.4Gentoo Linux 1.4
cpe:/a:gift-fasttrack:gift-fasttrack:0.8.1
cpe:/a:gift-fasttrack:gift-fasttrack:0.8.5
cpe:/a:gift-fasttrack:gift-fasttrack:0.8.6
cpe:/a:gift-fasttrack:gift-fasttrack:0.8.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0604
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0604
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-055
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16508
(VENDOR_ADVISORY)  XF  gift-fasttrack-daemon-dos(16508)
http://www.securityfocus.com/bid/10604
(VENDOR_ADVISORY)  BID  10604
http://www.gentoo.org/security/en/glsa/glsa-200406-19.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200406-19
http://secunia.com/advisories/11941/
(UNKNOWN)  SECUNIA  11941
http://gift-fasttrack.berlios.de/
(UNKNOWN)  CONFIRM  http://gift-fasttrack.berlios.de/
http://developer.berlios.de/bugs/?func=detailbug&bug_id=1573&group_id=809
(UNKNOWN)  MISC  http://developer.berlios.de/bugs/?func=detailbug&bug_id=1573&group_id=809

- 漏洞信息

giFT-FastTrack HTTP Header Parser远程服务拒绝漏洞
中危 其他
2004-12-06 00:00:00 2005-10-20 00:00:00
远程  
        giFT-FastTrack 0.8.6及其早期版本的HTTP客户端和服务器存在漏洞。远程攻击者可能借助空搜索查询导致服务拒绝(崩溃),从而引发一个NULL取值。
        

- 公告与补丁

        The vendor has released version 0.8.7 addressing this issue.
        Gentoo Linux has released advisory GLSA 200406-19 dealing with this issue. Please see the referenced advisory for further information. Users of affected packages are urged to execute the following as superuser:
         emerge sync
         emerge -pv ">=net-p2p/gift-fasttrack-0.8.7"
         emerge ">=net-p2p/gift-fasttrack-0.8.7"
        giFT-FastTrack giFT-FastTrack 0.8 .0
        
        giFT-FastTrack giFT-FastTrack 0.8.1
        
        giFT-FastTrack giFT-FastTrack 0.8.2
        
        giFT-FastTrack giFT-FastTrack 0.8.3
        
        giFT-FastTrack giFT-FastTrack 0.8.4
        
        giFT-FastTrack giFT-FastTrack 0.8.5
        
        giFT-FastTrack giFT-FastTrack 0.8.6
        

- 漏洞信息

7266
giFT-FastTrack HTTP Header Parsing DoS
Remote / Network Access Denial of Service
Loss of Availability
Exploit Unknown

- 漏洞描述

giFT-FastTrack contains a flaw that may allow a remote denial of service. The issue is triggered when a NULL pointer involving HTTP header parsing gets dereferenced, and will result in loss of availability for the service.

- 时间线

2004-06-24 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.8.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

giFT-FastTrack HTTP Header Parser Remote Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 10604
Yes No
2004-06-24 12:00:00 2009-07-12 05:16:00
Alan F. disclosed this vulnerability to the vendor.

- 受影响的程序版本

giFT-FastTrack giFT-FastTrack 0.8.6
giFT-FastTrack giFT-FastTrack 0.8.5
giFT-FastTrack giFT-FastTrack 0.8.4
giFT-FastTrack giFT-FastTrack 0.8.3
giFT-FastTrack giFT-FastTrack 0.8.2
giFT-FastTrack giFT-FastTrack 0.8.1
giFT-FastTrack giFT-FastTrack 0.8 .0
Gentoo Linux 1.4
giFT-FastTrack giFT-FastTrack 0.8.7

- 不受影响的程序版本

giFT-FastTrack giFT-FastTrack 0.8.7

- 漏洞讨论

It is reported that the giFT-FastTrack module is prone to a denial of service vulnerability in its HTTP header parser.

A remote attacker who sends malformed HTTP requests to an affected giFT server can crash the server.

The vendor has released version 0.8.7, addressing this issue. All prior versions are reported affected by this vulnerability.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has released version 0.8.7 addressing this issue.

Gentoo Linux has released advisory GLSA 200406-19 dealing with this issue. Please see the referenced advisory for further information. Users of affected packages are urged to execute the following as superuser:
emerge sync
emerge -pv ">=net-p2p/gift-fasttrack-0.8.7"
emerge ">=net-p2p/gift-fasttrack-0.8.7"


giFT-FastTrack giFT-FastTrack 0.8 .0

giFT-FastTrack giFT-FastTrack 0.8.1

giFT-FastTrack giFT-FastTrack 0.8.2

giFT-FastTrack giFT-FastTrack 0.8.3

giFT-FastTrack giFT-FastTrack 0.8.4

giFT-FastTrack giFT-FastTrack 0.8.5

giFT-FastTrack giFT-FastTrack 0.8.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站