发布时间 :2004-12-06 00:00:00
修订时间 :2008-09-05 16:38:52

[原文]gzexe in gzip 1.3.3 and earlier will execute an argument when the creation of a temp file fails instead of exiting the program, which could allow remote attackers or local users to execute arbitrary commands, a different vulnerability than CVE-1999-1332.

[CNNVD]GNU gzexe临时文件命令执行漏洞(CNNVD-200412-039)

        GNU gzexe是一个压缩可执行文件的工具。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  gzip-gzexe-tmpfile(16506)

- 漏洞信息

GNU gzexe临时文件命令执行漏洞
危急 其他
2004-12-06 00:00:00 2005-10-20 00:00:00
        GNU gzexe是一个压缩可执行文件的工具。

- 公告与补丁

        # emerge sync
        # emerge -pv ">=app-arch/gzip-1.3.3-r4"
        # emerge ">=app-arch/gzip-1.3.3-r4"

- 漏洞信息

gzip gzexe Temp File Failure Argument Handling Arbitrary Command Execution
Local Access Required Input Manipulation, Race Condition
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-06-23 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GNU gzexe Temporary File Command Execution Vulnerability
Failure to Handle Exceptional Conditions 10603
Yes Yes
2004-06-24 12:00:00 2009-07-12 05:16:00
The individual responsible for discovery of this issue is currently unknown; this issue was disclosed in the referenced Gentoo advisory.

- 受影响的程序版本

GNU gzip 1.3.3
+ Conectiva Linux 9.0
+ Gentoo Linux 1.4 _rc3
+ Gentoo Linux 1.4 _rc2

- 漏洞讨论

Reportedly gzexe is affected by a temporary file command execution vulnerability. This issue is due to a failure of the application properly handle exceptional condition when attempting to create temporary files.

This issue may allow an attacker to execute an arbitrary file in the context of an unsuspecting user; this may potentially lead to privilege escalation or unauthorized access.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Gentoo has released advisory GLSA 200406-18 dealing with this issue. It is recommended that all users using the affected software upgrade using the following sequence of commands:

# emerge sync

# emerge -pv ">=app-arch/gzip-1.3.3-r4"
# emerge ">=app-arch/gzip-1.3.3-r4"

Additionally, once the upgrade is complete, all self-extracting files created with earlier versions gzexe should be recreated, since the vulnerability is actually embedded in those executables. Please see the referenced Gentoo advisory for further information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考