发布时间 :2004-12-06 00:00:00
修订时间 :2016-10-17 22:46:15

[原文]The radius daemon (radiusd) for GNU Radius 1.1, when compiled with the -enable-snmp option, allows remote attackers to cause a denial of service (server crash) via malformed SNMP messages containing an invalid OID.

[CNNVD]GNU Radius SNMP OID远程拒绝服务漏洞(CNNVD-200412-021)

        GNU Radius是一款开放源代码远程用户验证和审计服务器。
        GNU Radius处理部分畸形SNMP消息时存在问题,远程攻击者可以利用这个漏洞对Radius服务程序进行拒绝服务攻击。
        通过提包含一个非法OID如-1的畸形SNMP包,可导致GNU Radius服务程序崩溃。不过只有带 '-enable-snmp'编译的GNU Radius才存在此漏洞。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  FULLDISC  20040621 [Full-Disclosure] iDEFENSE Security Advisory 06.21.04 - GNU Radius SNMP Invalid OID Denial of Service Vulnerability
(VENDOR_ADVISORY)  XF  radius-snmp-oid-dos(16466)

- 漏洞信息

GNU Radius SNMP OID远程拒绝服务漏洞
中危 其他
2004-12-06 00:00:00 2005-10-20 00:00:00
        GNU Radius是一款开放源代码远程用户验证和审计服务器。
        GNU Radius处理部分畸形SNMP消息时存在问题,远程攻击者可以利用这个漏洞对Radius服务程序进行拒绝服务攻击。
        通过提包含一个非法OID如-1的畸形SNMP包,可导致GNU Radius服务程序崩溃。不过只有带 '-enable-snmp'编译的GNU Radius才存在此漏洞。

- 公告与补丁

        GNU Upgrade radius-1.2.tar.gz

- 漏洞信息

GNU Radius SNMP Invalid OID DoS
Remote / Network Access Denial of Service
Loss of Availability

- 漏洞描述

GNU Radius configured with --enable-snmp contains a flaw that may allow a denial of service. The issue is triggered when an SNMP transaction is initiated with an invalid Object ID parameter, and will result in loss of availability for the service.

- 时间线

2004-06-21 2004-06-21
Unknow Unknow

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workarounds: 1. reconfigure with "--disable-snmp" 2. block SNMP traffic (default port 161 UDP) on network interfaces which could provide undesirable traffic.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GNU Radius SNMP OID Remote Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 10582
Yes No
2004-06-21 12:00:00 2009-07-12 05:16:00
The discoverer of this vulnerability wishes to remain anonymous.

- 受影响的程序版本

GNU Radius 1.1
GNU Radius 1.2

- 不受影响的程序版本

GNU Radius 1.2

- 漏洞讨论

GNU Radius is reported prone to a remote denial of service vulnerability. The issue is reported to present itself when GNU Radius handles SNMP messages that contain invalid Object ID data. It is reported that this vulnerability will exist only when the affected Radius server is compiled with the '-enable-snmp' option.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

The vendor has released GNU Radius version 1.2 to address this issue:

GNU Radius 1.1

- 相关参考