发布时间 :2004-12-23 00:00:00
修订时间 :2008-09-05 16:38:45

[原文]The tspc.conf configuration file in freenet6 before 0.9.6 and before 1.0 on Debian Linux has world readable permissions, which could allow local users to gain sensitive information, such as a username and password.


        freenet6 0.9.6以前的版本中的tspc.conf配置文件和Debian Linux1.0以前的版本拥有全域局可读权限,本地用户利用该漏洞获取敏感信息,比如:用户名和密码。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  freenet6-world-readable(17544)

- 漏洞信息

低危 配置错误
2004-12-23 00:00:00 2005-10-20 00:00:00
        freenet6 0.9.6以前的版本中的tspc.conf配置文件和Debian Linux1.0以前的版本拥有全域局可读权限,本地用户利用该漏洞获取敏感信息,比如:用户名和密码。

- 公告与补丁

        Debian has released an advisory (DSA 555-1) along with fixes dealing with this issue. Please see the referenced advisory for more information.
        Freenet6 Freenet6 0.9.6

- 漏洞信息 (F34540)

dsa-555.txt (PacketStormID:F34540)
2004-10-07 00:00:00
Simon Josefsson

Debian Security Advisory DSA 555-1 - It has been noticed that the freenet6 tspc.conf file is world readable by default, allowing a local attacker to retrieve password information.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 555-1                                        Martin Schulze
September 30th, 2004          
- --------------------------------------------------------------------------

Package        : freenet6
Vulnerability  : wrong file permissions
Problem-Type   : local
Debian-specific: yes
CVE ID         : CAN-2004-0563
Debian Bug     : 254709

Simon Josefsson noticed that the tspc.conf configuration file in
freenet6, a client to configure an IPv6 tunnel to, is set
world readable.  This file can contain the username and the password
used to contact the IPv6 tunnelbroker

For the stable distribution (woody) this problem has been fixed in
version 0.9.6-1woody2.

For the unstable distribution (sid) this problem has been fixed in
version 1.0-2.2.

We recommend that you upgrade your freenet6 package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:
      Size/MD5 checksum:      577 07d5a61effbf3748e61db855bf0afb4a
      Size/MD5 checksum:    12385 9a30a4b9420bd4949e375358f974addc
      Size/MD5 checksum:   334333 c846c0e734d93c7abdc1553781e1fa5b

  Alpha architecture:
      Size/MD5 checksum:    42380 3865b018d1808f349ade4d0d9e010af1

  ARM architecture:
      Size/MD5 checksum:    39996 a9f3b9d6b98173bdbc0173b32b602698

  Intel IA-32 architecture:
      Size/MD5 checksum:    38434 2217e61b208d1a7a0ba7aa358861946a

  Intel IA-64 architecture:
      Size/MD5 checksum:    54672 d8f7d48de839f7b117cb91da4880f1e3

  HP Precision architecture:
      Size/MD5 checksum:    39498 efb23a7b33d5c75dc12774b924f7adb7

  Motorola 680x0 architecture:
      Size/MD5 checksum:    37766 2c81680bcbd3a113e1e3f3cd08446e7c

  Big endian MIPS architecture:
      Size/MD5 checksum:    40490 0181be8c2a012f601872e02284ad22e6

  Little endian MIPS architecture:
      Size/MD5 checksum:    40538 a2f052292ddfadd2cf5f99d67e4b20fa

  PowerPC architecture:
      Size/MD5 checksum:    38578 5e0aad661c57e19ed64376ee5d59a932

  IBM S/390 architecture:
      Size/MD5 checksum:    39094 3e3f26c92e1ff8169bc5016a8215e11e

  Sun Sparc architecture:
      Size/MD5 checksum:    41458 1d3b8998d4dc533f4e6af82386e92515

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.2.5 (GNU/Linux)



- 漏洞信息

Debian Freenet6 Config File Information Disclosure
Local Access Required Information Disclosure
Loss of Confidentiality
Exploit Public Vendor Verified

- 漏洞描述

Freenet6 on Debian Woody and Sid contains a flaw that may lead to an unauthorized information disclosure.  The issue is caused by the incorrect permissions (world readable) being set on the tspc.conf file. This could be exploited to gain knowledge of the username and password for the IPv6 tunnelbroker

- 时间线

2004-09-30 Unknow
2004-09-30 Unknow

- 解决方案

Upgrade to version 0.9.6-1woody2 or higher, as it has been reported to fix this vulnerability. While a workaround is available, it is advised that all users upgrade to this version.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Freenet6 Client Default Installation Configuration File Permission Vulnerability
Configuration Error 11280
No Yes
2004-09-30 12:00:00 2009-07-12 07:06:00
The discovery of this issue is credited to Simon Josefsson.

- 受影响的程序版本

Freenet6 Freenet6 1.0
Freenet6 Freenet6 0.9.6

- 漏洞讨论

Freenet6 is affected by a default install configuration file permission vulnerability. This issue is due to a default configuration error..

An attacker may leverage this issue to steal authentication information from the configuration file that is by default set as world readable.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Debian has released an advisory (DSA 555-1) along with fixes dealing with this issue. Please see the referenced advisory for more information.

Freenet6 Freenet6 0.9.6

- 相关参考