CVE-2004-0560
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:38:45
NMCOP    

[原文]Integer overflow in gopher daemon (gopherd) 3.0.3 allows remote attackers to cause a denial of service and possibly execute arbitrary code via crafted content of a certain size that triggers the overflow.


[CNNVD]gopher daemon (gopherd)整数溢出漏洞(CNNVD-200412-296)

        gopher daemon (gopherd) 3.0.3版本存在整数溢出漏洞。远程攻击者借助触发溢出的一个特定型号的畸形内容导致服务拒绝并且可能执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0560
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0560
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-296
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2004/dsa-638
(UNKNOWN)  DEBIAN  DSA-638
http://secunia.com/advisories/13855
(UNKNOWN)  SECUNIA  13855

- 漏洞信息

gopher daemon (gopherd)整数溢出漏洞
高危 缓冲区溢出
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        gopher daemon (gopherd) 3.0.3版本存在整数溢出漏洞。远程攻击者借助触发溢出的一个特定型号的畸形内容导致服务拒绝并且可能执行任意代码。

- 公告与补丁

        

- 漏洞信息 (F35733)

dsa-638.txt (PacketStormID:F35733)
2005-01-16 00:00:00
 
advisory
linux,debian
CVE-2004-0560,CVE-2004-0561
[点击下载]

Debian Security Advisory 638-1 - jaguar has discovered two security relevant problems in gopherd, the Gopher server in Debian which is part of the gopher package.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 638-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
January 13th, 2005                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : gopher
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-0560 CAN-2004-0561

"jaguar" has discovered two security relevant problems in gopherd, the
Gopher server in Debian which is part of the gopher package.  The
Common Vulnerabilities and Exposures project identifies the following
vulnerabilities:

CAN-2004-0560

    An integer overflow can happen when posting content of a specially
    calculated size.

CAN-2004-0561

    A format string vulnerability has been found in the log routine.

For the stable distribution (woody) these problems have been fixed in
version 3.0.3woody2.

The unstable distribution (sid) does not contain a gopherd package.
It has been replaced by Pygopherd.

We recommend that you upgrade your gopherd package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/g/gopher/gopher_3.0.3woody2.dsc
      Size/MD5 checksum:      552 8ca5e42b27ee90a38e94bf9a6970c66c
    http://security.debian.org/pool/updates/main/g/gopher/gopher_3.0.3woody2.tar.gz
      Size/MD5 checksum: