发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-10 15:26:49

[原文]Buffer overflow in (1) queue.c and (2) queued.c in queue before 1.30.1 may allow remote attackers to execute arbitrary code.

[CNNVD]GNU Queue多个未明缓冲区溢出漏洞(CNNVD-200412-774)

        Queue 1.30.1之前版本中的(1)queue.c和(2)queued.c存在缓冲区溢出漏洞。远程攻击者可能可以执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gnu:queue:1.20.2GNU queue 1.20.2
cpe:/a:gnu:queue:1.20.1GNU queue 1.20.1
cpe:/a:gnu:queue:1.12.9GNU queue 1.12.9
cpe:/a:gnu:queue:1.12.7GNU queue 1.12.7
cpe:/a:gnu:queue:1.12.8GNU queue 1.12.8
cpe:/a:gnu:queue:1.20.0GNU queue 1.20.0pre3

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  XF  queue-bo(18945)

- 漏洞信息

GNU Queue多个未明缓冲区溢出漏洞
高危 缓冲区溢出
2004-12-31 00:00:00 2005-10-20 00:00:00
        Queue 1.30.1之前版本中的(1)queue.c和(2)queued.c存在缓冲区溢出漏洞。远程攻击者可能可以执行任意代码。

- 公告与补丁

        Debian has released advisory DSA 643-1 along with fixes dealing with this issue. Please see the referenced advisory for more information.
        GNU Queue 1.30.1

- 漏洞信息 (F35805)

dsa-643.txt (PacketStormID:F35805)
2005-01-19 00:00:00

Debian Security Advisory 643-1 - jaguar of the Debian Security Audit Project has discovered several buffer overflows in queue, a transparent load balancing system.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 643-1                                        Martin Schulze
January 18th, 2005            
- --------------------------------------------------------------------------

Package        : queue
Vulnerability  : buffer overflows
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-0555

"jaguar" of the Debian Security Audit Project has discovered several
buffer overflows in queue, a transparent load balancing system.

For the stable distribution (woody) these problems have been fixed in
version 1.30.1-4woody2.

For the unstable distribution (sid) these problems have been fixed in
version 1.30.1-5.

We recommend that you upgrade your queue package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:
      Size/MD5 checksum:      582 24c706e1af4baa9e8ac3dc02c8d72dce
      Size/MD5 checksum:    42917 cb036472a17be964822cd1748dff9c5f
      Size/MD5 checksum:   699770 82dd2a37f9c3d5f977afc0a990c9c648

  Alpha architecture:
      Size/MD5 checksum:   134242 cf2f009836139723d0b9eeccf6497e89

  ARM architecture:
      Size/MD5 checksum:   112840 f2ee06cf9103664ae7dd631ff9cc5173

  Intel IA-32 architecture:
      Size/MD5 checksum:   108874 777f71c6cf3136e7143094f9ba4507f7

  Intel IA-64 architecture:
      Size/MD5 checksum:   151766 caa6d74226f7ad6ebfbb50402b366693

  HP Precision architecture:
      Size/MD5 checksum:   116304 145964aa0dfd6fe42f6a67104af370a5

  Motorola 680x0 architecture:
      Size/MD5 checksum:   105868 d9035e0b49e56257444d1445b9f2b48a

  Big endian MIPS architecture:
      Size/MD5 checksum:   117588 1d67e473d49dcfc3e6b8c083976ee22a

  Little endian MIPS architecture:
      Size/MD5 checksum:   118012 721e4a42ae02098ff7acd6fbe60934c7

  PowerPC architecture:
      Size/MD5 checksum:   112670 a294d33370973324ef46a8beaf20880a

  IBM S/390 architecture:
      Size/MD5 checksum:   112492 799fe37a8371ab10c4fb78298b054b8e

  Sun Sparc architecture:
      Size/MD5 checksum:   123792 6a6685be2847e8c50c71712b80b05c2c

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.2.5 (GNU/Linux)



- 漏洞信息

GNU Queue Multiple Unspecified Overflows
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-01-18 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

GNU Queue Multiple Unspecified Buffer Overflow Vulnerabilities
Boundary Condition Error 12293
No No
2005-01-18 12:00:00 2009-07-12 10:06:00
"jaguar" is credited with the discovery of these issues.

- 受影响的程序版本

GNU Queue 1.30.1
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

Multiple unspecified buffer overflow vulnerabilities affect GNU Queue. This issue is due to a failure of the application to properly validate the length of user-supplied strings prior to copying them into static process buffers.

An attacker may leverage these issues to execute instructions with the privileges of the affected application. Although unconfirmed this may facilitate unauthorized access or privilege escalation.

This BID will be updated as more information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

Debian has released advisory DSA 643-1 along with fixes dealing with this issue. Please see the referenced advisory for more information.

GNU Queue 1.30.1

- 相关参考