CVE-2004-0547
CVSS5.0
发布时间 :2004-08-06 00:00:00
修订时间 :2008-09-10 15:26:47
NMCOS    

[原文]Buffer overflow in the ODBC driver for PostgreSQL before 7.2.1 allows remote attackers to cause a denial of service (crash).


[CNNVD]PostgreSQL ODBC Driver未明远程缓冲区溢出漏洞(CNNVD-200408-102)

        
        PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。
        PostgreSQL的ODBC驱动存在一个缓冲区溢出问题,远程攻击者可以利用这个漏洞对相关的应用程序进行拒绝服务攻击。
        利用这个问题,可以导致如使用php4-odbc的PHP脚本使的Apache WEB服务程序崩溃,不过目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0547
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0547
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-102
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2004/dsa-516
(VENDOR_ADVISORY)  DEBIAN  DSA-516
http://xforce.iss.net/xforce/xfdb/16329
(VENDOR_ADVISORY)  XF  postgresql-odbc-bo(16329)
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:072
(UNKNOWN)  MANDRAKE  MDKSA-2004:072

- 漏洞信息

PostgreSQL ODBC Driver未明远程缓冲区溢出漏洞
中危 边界条件错误
2004-08-06 00:00:00 2005-10-20 00:00:00
远程  
        
        PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。
        PostgreSQL的ODBC驱动存在一个缓冲区溢出问题,远程攻击者可以利用这个漏洞对相关的应用程序进行拒绝服务攻击。
        利用这个问题,可以导致如使用php4-odbc的PHP脚本使的Apache WEB服务程序崩溃,不过目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2004/dsa-516

- 漏洞信息

6736
PostgreSQL psqlodbc PGAPI_Connect Overflow DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown

- 漏洞描述

A remote overflow exists in psqlodbc. The "PGAPI_Connect()" function fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request containing more than 10,000 bytes, a remote attacker can cause applications which use the ODBC driver to crash resulting in a loss of availability.

- 时间线

2004-05-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 07.03.0200-3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PostgreSQL ODBC Driver Unspecified Remote Buffer Overflow Vulnerability
Boundary Condition Error 10470
Yes No
2004-06-07 12:00:00 2009-07-12 05:16:00
This issue was reported in a Debian advisory.

- 受影响的程序版本

PostgreSQL PostgreSQL 7.2.1
+ Conectiva Linux 8.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Gentoo Linux 0.7
+ Gentoo Linux 0.5

- 漏洞讨论

PostgreSQL ODBC driver is reportedly prone to a remote buffer overflow vulnerability. This vulnerability was reported in a Debian advisory and may allow a remote attacker to crash a Web server used with the application. It is reported that this issue can be exploited by using a malicious script in order to cause a denial of service condition in the Web server.

Due to a lack of details, further information is not available at the moment. This BID will be updated as more information becomes available.

PostgreSQL version 7.2.1 is confirmed to be vulnerable at the moment, however, it is likely that other versions are affected as well.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released an advisory (DSA 516-1) to address this issue. Please see the referenced advisory for more information.

Mandrake has released advisory MDKSA-2004:072 along with fixes for their Corporate Server. Please see the referenced advisory for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


PostgreSQL PostgreSQL 7.2.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站