发布时间 :2004-08-06 00:00:00
修订时间 :2016-10-17 22:45:59

[原文]Format string vulnerability in Tripwire commercial 4.0.1 and earlier, including 2.4, and open source 2.3.1 and earlier, allows local users to gain privileges via format string specifiers in a file name, which is used in the generation of an email report.

[CNNVD]Tripwire Email报告功能格式串处理漏洞(CNNVD-200408-071)

        当tripwire使用'tripwire -m c -M'产生EMAIL报告时,每一行报告会传递给pipedmailmessage.cpp文件中的fprintf()函数,如:
         fprintf(mpFile, s.c_str() );

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040602 Format String Vulnerability in Tripwire
(UNKNOWN)  BUGTRAQ  20040603 Re: Format String Vulnerability in Tripwire
(UNKNOWN)  BID  10454
(UNKNOWN)  XF  tripwire-fprintf-format-string(16309)

- 漏洞信息

Tripwire Email报告功能格式串处理漏洞
高危 输入验证
2004-08-06 00:00:00 2005-10-20 00:00:00
        当tripwire使用'tripwire -m c -M'产生EMAIL报告时,每一行报告会传递给pipedmailmessage.cpp文件中的fprintf()函数,如:
         fprintf(mpFile, s.c_str() );

- 公告与补丁

        * 可采用如下第三方补丁:
        Index: src/tripwire/pipedmailmessage.cpp
        retrieving revision 1.1
        retrieving revision 1.2
        diff -u -r1.1 -r1.2
        --- src/tripwire/pipedmailmessage.cpp 21 Jan 2001 00:46:48 -0000 1.1
        +++ src/tripwire/pipedmailmessage.cpp 26 May 2004 20:59:15 -0000 1.2
        @@ -180,7 +180,7 @@
        void cPipedMailMessage::SendString( const TSTRING& s )
        - if( _ftprintf( mpFile, s.c_str() ) < 0 )
        + if( _ftprintf( mpFile, "", s.c_str() ) < 0 )
        TOSTRINGSTREAM estr;
        estr << TSS_GetString( cTripwire,
        tripwire::STR_ERR2_MAIL_MESSAGE_COMMAND )
        MDKSA-2004:057:Updated tripwire packages fix format string vulnerability

        Updated Packages:
        Mandrakelinux 10.0:
        Corporate Server 2.1:
        Mandrakelinux 9.2:

- 漏洞信息

Tripwire Email Report Format String Arbitrary Code Execution
Local Access Required, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Tripwire contains a flaw that may allow a malicious user to execute arbitrary code. The issue is triggered when creating a file with a specially crafted filename which may be included in the email report and passed to the fprintf() function. It is possible that the flaw may allow arbitrary code execution resulting in a loss of integrity.

- 时间线

2004-06-02 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Paul Herman has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Tripwire Email Reporting Format String Vulnerability
Input Validation Error 10454
Yes No
2004-06-03 12:00:00 2009-07-12 05:16:00
Discovery of this issue is credited to Paul Herman <>.

- 受影响的程序版本

Tripwire Tripwire Open Source 2.3.1
Tripwire Tripwire Open Source 2.3 .0
Tripwire Tripwire 4.1
Tripwire Tripwire 4.0.1
Tripwire Tripwire 4.0
Tripwire Tripwire 3.0 1
Tripwire Tripwire 3.0
Tripwire Tripwire 2.4.2
Tripwire Tripwire 2.4 .0
Tripwire Tripwire 2.3.1 -2
Tripwire Tripwire 2.3.1
Tripwire Tripwire 2.3 .0
Tripwire Tripwire 2.2.1
Tripwire Tripwire do not use

- 漏洞讨论

Tripwire is affected by an email reporting format string vulnerability. This issue is due to a failure to properly inplement a formatted string function.

This vulnerability will allow for execution of arbitrary code on a system running the affected software. This would occur in the security context of the user invoking the vulnerable application; typically the superuser.

**Update - It is reported that this issue only presents itself when the MAILMETHOD is sendmail.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

Gentoo Linux has released advisory GLSA 200406-02 dealing with this issue. All tripwire users should upgrade to the latest stable version:
emerge sync
emerge -pv ">=app-admin/tripwire-"
emerge ">=app-admin/tripwire-"

Please see the referenced Gentoo Linux advisory for more information.

Mandrake advisory MDKSA-2004:057 is available. Please see the attached advisory for details on obtaining and applying fixes. Mandrake also released advisory MDKSA-2004:057-1 to provide updated fixes for Mandrake 9.2, as the previous fixes had a bug. Please see the updated advisory for details on obtaining new fixes for Mandrake 9.2.

Advisory FLSA:1719 has been released for Fedora Legacy. Please see the attached advisory for details on obtaining and applying fixes.

It has been reported that the vendor has produced a fix for the commercial version of the software.

The vendor recommends applying the workaround patch until new versions are available. Please see the referenced message from the vendor for more information.

Please see the reference section and contact the vendor for more information.

Tripwire Tripwire 2.3.1

Tripwire Tripwire 2.3.1 -2

- 相关参考