CVE-2004-0530
CVSS7.2
发布时间 :2004-08-06 00:00:00
修订时间 :2008-09-10 15:26:46
NMCO    

[原文]The PHP package in Slackware 8.1, 9.0, and 9.1, when linked against a static library, includes /tmp in the search path, which allows local users to execute arbitrary code as the PHP user by inserting shared libraries into the appropriate path.


[CNNVD]Slackware Linux PHP Packages不安全链接配置漏洞(CNNVD-200408-097)

        
        Slackware是一款开放源代码的Linux操作系统。
        Slackware Linux PHP存在一个配置错误,在链接PHP时会在不安全目录中链接共享库。
        攻击者可以利用这个漏洞把不安全库放置在不安全目录中(如/tmp),可能以PHP进程权限在系统上执行任意代码,目前没有漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0530
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0530
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-097
(官方数据源) CNNVD

- 其它链接及资源

http://www.slackware.com/security/viewer.php?l=slackware-security&y=2004&m=slackware-security.419765
(VENDOR_ADVISORY)  SLACKWARE  SSA:2004-154
http://xforce.iss.net/xforce/xfdb/16310
(UNKNOWN)  XF  linux-php-gain-privileges(16310)
http://www.securityfocus.com/bid/10461
(UNKNOWN)  BID  10461
http://secunia.com/advisories/11760
(UNKNOWN)  SECUNIA  11760

- 漏洞信息

Slackware Linux PHP Packages不安全链接配置漏洞
高危 配置错误
2004-08-06 00:00:00 2005-10-20 00:00:00
本地  
        
        Slackware是一款开放源代码的Linux操作系统。
        Slackware Linux PHP存在一个配置错误,在链接PHP时会在不安全目录中链接共享库。
        攻击者可以利用这个漏洞把不安全库放置在不安全目录中(如/tmp),可能以PHP进程权限在系统上执行任意代码,目前没有漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Slackware
        ---------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Updated package for Slackware 8.1:
        ftp://ftp.slackware.com/pub/slackware/slackware-8.1/patches/packages/php-4.3.6-i386-1.tgz
        Updated package for Slackware 9.0:
        ftp://ftp.slackware.com/pub/slackware/slackware-9.0/patches/packages/php-4.3.6-i386-1.tgz
        Updated package for Slackware 9.1:
        ftp://ftp.slackware.com/pub/slackware/slackware-9.1/patches/packages/php-4.3.6-i486-1.tgz
        Updated package for Slackware -current:
        ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/php-4.3.6-i486-4.tgz

- 漏洞信息

6589
Slackware Linux PHP Insecure Static Library Code Execution
Local Access Required Race Condition
Loss of Integrity
Exploit Unknown

- 漏洞描述

The Slackware PHP package contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is caused by linking to libraries in an insecure location (the /tmp directory). An attacker could place shared libraries in this location, and cause arbitrary code to execute as the PHP user, leading to a loss of integrity.

- 时间线

2004-06-02 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Slackware has released an updated package to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站