CVE-2004-0481
CVSS2.1
发布时间 :2005-02-23 00:00:00
修订时间 :2008-09-05 16:38:31
NMCOPS    

[原文]The logging feature in kcms_configure in the KCMS package on Solaris 8 and 9, and possibly other versions, allows local users to corrupt arbitrary files via a symlink attack on the KCS_ClogFile file.


[CNNVD]Solaris kcms_configure命令修改任意文件漏洞(CNNVD-200502-090)

        Solaris是一款商业性质的操作系统。
        Solaris kcms_configure命令存在一个安全问题,本地攻击者可以利用这个漏洞破坏系统文件。
        kcms_configure是Kodak Color管理系统的一部分,用于使用KCMS库配置X11 Window系统,kcms_configure存在一个安全问题允许本地非特权用户修改系统上的文件,导致拒绝服务或者权限提升。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:sun:solaris:9.0::sparc
cpe:/o:sun:solaris:8.2
cpe:/o:sun:solaris:8.0
cpe:/o:sun:solaris:9.0::x86
cpe:/o:sun:solaris:8.0::x86
cpe:/o:sun:solaris:8.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0481
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0481
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200502-090
(官方数据源) CNNVD

- 其它链接及资源

http://www.idefense.com/application/poi/display?id=206&type=vulnerabilities
(VENDOR_ADVISORY)  IDEFENSE  20050223 Sun Solaris kcms_configure Arbitrary File Corruption Vulnerability
http://sunsolve.sun.com/search/document.do?assetkey=1-26-57706-1
(VENDOR_ADVISORY)  SUNALERT  57706

- 漏洞信息

Solaris kcms_configure命令修改任意文件漏洞
低危 设计错误
2005-02-23 00:00:00 2005-10-20 00:00:00
本地  
        Solaris是一款商业性质的操作系统。
        Solaris kcms_configure命令存在一个安全问题,本地攻击者可以利用这个漏洞破坏系统文件。
        kcms_configure是Kodak Color管理系统的一部分,用于使用KCMS库配置X11 Window系统,kcms_configure存在一个安全问题允许本地非特权用户修改系统上的文件,导致拒绝服务或者权限提升。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://classic.sunsolve.sun.com/pub-cgi/retrieve.pl?type=0&doc=fsalert%2F57706&display=plain

- 漏洞信息 (F36321)

iDEFENSE Security Advisory 2005-02-23.t (PacketStormID:F36321)
2005-02-26 00:00:00
iDefense Labs  idefense.com
advisory,arbitrary,local
solaris
CVE-2004-0481
[点击下载]

iDEFENSE Security Advisory 02.23.05 - Local exploitation of a race condition in the Kodak Color Management System's kcms_configure script packaged with Sun Microsystems Inc. Solaris operating system can allow for the corruption of arbitrary files on the system.

Sun Solaris kcms_configure Arbitrary File Corruption Vulnerability

iDEFENSE Security Advisory 02.23.05
www.idefense.com/application/poi/display?id=206&type=vulnerabilities
February 23, 2005

I. BACKGROUND

The kcms_configure utility is part of the Kodak Color Management System
(KCMS) package that is included with Solaris.  It is installed setuid
root by default. 

II. DESCRIPTION

Local exploitation of a race condition in the Kodak Color Management
System's kcms_configure script packaged with Sun Microsystems Inc.
Solaris operating system can allow for the corruption of arbitrary files
on the system.

The problem specifically exists due to logging errors within
kcms_configure, a set user id (setuid) root script. The file
KCS_ClogFile will be written to if it exists in the current directory.
Due to a lack of sanity checking a local attacker can redirect log file
output to an arbitrary file on the system through the usage of symbolic
links. By specifying an invalid monitor profile argument the attacker
can force an error log entry to be written.

III. ANALYSIS

Successful exploitation allows local attackers to corrupt arbitrary
files on the system. Attackers can use this ability to append to
important system files, possibly resulting in a denial of service or
local privilege elevation.

IV. DETECTION

iDEFENSE has confirmed the existence of this vulnerability in Sun
Solaris versions 8 and 9. It is suspected that previous versions are
also vulnerable. It has been reported that Solaris 10 pre-release is
also vulnerable.

V. WORKAROUND

Remove the setuid bit from kcms_configure:
    
    # chmod -s /usr/openwin/bin/kcms_configure 

VI. VENDOR RESPONSE

This issue is addressed in Sun Alert ID #57706 available at:

http://www.sunsolve.sun.com/search/printfriendly.do?assetkey=1-26-57706-
1

VII. CVE INFORMATION

The Common Vulnerabilities and Exposures (CVE) project has assigned the
names CAN-2004-0481 to these issues. This is a candidate for inclusion
in the CVE list (http://cve.mitre.org), which standardizes names for
security problems.

VIII. DISCLOSURE TIMELINE

04/27/2004 	 Initial vendor notification
04/27/2004 	 Initial vendor response
02/23/2005   Public disclosure

IX. CREDIT

iDEFENSE Labs is credited with this discovery.

Get paid for vulnerability research
http://www.idefense.com/poi/teams/vcp.jsp

Free tools, research and upcoming events
http://labs.idefense.com

X. LEGAL NOTICES

Copyright (c) 2005 iDEFENSE, Inc.

Permission is granted for the redistribution of this alert
electronically. It may not be edited in any way without the express
written consent of iDEFENSE. If you wish to reprint the whole or any
part of this alert in any other medium other than electronically, please
email customerservice@idefense.com for permission.

Disclaimer: The information in the advisory is believed to be accurate
at the time of publishing based on currently available information. Use
of the information constitutes acceptance for use in an AS IS condition.
There are no warranties with regard to this information. Neither the
author nor the publisher accepts any liability for any direct, indirect,
or consequential loss or damage arising from use of, or reliance on,
this information.
    

- 漏洞信息

14035
Solaris kcms_configure Arbitrary File Manipulation

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-02-18 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Sun Solaris KCMS_Configure Arbitrary File Corruption Vulnerability
Design Error 12605
No Yes
2005-02-21 12:00:00 2009-07-12 10:56:00
Discovery of this vulnerability is credited to iDEFENSE Labs.

- 受影响的程序版本

Sun Solaris 9_x86
Sun Solaris 9
Sun Solaris 8_x86
Sun Solaris 8_sparc
Sun Solaris 7.0_x86
Sun Solaris 7.0

- 漏洞讨论

An arbitrary file corruption vulnerability is reported to exist in the kcms_configure utility. This issue is due to a design error that may allow an attacker to specify a file to be written to by a set user ID 'root' script that is included in the affected software.

An attacker may exploit this vulnerability to corrupt arbitrary files leading to a denial of service or potentially an escalation of privileges.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Sun has released an alert (57706), an updates to address this vulnerability.


Sun Solaris 7.0_x86

Sun Solaris 9_x86

Sun Solaris 7.0

Sun Solaris 8_x86

Sun Solaris 8_sparc

Sun Solaris 9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站