CVE-2004-0456
CVSS7.6
发布时间 :2004-12-06 00:00:00
修订时间 :2008-09-10 15:26:28
NMCOS    

[原文]Stack-based buffer overflow in pavuk 0.9pl28, 0.9pl27, and possibly other versions allows remote web sites to execute arbitrary code via a long HTTP Location header.


[CNNVD]Pavuk远程堆栈缓冲区溢出漏洞(CNNVD-200412-012)

        
        Pavuk是一款文件下载程序。
        Pavuk不正确处理过长的HTTP应答,远程攻击者可以利用这个漏洞以pavuk进程权限在系统上执行任意指令。
        通过恶意服务器发送超长的HTTP 305应答给pavuk程序,可导致发生基于堆栈的缓冲区溢出,精心构建应答数据可能以pavuk进程权限在系统上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.6 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:gentoo:linux:1.4:rc1Gentoo Linux 1.4 rc1
cpe:/o:gentoo:linux:1.2Gentoo Linux 1.2
cpe:/o:debian:debian_linux:3.0::hppa
cpe:/o:debian:debian_linux:3.0::mips
cpe:/o:debian:debian_linux:3.0::ia-32
cpe:/o:gentoo:linux:1.4:rc2Gentoo Linux 1.4 rc2
cpe:/o:debian:debian_linux:3.0::m68k
cpe:/o:debian:debian_linux:3.0::s-390
cpe:/o:debian:debian_linux:3.0::alpha
cpe:/o:debian:debian_linux:3.0::arm
cpe:/a:pavuk:pavuk:0.9pl28i
cpe:/o:debian:debian_linux:3.0::ia-64
cpe:/a:pavuk:pavuk:0.928r1
cpe:/o:gentoo:linux:1.4:rc3Gentoo Linux 1.4 rc3
cpe:/o:debian:debian_linux:3.0::mipsel
cpe:/o:gentoo:linux:1.1a
cpe:/o:gentoo:linux:1.4Gentoo Linux 1.4
cpe:/o:debian:debian_linux:3.0::sparc
cpe:/o:debian:debian_linux:3.0Debian Debian Linux 3.0
cpe:/o:debian:debian_linux:3.0::ppc

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0456
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0456
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-012
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16551
(VENDOR_ADVISORY)  XF  pavuk-location-bo(16551)
http://www.securityfocus.com/bid/10633
(VENDOR_ADVISORY)  BID  10633
http://www.debian.org/security/2004/dsa-527
(VENDOR_ADVISORY)  DEBIAN  DSA-527
http://security.gentoo.org/glsa/glsa-200406-22.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200406-22
http://lists.grok.org.uk/pipermail/full-disclosure/2004-July/023322.html
(UNKNOWN)  FULLDISC  20040702 pavuk buffer overflow

- 漏洞信息

Pavuk远程堆栈缓冲区溢出漏洞
高危 边界条件错误
2004-12-06 00:00:00 2005-10-20 00:00:00
远程  
        
        Pavuk是一款文件下载程序。
        Pavuk不正确处理过长的HTTP应答,远程攻击者可以利用这个漏洞以pavuk进程权限在系统上执行任意指令。
        通过恶意服务器发送超长的HTTP 305应答给pavuk程序,可导致发生基于堆栈的缓冲区溢出,精心构建应答数据可能以pavuk进程权限在系统上执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        Debian已经为此发布了一个安全公告(DSA-527-1)以及相应补丁:
        DSA-527-1:DSA-527-1 pavuk -- buffer overflow
        链接:
        http://www.debian.org/security/2004/dsa-527

        补丁下载:
        Pavuk Pavuk 0.9pl28i:
        Debian Upgrade pavuk_0.9pl28-1woody1_alpha.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_alpha.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_arm.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_arm.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_i386.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_i386.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_ia64.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_ia64.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_hppa.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_hppa.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_m68k.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_m68k.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_mips.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_mips.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_mipsel.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_mipsel.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_powerpc.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_powerpc.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_s390.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_s390.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade pavuk_0.9pl28-1woody1_sparc.deb
        
        http://security.debian.org/pool/updates/main/p/pavuk/pavuk_0.9pl28-1woody1_sparc.deb

        Debian GNU/Linux 3.0 (woody)

- 漏洞信息

11537
Pavuk Multiple Unspecified Overflows
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-11-08 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Pavuk Multiple Unspecified Remote Buffer Overflow Vulnerabilities
Boundary Condition Error 11626
Yes No
2004-11-08 12:00:00 2009-07-12 08:06:00
The vendor disclosed these issues.

- 受影响的程序版本

Pavuk Pavuk 0.9 pl30b
Pavuk Pavuk 0.9 pl28
Pavuk Pavuk 0.9pl28i
Pavuk Pavuk 0.928r2
Pavuk Pavuk 0.928r1
Gentoo Linux
Pavuk Pavuk 0.9.31

- 不受影响的程序版本

Pavuk Pavuk 0.9.31

- 漏洞讨论

Pavuk is reported prone to multiple unspecified remote buffer overflow vulnerabilities. These issue exist due to insufficient boundary checks performed by the application. A remote attacker may exploit these vulnerabilities to cause a denial of service condition or execute arbitrary code on a vulnerable computer.

In addition to these vulnerabilities, Pavuk is reported prone to other buffer overflow vulnerabilities affecting the digest authentication handler and the HTTP header processing functionality. It is likely that these issues are related to BIDS 10633 and 10797. This information cannot be confirmed at the moment. This BID will be updated as more information becomes available.

Pavuk versions 0.9pl30b and prior are affected by these vulnerabilities.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The vendor has released Pavuk Web Spider and Performance Measure 0.9.31 to address this issue.

Gentoo Linux has released advisory GLSA 200411-19 to address this issue. Users of affected packages are urged to execute the following commands with superuser privileges:
emerge --sync
emerge --ask --oneshot --verbose ">=net-misc/pavuk-0.9.31"
Please see the referenced advisory for further information.


Pavuk Pavuk 0.928r1

Pavuk Pavuk 0.9pl28i

Pavuk Pavuk 0.928r2

Pavuk Pavuk 0.9 pl30b

Pavuk Pavuk 0.9 pl28

- 相关参考

  • Home Page (Pavuk Web Spider and Performance Measure)
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站