CVE-2004-0454
CVSS7.2
发布时间 :2004-12-06 00:00:00
修订时间 :2008-09-05 16:38:28
NMCO    

[原文]Buffer overflow in the msg function for rlpr daemon (rlprd) 2.04 allows local users to execute arbitrary code.


[CNNVD]Rlpr msg()函数多个安全漏洞(CNNVD-200412-034)

        
        rlpr是一款不使用/etc/printcap的lpd打印工具。
        rlpr包含的msg()函数存在格式串和缓冲区溢出问题,本地或远程攻击者可以利用这个漏洞以rlprd进程权限执行任意指令。
        问题一是msg()调用syslog函数记录时没有进行任何过滤,提交格式串数据可能破坏内存信息。另外msg()函数对输入缺少充分缓冲区边界检查,可导致缓冲区溢出攻击。精心构建提交数据可能以rlprd进程(远程)或者root(本地)权限执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:rlpr:rlpr:2.0.3
cpe:/a:rlpr:rlpr:2.0
cpe:/a:rlpr:rlpr:2.0.4
cpe:/a:rlpr:rlpr:2.0.2
cpe:/a:rlpr:rlpr:2.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0454
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0454
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-034
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16454
(VENDOR_ADVISORY)  XF  rlpr-msg-bo(16454)
http://www.securityfocus.com/bid/10578
(VENDOR_ADVISORY)  BID  10578
http://www.debian.org/security/2004/dsa-524
(VENDOR_ADVISORY)  DEBIAN  DSA-524

- 漏洞信息

Rlpr msg()函数多个安全漏洞
高危 输入验证
2004-12-06 00:00:00 2005-10-20 00:00:00
远程  
        
        rlpr是一款不使用/etc/printcap的lpd打印工具。
        rlpr包含的msg()函数存在格式串和缓冲区溢出问题,本地或远程攻击者可以利用这个漏洞以rlprd进程权限执行任意指令。
        问题一是msg()调用syslog函数记录时没有进行任何过滤,提交格式串数据可能破坏内存信息。另外msg()函数对输入缺少充分缓冲区边界检查,可导致缓冲区溢出攻击。精心构建提交数据可能以rlprd进程(远程)或者root(本地)权限执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        rlpr rlpr 2.0 2:
        Debian Upgrade rlpr_2.02-7woody1_alpha.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_alpha.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_arm.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_arm.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_i386.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_i386.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_ia64.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_ia64.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_hppa.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_hppa.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_m68k.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_m68k.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_mips.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_mips.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_mipsel.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_mipsel.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_powerpc.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_powerpc.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_s390.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_s390.deb

        Debian GNU/Linux 3.0 (woody)
        Debian Upgrade rlpr_2.02-7woody1_sparc.deb
        
        http://security.debian.org/pool/updates/main/r/rlpr/rlpr_2.02-7woody1_sparc.deb

        Debian GNU/Linux 3.0 (woody)

- 漏洞信息

7194
rlpr msg() Overflow
Local Access Required, Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote/local overflow exists in rlpr. The msg() function fails to properly check bounds resulting in a buffer overflow. With a specially crafted request, an attacker can execute arbitrary code with the privileges of either the rlprd process or root, resulting in a loss of integrity.

- 时间线

2004-06-19 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.05 or higher, as it has been reported to fix this vulnerability. In addition, Debian has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站