CVE-2004-0450
CVSS10.0
发布时间 :2004-08-06 00:00:00
修订时间 :2008-09-05 16:38:27
NMCOP    

[原文]Format string vulnerability in the printlog function in log2mail before 0.2.5.2 allows local users or remote attackers to execute arbitrary code via format string specifiers in a logfile monitored by log2mail.


[CNNVD]Michael Krax log2mail写LOG文件格式串漏洞(CNNVD-200408-052)

        
        log2mail是一款用于监视日志文件,能通过邮件发送日志与模型匹配的工具。
        Michael Krax log2mail写日志文件存在格式串问题,远程攻击者可以利用这个漏洞以'log2mail'用户进程权权限在系统上执行任意指令。
        用户可以提供特殊消息到log2mail监视的日志文件,当log2mail进行解析转换时可发生格式串问题,默认情况下,进程以'adm'组的'log2mail'用户权限运行,精心构建提交数据可能以'adm'权限执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:log2mail:log2mail:0.2.2.2
cpe:/a:log2mail:log2mail:0.2.5.2
cpe:/a:log2mail:log2mail:0.2.5.1
cpe:/a:log2mail:log2mail:0.2.5.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0450
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0450
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-052
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10460
(VENDOR_ADVISORY)  BID  10460
http://www.debian.org/security/2004/dsa-513
(VENDOR_ADVISORY)  DEBIAN  DSA-513
http://xforce.iss.net/xforce/xfdb/16311
(UNKNOWN)  XF  log2mail-syslog-format-string(16311)
http://secunia.com/advisories/11769
(UNKNOWN)  SECUNIA  11769
http://secunia.com/advisories/11768
(UNKNOWN)  SECUNIA  11768
http://osvdb.org/6711
(UNKNOWN)  OSVDB  6711
http://felinemenace.org/~jaguar/advisories/log2mail.txt
(UNKNOWN)  MISC  http://felinemenace.org/~jaguar/advisories/log2mail.txt

- 漏洞信息

Michael Krax log2mail写LOG文件格式串漏洞
危急 未知
2004-08-06 00:00:00 2005-10-20 00:00:00
远程  
        
        log2mail是一款用于监视日志文件,能通过邮件发送日志与模型匹配的工具。
        Michael Krax log2mail写日志文件存在格式串问题,远程攻击者可以利用这个漏洞以'log2mail'用户进程权权限在系统上执行任意指令。
        用户可以提供特殊消息到log2mail监视的日志文件,当log2mail进行解析转换时可发生格式串问题,默认情况下,进程以'adm'组的'log2mail'用户权限运行,精心构建提交数据可能以'adm'权限执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2004/dsa-513

- 漏洞信息 (F33501)

dsa-513.txt (PacketStormID:F33501)
2004-06-09 00:00:00
Matt Zimmerman  debian.org
advisory,arbitrary
linux,debian
CVE-2004-0450
[点击下载]

Debian Security Advisory DSA 513-1 - Jaguar discovered a format string vulnerability in log2mail, whereby a user able to log a specially crafted message to a logfile monitored by log2mail (for example, via syslog) could cause arbitrary code to be executed with the privileges of the log2mail process. Versions below 0.2.5.2 are affected.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 513-1                     security@debian.org
http://www.debian.org/security/                             Matt Zimmerman
June 3rd, 2004                          http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : log2mail
Vulnerability  : format string
Problem-Type   : local/remote
Debian-specific: no
CVE Ids        : CAN-2004-0450

jaguar@felinemenace.org discovered a format string vulnerability in
log2mail, whereby a user able to log a specially crafted message to a
logfile monitored by log2mail (for example, via syslog) could cause
arbitrary code to be executed with the privileges of the log2mail
process.  By default, this process runs as user 'log2mail', which is a
member of group 'adm' (which has access to read system logfiles).

CAN-2004-0450: log2mail format string vulnerability via syslog(3) in
printlog()

For the current stable distribution (woody), this problem has been
fixed in version 0.2.5.2.

For the unstable distribution (sid), this problem will be fixed soon.

We recommend that you update your log2mail package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2.dsc
      Size/MD5 checksum:      483 2a1a8392e2e4ef146ad437e8d0abfd3b
    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2.tar.gz
      Size/MD5 checksum:    29532 a593de7eb31e492bcaec9f2cbf0d8c8a

  Alpha architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_alpha.deb
      Size/MD5 checksum:    70318 a09d0a7d8585c1c4845e5fe479e7d94f

  ARM architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_arm.deb
      Size/MD5 checksum:    31408 92dea5294c75b0b3befc50584de55b3a

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_i386.deb
      Size/MD5 checksum:    38750 1ac164fad7f976532b264a9ff5ea4ced

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_ia64.deb
      Size/MD5 checksum:    49242 5704ea6ac083a7f7800b2ac2df8d31db

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_hppa.deb
      Size/MD5 checksum:    44726 9946fba7d6e7d1590073413e282e5aa0

  Motorola 680x0 architecture:


    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_m68k.deb
      Size/MD5 checksum:    38700 e6ca7eefcb0adca40309075c14970877

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_mips.deb
      Size/MD5 checksum:    48576 a2a96b0be1b4a8bc83a17db7fa2a51a1

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_mipsel.deb
      Size/MD5 checksum:    47872 bcff2fb39c25c51270e0330fdafa5b87

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_powerpc.deb
      Size/MD5 checksum:    37056 2b8f844e4abf80505823c24dd1f0a7d8

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_s390.deb
      Size/MD5 checksum:    37280 86d660937516c317493412ba005ea2fb

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/l/log2mail/log2mail_0.2.5.2_sparc.deb
      Size/MD5 checksum:    34914 8ba63250986eb25923bcf1229f18bfe7

  These files will probably be moved into the stable distribution on
  its next revision.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show ' and http://packages.debian.org/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAv2lzArxCt0PiXR4RAnQAAJ0RtKmWRNOvzIM5lYCPvGpUzPt4HwCfbk/r
hTSjw5TcWHIxSatXTd87KjU=
=lhiB
-----END PGP SIGNATURE-----
    

- 漏洞信息

6711
log2mail printlog() Message Logging Format String
Local Access Required, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

log2mail contains a flaw that may allow a malicious user to execute arbitrary code on the system. This issue is due to a format string error in the "printlog()" function. By logging a crafted message via the syslog function, a local attacker can execute arbitrary code with the privilege of the log2mail process, which is typically a member of group 'adm', resulting in a loss of integrity.

- 时间线

2004-06-07 Unknow
2004-06-03 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Debian has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站