CVE-2004-0433
CVSS10.0
发布时间 :2004-08-18 00:00:00
修订时间 :2008-09-10 15:26:23
NMCOS    

[原文]Multiple buffer overflows in the Real-Time Streaming Protocol (RTSP) client for (1) MPlayer before 1.0pre4 and (2) xine lib (xine-lib) before 1-rc4, when playing Real RTSP (realrtsp) streams, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via (a) long URLs, (b) long Real server responses, or (c) long Real Data Transport (RDT) packets.


[CNNVD]MPlayer/Xine-Lib多个RealRTSP缓冲区溢出漏洞(CNNVD-200408-167)

        MPlayer 1.0pre4之前版本和(2) xine lib (xine-lib) 1-rc4之前版本中的Real-Time Streaming Protocol (RTSP)客户端存在多个缓冲区溢出漏洞。当使用Real RTSP (realrtsp)数据流时远程攻击者可以通过(a) 超长URLs, (b)超长 Real服务器响应,或者(c)超长Real Data Transport (RDT)数据包导致服务拒绝(崩溃)和可能执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:xine:xine-lib:1_rc3c
cpe:/a:xine:xine-lib:1_beta1
cpe:/a:xine:xine-lib:1_rc2
cpe:/a:xine:xine-lib:1_beta7
cpe:/a:xine:xine-lib:1_beta8
cpe:/a:xine:xine-lib:1_beta3
cpe:/a:xine:xine-lib:1_rc3a
cpe:/a:xine:xine-lib:1_beta10
cpe:/a:xine:xine-lib:1_beta2
cpe:/a:xine:xine-lib:1_beta5
cpe:/a:xine:xine-lib:1_beta4
cpe:/a:xine:xine-lib:1_beta6
cpe:/a:xine:xine-lib:1_beta9
cpe:/a:mplayer:mplayer:1.0_pre3try2
cpe:/a:xine:xine-lib:1_beta11
cpe:/a:xine:xine-lib:1_rc3b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0433
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0433
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-167
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16019
(VENDOR_ADVISORY)  XF  mplayer-rtsp-rdt-bo(16019)
http://www.xinehq.de/index.php/security/XSA-2004-3
(UNKNOWN)  CONFIRM  http://www.xinehq.de/index.php/security/XSA-2004-3
http://security.gentoo.org/glsa/glsa-200405-24.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200405-24

- 漏洞信息

MPlayer/Xine-Lib多个RealRTSP缓冲区溢出漏洞
危急 缓冲区溢出
2004-08-18 00:00:00 2005-10-20 00:00:00
远程  
        MPlayer 1.0pre4之前版本和(2) xine lib (xine-lib) 1-rc4之前版本中的Real-Time Streaming Protocol (RTSP)客户端存在多个缓冲区溢出漏洞。当使用Real RTSP (realrtsp)数据流时远程攻击者可以通过(a) 超长URLs, (b)超长 Real服务器响应,或者(c)超长Real Data Transport (RDT)数据包导致服务拒绝(崩溃)和可能执行任意代码。

- 公告与补丁

        Slackware Linux has released advisory SSA:2004-124-03 dealing with this issue. Please see the referenced advisory for more information.
        Gentoo has released advisory GLSA 200405-24 dealing with this issue. Please see the referenced advisory for more information. Gentoo users can carry out the following commands to upgrade their computers:
        # emerge sync
        # emerge -pv ">=media-video/mplayer-1.0_pre4"
        # emerge ">=media-video/mplayer-1.0_pre4"
        # emerge -pv ">=media-libs/xine-lib-1_rc4"
        # emerge ">=media-libs/xine-lib-1_rc4"
        These issues have been addressed in MPlayer 1.0pre4 and xine-lib 1-rc4.
        xine xine-lib 1-rc2
        
        xine xine-lib 1-beta7
        
        xine xine-lib 1-beta3
        
        xine xine-lib 1-rc3c
        
        xine xine-lib 1-beta10
        
        xine xine-lib 1-beta9
        
        xine xine-lib 1-beta1
        
        xine xine-lib 1-rc3a
        
        xine xine-lib 1-beta2
        
        xine xine-lib 1-beta8
        
        xine xine-lib 1-beta4
        
        xine xine-lib 1-beta11
        
        xine xine-lib 1-rc3b
        
        xine xine-lib 1-beta6
        
        xine xine-lib 1-beta5
        
        MPlayer MPlayer 1.0 pre3try2
        

- 漏洞信息

5723
MPlayer/xine-lib HTTP Parser Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-25 Unknow
Unknow Unknow

- 解决方案

Upgrade to MPlayer version 1.0pre4, xine-lib 1-rc4, or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MPlayer/Xine-Lib Multiple RealRTSP Buffer Overrun Vulnerabilities
Boundary Condition Error 10245
Yes No
2004-04-28 12:00:00 2009-07-12 04:07:00
Discovery of these issues is credited to Diego Biurrun, Roberto Togni and Miguel Freitas.

- 受影响的程序版本

xine xine-lib 1-rc3c
+ Slackware Linux 9.1
+ Slackware Linux -current
xine xine-lib 1-rc3b
xine xine-lib 1-rc3a
xine xine-lib 1-rc2
xine xine-lib 1-beta9
xine xine-lib 1-beta8
xine xine-lib 1-beta7
xine xine-lib 1-beta6
xine xine-lib 1-beta5
xine xine-lib 1-beta4
xine xine-lib 1-beta3
xine xine-lib 1-beta2
xine xine-lib 1-beta11
xine xine-lib 1-beta10
xine xine-lib 1-beta1
MPlayer MPlayer 1.0 pre3try2
xine xine-lib 1-rc4
MPlayer MPlayer 1.0 pre4

- 不受影响的程序版本

xine xine-lib 1-rc4
MPlayer MPlayer 1.0 pre4

- 漏洞讨论

Multiple buffer overruns were reported in realrtsp code shared between MPlayer and xine-lib.

One of the reported vulnerabilities may be triggered by enticing a user to request an excessively long URI from an RTSP server. Such a URI could be embedded in a playlist or possibly linked to from within a web page (if one of the players is configured as a handler for RTSP URIs).

Two more issues were also reported that could be exploited by a malicious RTSP server. One of the issues is exposed during session negotiation and the other issue is exposed when the clients receive RDT (Real Data Transfer) packets from the server.

These issues may permit remote attackers to execute arbitrary code in the context of the client user.

It should be noted that these issues are not present if support for realrtsp has been disabled.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Slackware Linux has released advisory SSA:2004-124-03 dealing with this issue. Please see the referenced advisory for more information.

Gentoo has released advisory GLSA 200405-24 dealing with this issue. Please see the referenced advisory for more information. Gentoo users can carry out the following commands to upgrade their computers:

# emerge sync
# emerge -pv ">=media-video/mplayer-1.0_pre4"
# emerge ">=media-video/mplayer-1.0_pre4"
# emerge -pv ">=media-libs/xine-lib-1_rc4"
# emerge ">=media-libs/xine-lib-1_rc4"

These issues have been addressed in MPlayer 1.0pre4 and xine-lib 1-rc4.


xine xine-lib 1-rc2

xine xine-lib 1-beta7

xine xine-lib 1-beta3

xine xine-lib 1-rc3c

xine xine-lib 1-beta10

xine xine-lib 1-beta9

xine xine-lib 1-beta1

xine xine-lib 1-rc3a

xine xine-lib 1-beta2

xine xine-lib 1-beta8

xine xine-lib 1-beta4

xine xine-lib 1-beta11

xine xine-lib 1-rc3b

xine xine-lib 1-beta6

xine xine-lib 1-beta5

MPlayer MPlayer 1.0 pre3try2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站