CVE-2004-0422
CVSS2.1
发布时间 :2004-07-07 00:00:00
修订时间 :2008-09-05 16:38:24
NMCOS    

[原文]flim before 1.14.3 creates temporary files insecurely, which allows local users to overwrite arbitrary files of the Emacs user via a symlink attack.


[CNNVD]Emacs flim库以不安全方式创建临时文件漏洞(CNNVD-200407-030)

        
        Emacs是一款功能强大的文本编辑器。
        Emacs包含的flim库在建立临时文件时没有进行正确地检查,本地攻击者可以利用这个漏洞以Emacs进程权限在系统上覆盖任意文件。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0422
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0422
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-030
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16027
(VENDOR_ADVISORY)  XF  flim-insecure-temporary-file(16027)
http://www.debian.org/security/2004/dsa-500
(VENDOR_ADVISORY)  DEBIAN  DSA-500
http://www.redhat.com/support/errata/RHSA-2004-344.html
(UNKNOWN)  REDHAT  RHSA-2004:344

- 漏洞信息

Emacs flim库以不安全方式创建临时文件漏洞
低危 竞争条件
2004-07-07 00:00:00 2005-10-20 00:00:00
本地  
        
        Emacs是一款功能强大的文本编辑器。
        Emacs包含的flim库在建立临时文件时没有进行正确地检查,本地攻击者可以利用这个漏洞以Emacs进程权限在系统上覆盖任意文件。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2004/dsa-500

- 漏洞信息

5748
FLIM Temporary File Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Loss of Integrity
Exploit Unknown

- 漏洞描述

FLIM contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when temporary files are created insecurely. This flaw may lead to a loss of integrity.

- 时间线

2004-05-01 2004-05-01
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Emacs flim Library Insecure Temporary File Creation Vulnerability
Race Condition Error 10259
No Yes
2004-05-02 12:00:00 2009-07-12 04:07:00
Discovery is credited to Tatsuya Kinoshita.

- 受影响的程序版本

Red Hat Fedora Core2
GNU Emacs 21.2
GNU Emacs 20.6
GNU Emacs 20.6
- Debian Linux 2.2
- FreeBSD FreeBSD 4.2
+ Mandriva Linux Mandrake 7.0
+ Mandriva Linux Mandrake 6.1
+ Mandriva Linux Mandrake 6.0
+ RedHat Linux 6.2 i386
GNU Emacs 20.5
GNU Emacs 20.4
GNU Emacs 20.3
GNU Emacs 20.2
GNU Emacs 20.1
GNU Emacs 20.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0

- 漏洞讨论

The Emacs flim library is prone to a symlink vulnerability. This could allow files to be overwritten with the privileges of the user running Emacs.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released an advisory (DSA 500-1) and fixes for this issue. See the referenced advisory for links to fixed packages.

RedHat has released an advisory (RHSA-2004:344-04) to address this issue in Red Hat Enterprise Linux. Please see the advisory in Web references for more information.

Red Hat has released a Fedora legacy advisory (FLSA:1581) to address this issue in flim. This advisory fixes the issue in Red Hat Linux 7.3 and 9 running on the i386 architecture. Please see the referenced advisory for more details and information about obtaining fixes.

Red Hat Fedora has released an advisory dealing with this issue for their Core 2 product. Please see the referenced advisory for more information.


Red Hat Fedora Core2

Debian Linux 3.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站