发布时间 :2004-08-06 00:00:00
修订时间 :2008-09-05 16:38:22

[原文]libsvn_ra_svn in Subversion 1.0.4 trusts the length field of (1) svn://, (2) svn+ssh://, and (3) other svn protocol URL strings, which allows remote attackers to cause a denial of service (memory consumption) and possibly execute arbitrary code via an integer overflow that leads to a heap-based buffer overflow.

[CNNVD]Subversion SVN协议解析远程整数溢出漏洞(CNNVD-200408-032)


- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:openpkg:openpkg:2.0OpenPKG 2.0

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  subversion-svn-bo(16396)
(UNKNOWN)  SUSE  SuSE-SA:2004:018
(UNKNOWN)  BUGTRAQ  20041012 [FMADV] Subversion <= 1.04 Heap Overflow

- 漏洞信息

Subversion SVN协议解析远程整数溢出漏洞
危急 边界条件错误
2004-08-06 00:00:00 2005-10-20 00:00:00

- 公告与补丁

        * 关闭svnserve服务程序使用DAV (
        Subversion Upgrade subversion-1.0.5.tar.gz

- 漏洞信息

Subversion (SVN) svnserver svn:// Protocol Handler Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote overflow exists in the Subversion libsvn_ra_svn library. svnserver fails to validate svn:// requests resulting in a heap overflow. With a specially crafted request, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2004-06-12 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Subversion SVN Protocol Parser Remote Integer Overflow Vulnerability
Boundary Condition Error 10519
Yes No
2004-06-11 12:00:00 2009-07-12 05:16:00
Discovery of this vulnerability is credited to ned <>.

- 受影响的程序版本

Subversion Subversion 1.0.4
Subversion Subversion 1.0.3
Subversion Subversion 1.0.2
Subversion Subversion 1.0.1
+ Conectiva Linux 10.0
Subversion Subversion 1.0
Subversion Subversion 0.27
+ RedHat Linux 9.0 i386
OpenPKG OpenPKG 2.0
OpenPKG OpenPKG Current
Subversion Subversion 1.0.5

- 不受影响的程序版本

Subversion Subversion 1.0.5

- 漏洞讨论

It is reported that Subversion is prone to a remote integer overrun vulnerability. The issue exists in the svn protocol parser and is due to a lack of sufficient bounds checking performed on svn URI strings that are transmitted by the client.

If the URI string recieved is long enough an integer overrun may occur where the size value of the URI string will wrap and be misrepresented. This may potentially result in corruption of heap memory management structures.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

The vendor has released version 1.0.5 addressing this issue, all users are urged to upgrade.

Gentoo Linux has released advisory GLSA 200406-07 addressing this issue. Please see the referenced advisory for further information. Affected users are urged to execute the following commands as superuser:
emerge sync
emerge -pv ">=dev-util/subversion-1.0.4-r1"
emerge ">=dev-util/subversion-1.0.4-r1"

OpenPKG has released advisory OpenPKG-SA-2004.028 addressing this issue. Please see the referenced advisory for further information.

Fedora advisories FEDORA-2004-165 and FEDORA-2004-166 are available for Fedora Core 1 and 2 respectively. Please see these advisories to obtain fixes for Fedora.

SuSE has released an advisory (SuSE-SA:2004:018) to address this issue. Please see the referenced advisory for more information.

Fedora Legacy has made advisory FLSA:1748 available dealing with this issue in RedHat Linux 9.0. Please see the referenced advisory for more information.

Subversion Subversion 0.27

Subversion Subversion 1.0

Subversion Subversion 1.0.1

Subversion Subversion 1.0.2

Subversion Subversion 1.0.3

Subversion Subversion 1.0.4

- 相关参考