CVE-2004-0400
CVSS7.5
发布时间 :2004-07-07 00:00:00
修订时间 :2008-09-10 15:26:13
NMCOS    

[原文]Stack-based buffer overflow in Exim 4 before 4.33, when the headers_check_syntax option is enabled, allows remote attackers to cause a denial of service and possibly execute arbitrary code during the header check.


[CNNVD]Exim头语法检查远程堆栈缓冲区溢出漏洞(CNNVD-200407-022)

        
        Exim是一款流行的EMAIL服务器(MTA)。
        Exim在exim.conf配置文件中设置headers_check_syntax选项时检查头时没有正确检查缓冲区边界,远程攻击者可以利用这个漏洞发送恶意邮件,诱使Exim处理,触发缓冲区溢出。
        在exim 3.35的accept.c和exim 4.32的verify.c中:
        ---
        char hname[64];
        char *t = h->text;
        char *tt = hname;
        char *verb = "is";
        int len;
        while (*t != ':') *tt++ = *t++;
        *tt = 0;
        ---
        如果exim 3.35的exim.conf文件中包含"headers_check_syntax"和exim 4.32中包含"require verify = header_syntax" 选项,由于没有对"t"限制长度,可造成缓冲区溢出,目前还不知道是否可用于执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0400
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0400
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200407-022
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16077
(VENDOR_ADVISORY)  XF  exim-headerschecksyntax-bo(16077)
http://www.guninski.com/exim1.html
(VENDOR_ADVISORY)  MISC  http://www.guninski.com/exim1.html
http://www.debian.org/security/2004/dsa-502
(VENDOR_ADVISORY)  DEBIAN  DSA-502
http://www.debian.org/security/2004/dsa-501
(VENDOR_ADVISORY)  DEBIAN  DSA-501
http://lists.grok.org.uk/pipermail/full-disclosure/2004-May/021015.html
(UNKNOWN)  FULLDISC  20040506 Buffer overflows in exim, yet still exim much better than windows

- 漏洞信息

Exim头语法检查远程堆栈缓冲区溢出漏洞
高危 边界条件错误
2004-07-07 00:00:00 2005-10-20 00:00:00
远程  
        
        Exim是一款流行的EMAIL服务器(MTA)。
        Exim在exim.conf配置文件中设置headers_check_syntax选项时检查头时没有正确检查缓冲区边界,远程攻击者可以利用这个漏洞发送恶意邮件,诱使Exim处理,触发缓冲区溢出。
        在exim 3.35的accept.c和exim 4.32的verify.c中:
        ---
        char hname[64];
        char *t = h->text;
        char *tt = hname;
        char *verb = "is";
        int len;
        while (*t != ':') *tt++ = *t++;
        *tt = 0;
        ---
        如果exim 3.35的exim.conf文件中包含"headers_check_syntax"和exim 4.32中包含"require verify = header_syntax" 选项,由于没有对"t"限制长度,可造成缓冲区溢出,目前还不知道是否可用于执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2004/dsa-502

- 漏洞信息

5897
Exim header_syntax Function Remote Overflow
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

A remote overflow exists in Exim. The issue is due to a boundary error within a routine for header syntax checking resulting in a buffer overflow. With a specially crafted request, an attacker can cause arbitrary code execution resulting in a loss of confidentiality and integrity.

- 时间线

2004-05-06 Unknow
2004-05-06 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround: Make sure you don't have the following options in the exim configuration file: For version 3.35: headers_check_syntax For version 4.32: require verify = header_syntax

- 相关参考

- 漏洞作者

- 漏洞信息

Exim Header Syntax Checking Remote Stack Buffer Overrun Vulnerability
Boundary Condition Error 10291
Yes No
2004-05-06 12:00:00 2009-07-12 04:07:00
Discovery is credited to Georgi Guninski.

- 受影响的程序版本

University of Cambridge Exim-tls 3.35
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
University of Cambridge Exim 4.32
University of Cambridge Exim 3.35
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
University of Cambridge Exim 4.32

- 不受影响的程序版本

University of Cambridge Exim 4.32

- 漏洞讨论

Exim is reportedly prone to a remotely exploitable stack-based buffer overrun vulnerability.

This issue is exposed if header syntax checking has been enabled in the agent and may be triggered by a malicious e-mail. Though not confirmed to be exploitable, if this condition were to be exploited, it would result in execution of arbitrary code in the context of the mail transfer agent. Otherwise, the agent would crash when handling malformed syntax in an e-mail message.

The issue is reported to exist in both Exim 3.35 and 4.32, though the vulnerable code exists in different source files in each of these versions.

It should be noted that the vulnerable functionality is not enabled in the default install, though some Linux/Unix distributions that ship the software may enable it.

- 漏洞利用

Proof-of-concept code that triggers a denial of service is available at the following location:
http://www.guninski.com/exim1.html

(note: there are separate proof-of-concepts for Exim 3.35 and 4.32.)

- 解决方案

Debian has released advisory DSA-501-1 dealing with this and other issues. Please see the referenced web advisory for more information and details on obtaining fixes.

Debian has released advisory DSA 502-1 dealing with this issue for their Exim-tls packages. Please see the referenced web advisory for more information and details on obtaining fixes.

Gentoo has released advisory GLSA 200405-07 dealing with this issue. They have recommended taking the following actions:

All users of Exim should upgrade to the latest stable version:

# emerge sync

# emerge -pv ">=net-mail/exim-4.33-r1"
# emerge ">=net-mail/exim-4.33-r1"

Please see the referenced advisory for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.


University of Cambridge Exim-tls 3.35

University of Cambridge Exim 3.35

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站