CVE-2004-0394
CVSS2.1
发布时间 :2004-08-18 00:00:00
修订时间 :2008-09-10 15:26:12
NMCOPS    

[原文]A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not be exploitable due to the functionality of panic.


[CNNVD]Linux Kernel panic函数调用缓冲区溢出漏洞(CNNVD-200408-150)

        Linux 2.4.x版本中的panic()函数存在“潜在的”缓冲区溢出漏洞。由于功能性恐慌该漏洞可能不被利用。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0394
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0394
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200408-150
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/15953
(VENDOR_ADVISORY)  XF  linux-panic-bo(15953)
http://www.novell.com/linux/security/advisories/2004_10_kernel.html
(UNKNOWN)  SUSE  SuSE-SA:2004:010
http://www.linuxsecurity.com/advisories/engarde_advisory-4285.html
(UNKNOWN)  ENGARDE  ESA-20040428-004
http://security.gentoo.org/glsa/glsa-200407-02.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200407-02
http://lwn.net/Articles/81773/
(UNKNOWN)  MLIST  [fedora-announce] 20040422 Fedora alert FEDORA-2004-111 (kernel)
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000846
(VENDOR_ADVISORY)  CONECTIVA  CLA-2004:846
ftp://patches.sgi.com/support/free/security/advisories/20040505-01-U.asc
(UNKNOWN)  SGI  20040505-01-U
ftp://patches.sgi.com/support/free/security/advisories/20040504-01-U.asc
(UNKNOWN)  SGI  20040504-01-U
http://www.securityfocus.com/bid/10233
(UNKNOWN)  BID  10233
http://www.mandriva.com/security/advisories?name=MDKSA-2004:037
(UNKNOWN)  MANDRAKE  MDKSA-2004:037
http://www.debian.org/security/2006/dsa-1082
(UNKNOWN)  DEBIAN  DSA-1082
http://www.debian.org/security/2006/dsa-1070
(UNKNOWN)  DEBIAN  DSA-1070
http://www.debian.org/security/2006/dsa-1069
(UNKNOWN)  DEBIAN  DSA-1069
http://www.debian.org/security/2006/dsa-1067
(UNKNOWN)  DEBIAN  DSA-1067
http://secunia.com/advisories/20338
(UNKNOWN)  SECUNIA  20338
http://secunia.com/advisories/20202
(UNKNOWN)  SECUNIA  20202
http://secunia.com/advisories/20163
(UNKNOWN)  SECUNIA  20163
http://secunia.com/advisories/20162
(UNKNOWN)  SECUNIA  20162

- 漏洞信息

Linux Kernel panic函数调用缓冲区溢出漏洞
低危 缓冲区溢出
2004-08-18 00:00:00 2005-10-20 00:00:00
本地  
        Linux 2.4.x版本中的panic()函数存在“潜在的”缓冲区溢出漏洞。由于功能性恐慌该漏洞可能不被利用。

- 公告与补丁

        Please see the referenced advisories for information on obtaining and applying the appropriate updates.
        
        SGI ProPack 2.4
        
        Linux kernel 2.4.16
        
        Linux kernel 2.4.17