CVE-2004-0361
CVSS5.0
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:44:38
NMCOES    

[原文]The Javascript engine in Safari 1.2 and earlier allows remote attackers to cause a denial of service (segmentation fault) by creating a new Array object with a large size value, then writing into that array.


[CNNVD]Apple Safari超大JavaScript阵列操作拒绝服务漏洞(CNNVD-200411-132)

        Safari 1.2及其更早版本的Javascript引擎存在漏洞。远程攻击者可以通过下述操作导致服务拒绝,创建一个新的带有超大数值的阵列对象,然后向阵列写入数据。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0361
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0361
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-132
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107861828510106&w=2
(UNKNOWN)  BUGTRAQ  20040306 Safari javascript array overflow
http://www.insecure.ws/article.php?story=2004021918172533
(UNKNOWN)  MISC  http://www.insecure.ws/article.php?story=2004021918172533
http://www.securityfocus.com/bid/9815
(VENDOR_ADVISORY)  BID  9815
http://xforce.iss.net/xforce/xfdb/15413
(VENDOR_ADVISORY)  XF  safari-array-dos(15413)

- 漏洞信息

Apple Safari超大JavaScript阵列操作拒绝服务漏洞
中危 其他
2004-11-23 00:00:00 2005-10-20 00:00:00
远程  
        Safari 1.2及其更早版本的Javascript引擎存在漏洞。远程攻击者可以通过下述操作导致服务拒绝,创建一个新的带有超大数值的阵列对象,然后向阵列写入数据。

- 公告与补丁

        Apple has released an advisory (APPLE-SA-0024-09-07) along with fixes to address this, and many other issues. Please see the referenced advisory for further information.
        Apple Mac OS X 10.2.8
        
        Apple Mac OS X Server 10.2.8
        
        Apple Mac OS X 10.3.4
        
        Apple Mac OS X Server 10.3.4
        
        Apple Mac OS X 10.3.5
        
        Apple Mac OS X Server 10.3.5
        

- 漏洞信息 (23793)

Apple Safari 1.x Large JavaScript Array Handling Denial Of Service Vulnerability (EDBID:23793)
osX dos
2004-03-06 Verified
0 kang
N/A [点击下载]
source: http://www.securityfocus.com/bid/9815/info

Apple Safari Web Browser is reported to be prone to a security vulnerability related to handling of large JavaScript arrays (with 99999999999999999999999 or 0x23000000 elements). By declaring such an array and then attempting to access it, it may be possible to cause a browser crash.

This issue is likely due to memory corruption but it is not known if it could be further exploitable to execute arbitrary code.

var a = new Array(99999999999999999999999);
a[0+5]="AAAAA";

and:
var bam = new Array(0x23000000);
bam.sort(new Function("return 1"));		

- 漏洞信息

4158
Apple Safari JavaScript Array Creation DoS
Remote / Network Access Denial of Service
Loss of Availability

- 漏洞描述

Safari contains a flaw that may allow a remote denial of service. The issue is triggered when a large javascript array object is created (with 99999999999999999999999 or 0x23000000 element) and written to or accessed in any way, and will result in loss of availability for the platform.

- 时间线

2004-03-08 2004-03-08
Unknow Unknow

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Apple Safari Large JavaScript Array Handling Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 9815
Yes No
2004-03-06 12:00:00 2009-07-12 03:06:00
Discovery is credited to kang <kang@insecure.ws>.

- 受影响的程序版本

Apple Safari 1.1
Apple Safari 1.0
+ Apple Mac OS X 10.2.8
+ Apple Mac OS X 10.2.8
+ Apple Mac OS X 10.2.7
+ Apple Mac OS X 10.2.7
+ Apple Mac OS X 10.2.6
+ Apple Mac OS X 10.2.6
+ Apple Mac OS X 10.2.5
+ Apple Mac OS X 10.2.5
+ Apple Mac OS X 10.2.4
+ Apple Mac OS X 10.2.4
+ Apple Mac OS X 10.2.3
+ Apple Mac OS X 10.2.3
+ Apple Mac OS X 10.2.2
+ Apple Mac OS X 10.2.2
+ Apple Mac OS X 10.2.1
+ Apple Mac OS X 10.2.1
+ Apple Mac OS X 10.2
+ Apple Mac OS X 10.2
+ Apple Mac OS X Server 10.2.8
+ Apple Mac OS X Server 10.2.7
+ Apple Mac OS X Server 10.2.7
+ Apple Mac OS X Server 10.2.6
+ Apple Mac OS X Server 10.2.6
+ Apple Mac OS X Server 10.2.5
+ Apple Mac OS X Server 10.2.5
+ Apple Mac OS X Server 10.2.4
+ Apple Mac OS X Server 10.2.4
+ Apple Mac OS X Server 10.2.3
+ Apple Mac OS X Server 10.2.3
+ Apple Mac OS X Server 10.2.2
+ Apple Mac OS X Server 10.2.2
+ Apple Mac OS X Server 10.2.1
+ Apple Mac OS X Server 10.2.1
+ Apple Mac OS X Server 10.2
+ Apple Mac OS X Server 10.2
Apple Safari Beta 2
Apple Mac OS X Server 10.3.5
Apple Mac OS X Server 10.3.4
Apple Mac OS X Server 10.2.8
Apple Mac OS X 10.3.5
Apple Mac OS X 10.3.4
Apple Mac OS X 10.2.8

- 漏洞讨论

Apple Safari Web Browser is reported to be prone to a security vulnerability related to handling of large JavaScript arrays (with 99999999999999999999999 or 0x23000000 elements). By declaring such an array and then attempting to access it, it may be possible to cause a browser crash.

This issue is likely due to memory corruption but it is not known if it could be further exploitable to execute arbitrary code.

- 漏洞利用

The following examples were provided:
var a = new Array(99999999999999999999999);
a[0+5]="AAAAA";

and:
var bam = new Array(0x23000000);
bam.sort(new Function("return 1"));

- 解决方案

Apple has released an advisory (APPLE-SA-0024-09-07) along with fixes to address this, and many other issues. Please see the referenced advisory for further information.


Apple Mac OS X 10.2.8

Apple Mac OS X Server 10.2.8

Apple Mac OS X 10.3.4

Apple Mac OS X Server 10.3.4

Apple Mac OS X 10.3.5

Apple Mac OS X Server 10.3.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站