CVE-2004-0349
CVSS5.0
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:44:22
NMCOES    

[原文]Directory traversal vulnerability in GWeb HTTP Server 0.6 allows remote attackers to view arbitrary files via a .. (dot dot) in the URL.


[CNNVD]GWeb HTTP服务器目录遍历漏洞(CNNVD-200411-075)

        GWeb HTTP Server 0.6存在目录遍历漏洞。远程攻击者可以借助URL中一个的..(点 点)浏览任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:gweb:gweb_http_server:0.5
cpe:/a:gweb:gweb_http_server:0.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0349
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0349
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-075
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107833161617397&w=2
(UNKNOWN)  BUGTRAQ  20040303 directory traversal in GWeb 0.6
http://www.securityfocus.com/bid/9742
(VENDOR_ADVISORY)  BID  9742
http://xforce.iss.net/xforce/xfdb/15381
(VENDOR_ADVISORY)  XF  gweb-dotdot-directory-traversal(15381)

- 漏洞信息

GWeb HTTP服务器目录遍历漏洞
中危 路径遍历
2004-11-23 00:00:00 2006-08-31 00:00:00
远程  
        GWeb HTTP Server 0.6存在目录遍历漏洞。远程攻击者可以借助URL中一个的..(点 点)浏览任意文件。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com .

- 漏洞信息 (23758)

GWeb HTTP Server 0.5/0.6 Directory Traversal Vulnerability (EDBID:23758)
windows remote
2004-02-24 Verified
0 Donato Ferrante
N/A [点击下载]
source: http://www.securityfocus.com/bid/9742/info

It has been reported that GWeb is prone to a directory traversal vulnerability. The issue is due to the server's failure to properly validate user supplied http requests.

This issue may allow an attacker to escape the web server root directory and view any web server readable files. Information acquired by exploiting this issue may be used to aid further attacks against a vulnerable system.

http://www.exploit-db.com/sploits/23758.zip		

- 漏洞信息

4136
GWeb HTTP Server Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

GWeb HTTP Server contains a flaw that allows a remote attacker to navigate outside of the web path. The issue is due to GWeb not properly sanitizing user input, specifically traversal style attacks (../../). An attacker is able to see and download all the files on the remote system simply using a browser.

- 时间线

2004-03-04 2004-03-04
2004-03-04 Unknow

- 解决方案

There is no known vendor supplied patch. Donato Ferrante has released a patch with the original advisory. Please see external reference 'Other Advisory URL' for more information.

- 相关参考

- 漏洞作者

- 漏洞信息

GWeb HTTP Server Directory Traversal Vulnerability
Input Validation Error 9742
Yes No
2004-02-24 12:00:00 2009-07-12 03:06:00
Disclosure of this issue is credited to "Donato Ferrante" <fdonato@autistici.org>.

- 受影响的程序版本

GWeb HTTP Server 0.6
GWeb HTTP Server 0.5
GameSpy Software Development Kit
+ 4D Rulers Gore
+ Activision Starfleet Command III
+ Atari Terminator 3: War Of The Machines
+ Brat Designs Breed
+ Digital Reality Haegemonia 1.0.7
+ Digital Reality Haegemonia 1.0.5
+ Digital Reality Haegemonia 1.0.4
+ Digital Reality Haegemonia 1.0
+ DreamCatcher Gore Ultimate Soldier
+ Electronic Arts Inc. Armies of Exigo
+ Electronic Arts Inc. Battlefield 1942 1.3
+ Electronic Arts Inc. Battlefield 1942 1.2
+ Electronic Arts Inc. Need For Speed: Hot Pursuit 2
+ Gearbox Software Halo Combat Evolved 1.31
+ Gearbox Software Halo Combat Evolved 1.5
+ Gearbox Software Halo Combat Evolved 1.4
+ Gearbox Software Halo Combat Evolved 1.2
+ Gearbox Software Halo Combat Evolved 1.06
+ Global Star Software Hidden & Dangerous 2
+ Illusion Softworks Hidden & Dangerous 2
+ LucasArts Star Wars Battlefront 1.11
+ LucasArts Start Wars Republic Commando
+ Microsoft Halo - Combat Evolved
+ Monolith Productions Tron 2.0 1.0
+ Pan Vision I.G.I-2 Covert Strike 1.3
+ Pan Vision I.G.I-2 Covert Strike 1.2
+ Pan Vision I.G.I-2 Covert Strike 1.1
+ Pan Vision I.G.I-2 Covert Strike 1.0
+ People can Fly Painkiller 1.3.1
+ Sierra Entertainment Contract Jack 1.1
+ Sierra Entertainment Contract Jack 1.0
+ Sierra Entertainment Men of Valor
+ Sierra Entertainment Tribes: Vengeance
+ TimeGate Studios Axis & Allies
+ TimeGate Studios Kohan II
+ Vivendi Universal Judge Dredd: Dredd vs. Death

- 漏洞讨论

It has been reported that GWeb is prone to a directory traversal vulnerability. The issue is due to the server's failure to properly validate user supplied http requests.

This issue may allow an attacker to escape the web server root directory and view any web server readable files. Information acquired by exploiting this issue may be used to aid further attacks against a vulnerable system.

- 漏洞利用

No exploit is required to leverage this issue. The following proof of concept has been provided:

http://www.example.com/../../../../../../windows/system.ini

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站