CVE-2004-0344
CVSS6.4
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:44:16
NMCOE    

[原文]Directory traversal vulnerability in ModifyMessage.php in YaBB SE 1.5.4 through 1.5.5b allows remote attackers to delete arbitrary files via a .. (dot dot) in the attachOld parameter.


[CNNVD]YABB SE多个输入验证漏洞(CNNVD-200411-080)

        
        YABB SE是一款基于PHP/MySQL的论坛程序。
        YABB SE由于不正确的输入验证,远程攻击者可以利用这些漏洞进行SQL注入和目录遍历攻击。
        SQL注入漏洞存在于ModifyMessage函数中,由于对$msg参数没有进行任何输入检查,因此可造成SQL注入攻击。造成敏感信息泄露和数据库信息删除。
        目录遍历攻击是由于ModifyMessage函数没有对用户提交给$attachOld参数包含"../"字符的数据缺少过滤,攻击者可能以WEB进程权限查看系统任意文件内容。
        

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:yabb:yabb:1.5.5b::second_edition
cpe:/a:yabb:yabb:1.5.5::second_edition

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0344
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0344
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-080
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107816202813083&w=2
(UNKNOWN)  BUGTRAQ  20040301 YabbSE (3 on 1)
http://www.securityfocus.com/bid/9774
(VENDOR_ADVISORY)  BID  9774

- 漏洞信息

YABB SE多个输入验证漏洞
中危 输入验证
2004-11-23 00:00:00 2005-10-20 00:00:00
远程  
        
        YABB SE是一款基于PHP/MySQL的论坛程序。
        YABB SE由于不正确的输入验证,远程攻击者可以利用这些漏洞进行SQL注入和目录遍历攻击。
        SQL注入漏洞存在于ModifyMessage函数中,由于对$msg参数没有进行任何输入检查,因此可造成SQL注入攻击。造成敏感信息泄露和数据库信息删除。
        目录遍历攻击是由于ModifyMessage函数没有对用户提交给$attachOld参数包含"../"字符的数据缺少过滤,攻击者可能以WEB进程权限查看系统任意文件内容。
        

- 公告与补丁

        厂商补丁:
        YaBB
        ----
        用户必须升级到SMF 1.0 Public Beta 4,另外YaBB SE由于不在支持,供应商将不提供补丁:
        
        http://www.simplemachines.org/download.php

- 漏洞信息 (23774)

YaBB SE 1.5.x Arbitrary File Deletion (EDBID:23774)
php webapps
2004-03-01 Verified
0 Alnitak and BackSpace
N/A [点击下载]
source: http://www.securityfocus.com/bid/9774/info

It has been reported that YaBB SE may be prone to multiple vulnerabilities due to improper input validation. The issues may allow an attacker to carry out SQL injection and directory traversal attacks. Successful exploitation of these issues may allow an attacker to gain access to sensitive information that may be used to mount further attacks against a vulnerable system. The SQL injection vulnerabilities can be exploited to gain access to user authentication credentials and corrupt user information in the underlying database.

YaBB SE versions 1.5.4, 1.5.5, and 1.5.5b are reported to be affected by these issues, however it is possible that other versions are vulnerable as well.

http://www.example.com/forum/index.php?board=1;action=modify2;msg=2;threadid=2;start=0;sesc=aae1f7d45d5e54c853e9e2314fb982a1;subject=hola;message=hola;waction=deletemodify;posti
d=1+or+1=1+ORDER+BY+ID_MSG+DESC/*		

- 漏洞信息

6733
YaBB SE ModifyMessage.php Arbitrary File Deletion
Remote / Network Access

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-03-01 Unknow
2004-03-01 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站