CVE-2004-0339
CVSS6.8
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:44:10
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in ViewTopic.php in phpBB, possibly 2.0.6c and earlier, allows remote attackers to execute arbitrary script or HTML as other users via the postorder parameter.


[CNNVD]PHPBB ViewTopic.PHP “postorder”跨站脚本攻击(XSS)漏洞(CNNVD-200411-155)

        phpBB可能包括2.0.6c及其更早版本中的ViewTopic.php存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助postorder参数,以其他用户的身份执行任意脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:2.0.4
cpe:/a:phpbb_group:phpbb:2.0.5
cpe:/a:phpbb_group:phpbb:2.0.2
cpe:/a:phpbb_group:phpbb:2.0.3
cpe:/a:phpbb_group:phpbb:2.0.6c
cpe:/a:phpbb_group:phpbb:2.0_rc4
cpe:/a:phpbb_group:phpbb:2.0.1
cpe:/a:phpbb_group:phpbb:2.0
cpe:/a:phpbb_group:phpbb:2.0.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0339
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0339
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-155
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107799508130700&w=2
(UNKNOWN)  BUGTRAQ  20040228 New phpBB ViewTopic.php Cross Site Scripting Vulnerability
http://www.securityfocus.com/bid/9765
(PATCH)  BID  9765
http://xforce.iss.net/xforce/xfdb/15348
(UNKNOWN)  XF  phpbb-viewtopicphp-xss(15348)

- 漏洞信息

PHPBB ViewTopic.PHP “postorder”跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2004-11-23 00:00:00 2007-01-02 00:00:00
远程  
        phpBB可能包括2.0.6c及其更早版本中的ViewTopic.php存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助postorder参数,以其他用户的身份执行任意脚本或者HTML。

- 公告与补丁

        This issue has been fixed in phpBB 2.0.7.
        phpBB Group phpBB 2.0 .0
        
        phpBB Group phpBB 2.0 RC4
        
        phpBB Group phpBB 2.0.1
        
        phpBB Group phpBB 2.0.2
        
        phpBB Group phpBB 2.0.3
        
        phpBB Group phpBB 2.0.4
        
        phpBB Group phpBB 2.0.5
        
        phpBB Group phpBB 2.0.6 c
        
        phpBB Group phpBB 2.0.6
        

- 漏洞信息

4256
phpBB viewtopic.php postorder Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "postorder" variable upon submission to the "viewtopic.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-03-01 Unknow
2004-03-01 Unknow

- 解决方案

Upgrade to version 2.0.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPBB ViewTopic.PHP "postorder" Cross-Site Scripting Vulnerability
Input Validation Error 9765
Yes No
2004-02-28 12:00:00 2009-07-12 03:06:00
Discovered by Cheng Peng Su <apple_soup@msn.com>.

- 受影响的程序版本

phpBB Group phpBB 2.0.7
phpBB Group phpBB 2.0.6 c
phpBB Group phpBB 2.0.6
phpBB Group phpBB 2.0.5
phpBB Group phpBB 2.0.4
phpBB Group phpBB 2.0.3
phpBB Group phpBB 2.0.2
phpBB Group phpBB 2.0.1
phpBB Group phpBB 2.0 .0
phpBB Group phpBB 2.0 RC4
- Apache Software Foundation Apache 1.3.9
- Apache Software Foundation Apache 1.3.9
phpBB Group phpBB 2.0.7

- 不受影响的程序版本

phpBB Group phpBB 2.0.7

- 漏洞讨论

It has been reported that one of the scripts included with phpBB is prone to a cross-site scripting vulnerability. According to the author of the report, the script "viewtopic.php" returns the value of the HTML variable "postorder" to the client as its output without encoding it or otherwise removing potentially hostile content. This can be exploited by constructing malicious links with the malicious "postorder" variable value embedded as a GET request style HTML variable. If the target user visits such a link, the malicious, externally created content supplied in the link will be rendered (or executed, in the case of script code) as part of the viewtopic.php document and within the context of the vulnerable website (including the phpBB forum).

- 漏洞利用

No exploit code is required.

- 解决方案

This issue has been fixed in phpBB 2.0.7.


phpBB Group phpBB 2.0 .0

phpBB Group phpBB 2.0 RC4

phpBB Group phpBB 2.0.1

phpBB Group phpBB 2.0.2

phpBB Group phpBB 2.0.3

phpBB Group phpBB 2.0.4

phpBB Group phpBB 2.0.5

phpBB Group phpBB 2.0.6 c

phpBB Group phpBB 2.0.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站