CVE-2004-0331
CVSS5.0
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:44:01
NMCOS    

[原文]Heap-based buffer overflow in Dell OpenManage Web Server 3.4.0 allows remote attackers to cause a denial of service (crash) via a HTTP POST with a long application variable.


[CNNVD]Dell OpenManage Web Server POST请求堆溢出漏洞(CNNVD-200411-104)

        Dell OpenManage Web Server 3.4.0存在基于堆的缓冲区溢出漏洞。远程攻击者可以借助一个带有超长应用变量的HTTP POST导致服务拒绝(崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:dell:openmanage:3.2Dell OpenManage 3.2
cpe:/a:dell:openmanage:3.7.1Dell OpenManage 3.7.1
cpe:/a:dell:openmanage:3.4Dell OpenManage 3.4
cpe:/a:dell:openmanage:3.7Dell OpenManage 3.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0331
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0331
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-104
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107781539829143&w=2
(UNKNOWN)  BUGTRAQ  20040226 Dell OpenManage Web Server Heap Overflow (Pre-Auth)
http://sh0dan.org/files/domadv.txt
(UNKNOWN)  MISC  http://sh0dan.org/files/domadv.txt
http://www.securityfocus.com/bid/9750
(VENDOR_ADVISORY)  BID  9750
http://xforce.iss.net/xforce/xfdb/15325
(VENDOR_ADVISORY)  XF  dell-openmanage-ocsgetoeminpathfile-bo(15325)

- 漏洞信息

Dell OpenManage Web Server POST请求堆溢出漏洞
中危 缓冲区溢出
2004-11-23 00:00:00 2005-10-20 00:00:00
远程  
        Dell OpenManage Web Server 3.4.0存在基于堆的缓冲区溢出漏洞。远程攻击者可以借助一个带有超长应用变量的HTTP POST导致服务拒绝(崩溃)。

- 公告与补丁

        The vendor has released patches to address this issue.
        Dell OpenManage 3.2
        
        Dell OpenManage 3.4
        
        Dell OpenManage 3.7
        
        Dell OpenManage 3.7.1
        

- 漏洞信息

4077
Dell OpenManage Web Server HTTP POST Remote Overflow
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity, Loss of Availability
Exploit Unknown

- 漏洞描述

A remote overflow exists in OpenManage. The HTTP server fails to validate certain POST requests resulting in a heap overflow. With a specially crafted request, an attacker can cause arbitrary code execution resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2004-02-26 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Dell has released a patch to address this vulnerability. The patch release title is "Systems Management: Dell OpenManage Server Administrator Updates, Patch, Multi OS, English, Multi System, v.A01, SA_Security_Patch_WIN" for the windows release, "SA_Security_Patch_LX" for the Linux release, and "SA_Security_Patch_NW" for the Netware release. The patch was released on 3/2/2004.

- 相关参考

- 漏洞作者

- 漏洞信息

Dell OpenManage Web Server POST Request Heap Overflow Vulnerability
Boundary Condition Error 9750
Yes No
2004-02-26 12:00:00 2009-07-12 03:06:00
Discovery of this vulnerability has been credited to "wirepair" <wirepair@roguemail.net>.

- 受影响的程序版本

Dell OpenManage 3.7.1
Dell OpenManage 3.7
Dell OpenManage 3.4
Dell OpenManage 3.2

- 漏洞讨论

Dell OpenManage Web Server has been reported prone to a remote heap overflow vulnerability. The issue presents itself due to a lack of sufficient bounds checks performed on POST request data.

A remote attacker may exploit this issue to corrupt heap based memory management structures located adjacent to the affected buffer.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has released patches to address this issue.


Dell OpenManage 3.2

Dell OpenManage 3.4

Dell OpenManage 3.7

Dell OpenManage 3.7.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站