CVE-2004-0301
CVSS6.8
发布时间 :2004-11-23 00:00:00
修订时间 :2008-09-05 16:38:04
NMCOE    

[原文]Cross-site scripting (XSS) vulnerability in more.php for Online Store Kit 3.0 allows remote attackers to inject arbitrary HTML via the id parameter.


[CNNVD]Ecommerce Corporation Online Store Kit more.php多个安全漏洞(CNNVD-200411-089)

        
        Ecommerce Corporation Online Store是一款基于WEB的电子购物系统。
        Online Store Kit包含的more.php脚本对用户提交的URI数据缺少充分过滤,远程攻击者可以利用这个漏洞进行SQL注入和跨站脚本攻击。
        more.php脚本对用户提交给'id'参数的数据缺少过滤,攻击者可提交SQL命令,或者恶意脚本代码给这个参数,可造成信息泄露或修改数据库信息。
        

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ecommerce_corporation_online:store_kit:3.0_lite
cpe:/a:ecommerce_corporation_online:store_kit:3.0_pro
cpe:/a:ecommerce_corporation_online:store_kit:3.0_standard

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0301
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0301
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-089
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/15235
(UNKNOWN)  XF  onlinestorekit-more-xss(15235)
http://www.systemsecure.org/advisories/ssadvisory16022004.php
(UNKNOWN)  MISC  http://www.systemsecure.org/advisories/ssadvisory16022004.php
http://www.securityfocus.com/bid/9676
(UNKNOWN)  BID  9676
http://securitytracker.com/alerts/2004/Feb/1009079.html
(UNKNOWN)  SECTRACK  1009079
http://secunia.com/advisories/10902/
(VENDOR_ADVISORY)  SECUNIA  10902

- 漏洞信息

Ecommerce Corporation Online Store Kit more.php多个安全漏洞
中危 输入验证
2004-11-23 00:00:00 2007-01-02 00:00:00
远程  
        
        Ecommerce Corporation Online Store是一款基于WEB的电子购物系统。
        Online Store Kit包含的more.php脚本对用户提交的URI数据缺少充分过滤,远程攻击者可以利用这个漏洞进行SQL注入和跨站脚本攻击。
        more.php脚本对用户提交给'id'参数的数据缺少过滤,攻击者可提交SQL命令,或者恶意脚本代码给这个参数,可造成信息泄露或修改数据库信息。
        

- 公告与补丁

        厂商补丁:
        Ecommerce Corporation
        ---------------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.ecommerce.com/

- 漏洞信息 (23712)

Ecommerce Corporation Online Store Kit 3.0 More.PHP XSS (EDBID:23712)
php webapps
2003-02-17 Verified
0 David Sopas Ferreira
N/A [点击下载]
source: http://www.securityfocus.com/bid/9676/info
 
Multiple vulnerabilities have been identified in the software due to improper sanitization of user-supplied input. Successful exploitation of these issues could allow an attacker to carry out cross-site scripting and SQL injection attacks via the 'id' parameter of 'more.php' script.
 
Online Store Kit version 3.0 has been reported to be prone to these issues.

more.php?id=%3Cscript%3Ealert(document.domain);%3C/script%3E&

		

- 漏洞信息

4538
Online Store Kit SQL more.php XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Online Shopping Kit contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "id" variable upon submission to the more.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-02-17 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站