发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:43:06

[原文]Mailmgr 1.2.3 allows local users to overwrite arbitrary files via a symlink attack on (1) /tmp/mailmgr.unsort, (2) /tmp/mailmgr.tmp, or (3) /tmp/mailmgr.sort.



- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040212 Symlink vulnerabilities in mailmgr
(VENDOR_ADVISORY)  XF  mailmgr-insecure-temp-directory (15203)

- 漏洞信息

低危 配置错误
2004-11-23 00:00:00 2005-10-20 00:00:00

- 公告与补丁


- 漏洞信息

Mailmgr Multiple Script Symlink Arbitrary File Overwrite
Local Access Required Race Condition
Loss of Integrity
Exploit Public

- 漏洞描述

Mailmgr contains a flaw that may allow a malicious local user to manipulate arbitrary files on the system. The issue is due to the program creating the 'mailmgr.unsort', 'mailmgr.tmp' and 'mailmgr.sort' files insecurely in the /tmp directory. It is possible for a user to use a symlink style attack to manipulate arbitrary files, resulting in a loss of integrity.

- 时间线

2004-02-12 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround(s): Use the temporary_dir directive in /usr/local/etc/mailmgr.conf to point to a directory that does not have a sticky bit set.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Mailmgr Insecure Temporary File Creation Vulnerabilities
Configuration Error 9654
No Yes
2004-02-12 12:00:00 2009-07-12 02:06:00
Discovery is credited to Marco van Berkum.

- 受影响的程序版本

Mailmgr Mailmgr 1.2.3

- 漏洞讨论

Mailmgr is reportedly to be prone to a vulnerability related to temporary file handling. The specific issue is that a number of temporary files are created in an insecure manner, potentially providing malicious local users with an opportunity to launch symbolic link attacks and cause files to be corrupted (in the context of the user invoking the software). This would most likely result in a denial of service but could also allow for privilege escalation, though this has not been confirmed.

This issue was reported to exist in Mailmgr 1.2.3. Other versions are also likely affected.

- 漏洞利用

There is no exploit required.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考