CVE-2004-0263
CVSS5.0
发布时间 :2004-11-23 00:00:00
修订时间 :2013-11-01 21:26:04
NMCO    

[原文]PHP 4.3.4 and earlier in Apache 1.x and 2.x (mod_php) can leak global variables between virtual hosts that are handled by the same Apache child process but have different settings, which could allow remote attackers to obtain sensitive information.


[CNNVD]Apache mod_php全局变量信息泄露漏洞(CNNVD-200411-079)

        
        Apache mod_php是用于解析PHP的Apache模块。
        Apache mod_php在部分设置的情况下存在问题,远程攻击者可以利用这个漏洞获得敏感信息。
        如果服务器配置文件"php.ini"设置"register_globals = on",及提交一个请求给虚拟主机(虚拟主机包含"php_admin_flag register_globals off"设置),如果下一个请求通过相同apache子进程发送给其他的虚拟主机(此虚拟主机没有任何设置),那么服务器部分设置就会泄露。
        根据服务器和站点配置,攻击者可能获得全局变量信息,如MySQL密码等。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ibm:http_server:1.3.19IBM IBM HTTP Server 1.3.19
cpe:/a:apache:http_server:1.3Apache Software Foundation Apache HTTP Server 1.3
cpe:/a:apache:http_server:1.3.9Apache Software Foundation Apache HTTP Server 1.3.9
cpe:/a:apache:http_server:1.0Apache Software Foundation Apache HTTP Server 1.0
cpe:/a:apache:http_server:1.2Apache Software Foundation Apache 1.2
cpe:/a:apache:http_server:1.3.18Apache Software Foundation Apache HTTP Server 1.3.18
cpe:/a:apache:http_server:1.1Apache Software Foundation Apache HTTP Server 1.1
cpe:/a:apache:http_server:1.3.17Apache Software Foundation Apache HTTP Server 1.3.17
cpe:/a:apache:http_server:1.3.12Apache Software Foundation Apache HTTP Server 1.3.12
cpe:/a:apache:http_server:1.3.11Apache Software Foundation Apache HTTP Server 1.3.11
cpe:/a:apache:http_server:1.3.14Apache Software Foundation Apache HTTP Server 1.3.14
cpe:/a:apache:http_server:1.3.1Apache Software Foundation Apache HTTP Server 1.3.1
cpe:/a:apache:http_server:1.2.5Apache Software Foundation Apache HTTP Server 1.2.5
cpe:/a:apache:http_server:1.3.6Apache Software Foundation Apache HTTP Server 1.3.6
cpe:/a:apache:http_server:1.3.3Apache Software Foundation Apache HTTP Server 1.3.3
cpe:/a:apache:http_server:2.0.28:betaApache Software Foundation Apache HTTP Server 2.0.28 Beta
cpe:/a:apache:http_server:1.3.20Apache Software Foundation Apache HTTP Server 1.3.20
cpe:/a:apache:http_server:1.3.29Apache Software Foundation Apache HTTP Server 1.3.29
cpe:/a:apache:http_server:1.3.26Apache Software Foundation Apache HTTP Server 1.3.26
cpe:/a:apache:http_server:1.3.27Apache Software Foundation Apache HTTP Server 1.3.27
cpe:/a:apache:http_server:1.3.22Apache Software Foundation Apache HTTP Server 1.3.22
cpe:/a:apache:http_server:1.3.25Apache Software Foundation Apache HTTP Server 1.3.25
cpe:/a:apache:http_server:1.3.28Apache Software Foundation Apache HTTP Server 1.3.28
cpe:/a:apache:http_server:1.3.23Apache Software Foundation Apache HTTP Server 1.3.23
cpe:/a:apache:http_server:1.3.24Apache Software Foundation Apache HTTP Server 1.3.24
cpe:/a:apache:http_server:1.3.4Apache Software Foundation Apache HTTP Server 1.3.4
cpe:/a:apache:http_server:2.0.39Apache Software Foundation Apache HTTP Server 2.0.39
cpe:/a:apache:http_server:2.0.9Apache Software Foundation Apache HTTP Server 2.0.9a
cpe:/a:apache:http_server:1.1.1Apache Software Foundation Apache HTTP Server 1.1.1
cpe:/a:apache:http_server:2.0.41Apache Software Foundation Apache HTTP Server 2.0.41
cpe:/a:apache:http_server:1.0.3Apache Software Foundation Apache HTTP Server 1.0.3
cpe:/a:apache:http_server:2.0.40Apache Software Foundation Apache HTTP Server 2.0.40
cpe:/a:apache:http_server:1.0.5Apache Software Foundation Apache HTTP Server 1.0.5
cpe:/a:apache:http_server:2.0.46Apache Software Foundation Apache HTTP Server 2.0.46
cpe:/a:apache:http_server:2.0.47Apache Software Foundation Apache HTTP Server 2.0.47
cpe:/a:apache:http_server:2.0.45Apache Software Foundation Apache HTTP Server 2.0.45
cpe:/a:apache:http_server:2.0.42Apache Software Foundation Apache HTTP Server 2.0.42
cpe:/a:apache:http_server:2.0.43Apache Software Foundation Apache HTTP Server 2.0.43
cpe:/a:apache:http_server:2.0.48Apache Software Foundation Apache HTTP Server 2.0.48
cpe:/a:apache:http_server:1.3.19Apache Software Foundation Apache HTTP Server 1.3.19
cpe:/a:apache:http_server:2.0.44Apache Software Foundation Apache HTTP Server 2.0.44
cpe:/a:apache:http_server:2.0.28Apache Software Foundation Apache HTTP Server 2.0.28
cpe:/a:apache:http_server:1.0.2Apache Software Foundation Apache HTTP Server 1.0.2
cpe:/a:apache:http_server:2.0Apache Software Foundation Apache HTTP Server 2.0
cpe:/a:apache:http_server:2.0.36Apache Software Foundation Apache HTTP Server 2.0.36
cpe:/a:apache:http_server:2.0.35Apache Software Foundation Apache HTTP Server 2.0.35
cpe:/a:apache:http_server:2.0.38Apache Software Foundation Apache HTTP Server 2.0.38
cpe:/a:apache:http_server:2.0.32Apache Software Foundation Apache HTTP Server 2.0.32
cpe:/a:apache:http_server:2.0.37Apache Software Foundation Apache HTTP Server 2.0.37
cpe:/a:apache:http_server:1.3.7::dev

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0263
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0263
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-079
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/15072
(VENDOR_ADVISORY)  XF  php-virtualhost-info-disclosure(15072)
http://www.securityfocus.com/bid/9599
(VENDOR_ADVISORY)  BID  9599
http://security.gentoo.org/glsa/glsa-200402-01.xml
(UNKNOWN)  GENTOO  GLSA-200402-01
http://www.osvdb.org/3878
(UNKNOWN)  OSVDB  3878

- 漏洞信息

Apache mod_php全局变量信息泄露漏洞
中危 未知
2004-11-23 00:00:00 2006-08-31 00:00:00
远程  
        
        Apache mod_php是用于解析PHP的Apache模块。
        Apache mod_php在部分设置的情况下存在问题,远程攻击者可以利用这个漏洞获得敏感信息。
        如果服务器配置文件"php.ini"设置"register_globals = on",及提交一个请求给虚拟主机(虚拟主机包含"php_admin_flag register_globals off"设置),如果下一个请求通过相同apache子进程发送给其他的虚拟主机(此虚拟主机没有任何设置),那么服务器部分设置就会泄露。
        根据服务器和站点配置,攻击者可能获得全局变量信息,如MySQL密码等。
        

- 公告与补丁

        厂商补丁:
        Apache Software Foundation
        --------------------------
        Gentoo Linux建议升级到mode_php 4.3.4-r4版本:
        执行如下命令:
        # emerge sync
        # emerge -pv ">=dev-php/mod_php-4.3.4-r4"
        # emerge ">=dev-php/mod_php-4.3.4-r4"

- 漏洞信息

3878
PHP Virtual Host Configuration Information Disclosure
Remote / Network Access Authentication Management, Information Disclosure
Loss of Confidentiality

- 漏洞描述

PHP contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when multiple virtual hosts are served from an Apache server, and the same child process is used to access different virtual hosts, which will leak settings between virtual hosts resulting in a loss of confidentiality.

- 时间线

2004-01-27 2003-10-04
Unknow Unknow

- 解决方案

Upgrade to version 4.3.5RC2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站