CVE-2004-0257
CVSS5.0
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:42:34
NMCO    

[原文]OpenBSD 3.4 and NetBSD 1.6 and 1.6.1 allow remote attackers to cause a denial of service (crash) by sending an IPv6 packet with a small MTU to a listening port and then issuing a TCP connect to that port.


[CNNVD]OpenBSD ICMPV6处理远程拒绝服务攻击漏洞(CNNVD-200411-114)

        
        OpenBSD是一款开放源代码操作系统。
        OpenBSD在处理部分ICMPV6通信时存在问题,远程攻击者可以利用这个漏洞对主机系统进行拒绝服务攻击。
        如果OpenBSD系统配置为能接收icmpv6通信,就可能存在拒绝服务攻击,通过设置小的ipv6 mtu,然后进行tcp连接,就可以导致目标OpenBSD崩溃。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/o:openbsd:openbsd:3.4OpenBSD 3.4
cpe:/o:netbsd:netbsd:1.6.1NetBSD 1.6.1
cpe:/o:openbsd:openbsd:3.3OpenBSD 3.3
cpe:/o:netbsd:netbsd:1.6NetBSD 1.6
cpe:/o:openbsd:openbsd:3.0OpenBSD 3.0
cpe:/o:openbsd:openbsd:3.2OpenBSD 3.2
cpe:/o:openbsd:openbsd:3.1OpenBSD 3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0257
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0257
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-114
(官方数据源) CNNVD

- 其它链接及资源

ftp://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2004-002.txt.asc
(UNKNOWN)  NETBSD  NetBSD-SA2004-002
http://lists.grok.org.uk/pipermail/full-disclosure/2004-February/016704.html
(UNKNOWN)  FULLDISC  20040204 Remote openbsd crash with ip6, yet still openbsd much better than windows
http://marc.info/?l=bugtraq&m=107604603226564&w=2
(UNKNOWN)  BUGTRAQ  20040205 OpenBSD IPv6 remote kernel crash
http://www.guninski.com/obsdmtu.html
(UNKNOWN)  MISC  http://www.guninski.com/obsdmtu.html
http://www.openbsd.org/cgi-bin/cvsweb/src/sys/netinet6/ip6_output.c
(UNKNOWN)  CONFIRM  http://www.openbsd.org/cgi-bin/cvsweb/src/sys/netinet6/ip6_output.c
http://www.securityfocus.com/bid/9577
(VENDOR_ADVISORY)  BID  9577
http://xforce.iss.net/xforce/xfdb/15044
(VENDOR_ADVISORY)  XF  openbsd-ipv6-dos(15044)

- 漏洞信息

OpenBSD ICMPV6处理远程拒绝服务攻击漏洞
中危 未知
2004-11-23 00:00:00 2005-05-13 00:00:00
远程  
        
        OpenBSD是一款开放源代码操作系统。
        OpenBSD在处理部分ICMPV6通信时存在问题,远程攻击者可以利用这个漏洞对主机系统进行拒绝服务攻击。
        如果OpenBSD系统配置为能接收icmpv6通信,就可能存在拒绝服务攻击,通过设置小的ipv6 mtu,然后进行tcp连接,就可以导致目标OpenBSD崩溃。
        

- 公告与补丁

        厂商补丁:
        OpenBSD
        -------
        用户可以从CVS中下载修正版本为1.82的/src/sys/netinet6/ip6_output.c文件,然后重新编译内核。
        供应商已经发布OpenBSD 3.4-stable和3.3-stable的补丁,建议用户升级:
        
        http://www.openbsd.org/

- 漏洞信息

3825
Multiple BSD IPv6 Traffic Handling DoS
Remote / Network Access Denial of Service
Loss of Availability

- 漏洞描述

OpenBSD contains a flaw that may allow a remote denial of service. The issue is triggered when a combination of specially crafted IPv6 packets are sent, and will result in loss of availability for the platform.

- 时间线

2004-02-04 2004-02-01
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, OpenBSD has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站