CVE-2004-0250
CVSS10.0
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:42:27
NMCO    

[原文]SQL injection vulnerability in PhotoPost PHP Pro 4.6 and earlier allows remote attackers to gain privileges via (1) the product parameter in showproduct.php or (2) the cat parameter in showcat.php.


[CNNVD]所有Enthusiast Photopost PHP Pro SQL注入漏洞(CNNVD-200411-064)

        PhotoPost PHP Pro 4.6及其之前的版本存在SQL注入漏洞。远程攻击者可以借助以下参数获取权限(1)showproduct.php的product参数,或者(2)showcat.php的cat参数。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:photopost:photopost_php_pro:3.3
cpe:/a:photopost:photopost_php_pro:4.6
cpe:/a:photopost:photopost_php_pro:3.1
cpe:/a:photopost:photopost_php_pro:4.0
cpe:/a:photopost:photopost_php_pro:3.2
cpe:/a:photopost:photopost_php_pro:4.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0250
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0250
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-064
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107593114909696&w=2
(UNKNOWN)  BUGTRAQ  20040204 ZH2004-04SA (security advisory): Multiple Sql Injection
http://www.securityfocus.com/bid/9557
(VENDOR_ADVISORY)  BID  9557
http://www.zone-h.org/en/advisories/read/id=3864/
(UNKNOWN)  MISC  http://www.zone-h.org/en/advisories/read/id=3864/
http://xforce.iss.net/xforce/xfdb/15008
(VENDOR_ADVISORY)  XF  photopostphp-sql-injection(15008)

- 漏洞信息

所有Enthusiast Photopost PHP Pro SQL注入漏洞
危急 SQL注入
2004-11-23 00:00:00 2006-09-27 00:00:00
远程  
        PhotoPost PHP Pro 4.6及其之前的版本存在SQL注入漏洞。远程攻击者可以借助以下参数获取权限(1)showproduct.php的product参数,或者(2)showcat.php的cat参数。

- 公告与补丁

        The vendor has released a patch to address this issue. Users are advised to contact the vendor in order to obtain the patch.

- 漏洞信息

15444
PhotoPost PHP Pro showproduct.php product Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Patch / RCS

- 漏洞描述

PhotoPost PHP Pro contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'showproduct.php' script not properly sanitizing user-supplied input to the 'product' parameter. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2004-02-04 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, the vendor has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站