CVE-2004-0248
CVSS6.8
发布时间 :2004-11-23 00:00:00
修订时间 :2016-10-17 22:42:24
NMCOS    

[原文]Cross-site scripting vulnerability (XSS) in PHPX 3.2.3 allows remote attackers to execute arbitrary script as other users by injecting arbitrary HTML or script into (1) keywords argument of main.inc.php, (2) body argument of help.inc.php, or (3) the subject field in Personal Messages and Forum.


[CNNVD]PHPX多个漏洞(CNNVD-200411-151)

        PHPX 3.2.3存在跨站脚本攻击(XSS)漏洞。远程攻击者可以用其他用户的身份,通过向(1)main.inc.php的keywords参数,(2)help.inc.php的body参数,或者(3)Personal Messages和Forum的subject字段注入任意HTML或者脚本执行任意脚本。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0248
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0248
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200411-151
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107586932324901&w=2
(UNKNOWN)  BUGTRAQ  20040203 Multiple Vulnerabilities in PHPX
http://www.securityfocus.com/bid/9569
(PATCH)  BID  9569
http://xforce.iss.net/xforce/xfdb/15050
(PATCH)  XF  phpx-subject-html-injection(15050)
http://xforce.iss.net/xforce/xfdb/15051
(PATCH)  XF  phpx-main-help-xss(15051)

- 漏洞信息

PHPX多个漏洞
中危 跨站脚本
2004-11-23 00:00:00 2007-01-02 00:00:00
远程  
        PHPX 3.2.3存在跨站脚本攻击(XSS)漏洞。远程攻击者可以用其他用户的身份,通过向(1)main.inc.php的keywords参数,(2)help.inc.php的body参数,或者(3)Personal Messages和Forum的subject字段注入任意HTML或者脚本执行任意脚本。

- 公告与补丁

        These issues are addressed in PHPX 3.2.4.
        PHPX PHPX 3.2.3
        

- 漏洞信息

3829
PHPX Subject HTML Injection

- 漏洞描述

PHPX contains a flaw that allows a remote HTML code injection. This flaw exists because the application does not validate subject variables in Personal Messages and Forum. This could allow a user to embed a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-02-03 2004-02-03
Unknow Unknow

- 解决方案

Upgrade to version 3.2.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHPX Multiple Vulnerabilities
Input Validation Error 9569
Yes No
2004-02-03 12:00:00 2009-07-12 02:06:00
Discovery is credited to Manuel L?pez.

- 受影响的程序版本

PHPX PHPX 3.2.3
PHPX PHPX 3.2.4

- 不受影响的程序版本

PHPX PHPX 3.2.4

- 漏洞讨论

Multiple vulnerabilities were reported in PHPX. The specific issues include cross-site scripting, HTML injection and account hijacking via specially crafted cookies.

These issues were reported to exist in PHPX 3.2.3. Earlier versions are also likely affected.

- 漏洞利用

There is no exploit required for these issues. The following cross-site scripting examples were provided:

main.inc.php?keywords='><script>alert(document.cookie)</script>
help.inc.php?body='><script>alert(document.cookie)</script>

The following proof of concept has been provided by Ryan Wray for the insecure session id issue:

- 解决方案

These issues are addressed in PHPX 3.2.4.


PHPX PHPX 3.2.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站