CVE-2004-0197
CVSS7.5
发布时间 :2004-06-01 00:00:00
修订时间 :2008-09-10 15:25:28
NMCOS    

[原文]Buffer overflow in Microsoft Jet Database Engine 4.0 allows remote attackers to execute arbitrary code via a specially-crafted database query.


[CNNVD]Microsoft Jet数据库引擎远程任意指令漏洞(MS04-014)(CNNVD-200406-017)

        
        MS Jet Database Engine是微软开发的数据库引擎。
        Microsoft Jet Database Engine (Jet)存在远程缓冲区溢出,远程攻击者可以利用这个漏洞进行安装程序,更改删除数据,建立帐户等恶意攻击。
        目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:968MS Jet Database Buffer Overflow
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0197
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0197
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200406-017
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/740716
(UNKNOWN)  CERT-VN  VU#740716
http://www.us-cert.gov/cas/techalerts/TA04-104A.html
(UNKNOWN)  CERT  TA04-104A
http://xforce.iss.net/xforce/xfdb/15703
(UNKNOWN)  XF  msjet-query-execute-code(15703)
http://www.securityfocus.com/bid/10112
(UNKNOWN)  BID  10112
http://www.microsoft.com/technet/security/bulletin/ms04-014.asp
(UNKNOWN)  MS  MS04-014

- 漏洞信息

Microsoft Jet数据库引擎远程任意指令漏洞(MS04-014)
高危 未知
2004-06-01 00:00:00 2005-10-20 00:00:00
远程  
        
        MS Jet Database Engine是微软开发的数据库引擎。
        Microsoft Jet Database Engine (Jet)存在远程缓冲区溢出,远程攻击者可以利用这个漏洞进行安装程序,更改删除数据,建立帐户等恶意攻击。
        目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        Microsoft
        ---------
        Microsoft已经为此发布了一个安全公告(MS04-014)以及相应补丁:
        MS04-014:Vulnerability in the Microsoft Jet Database Engine Could Allow Code Execution (837001)
        链接:
        http://www.microsoft.com/technet/security/bulletin/MS04-014.mspx

        补丁下载:
        Microsoft Windows NT? Workstation 4.0 Service Pack 6a
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=7678462A-52EC-48D5-9AEB-46EC4CC053C7&displaylang=en

        Microsoft Windows NT Server 4.0 Service Pack 6a
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=7678462A-52EC-48D5-9AEB-46EC4CC053C7&displaylang=en

        Microsoft Windows NT Server 4.0 Terminal Server Edition Service Pack 6
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=7678462A-52EC-48D5-9AEB-46EC4CC053C7&displaylang=en

        Microsoft Windows 2000 Service Pack 2, Microsoft Windows 2000 Service Pack 3, and Microsoft Windows 2000 Service Pack 4
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=5813346A-7EC2-4F57-A199-8375DA0AD816&displaylang=en

        Microsoft Windows XP and Microsoft Windows XP Service Pack 1
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=EA17D1CB-075E-4B63-BC45-06EBBF41C6B5&displaylang=en

        
        Microsoft Windows XP 64-Bit Edition Service Pack 1
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=B487610D-806C-4289-BE70-92F7D2337E17&displaylang=en

        
        Microsoft Windows XP 64-Bit Edition Version 2003
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=E4E0EB80-7395-4C07-BC1D-B187DE541BC2&displaylang=en

        
        Microsoft Windows Server 2003
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=216D708B-3A55-4B50-8AD2-BFF06B668CBB&displaylang=en

        
        Microsoft Windows Server 2003 64-Bit Edition
        
        http://www.microsoft.com/downloads/details.aspx?FamilyId=E4E0EB80-7395-4C07-BC1D-B187DE541BC2&displaylang=en

- 漏洞信息

5241
Microsoft Jet Database Engine Remote Code Execution
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

The Microsoft Jet Database Engine contains a flaw that may allow a malicious user to execute code. The issue is triggered when a specially crafted query is issued. It is possible that the flaw may allow remote code execution resulting in a loss of confidentiality and integrity.

- 时间线

2004-04-13 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Microsoft has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Microsoft Jet Database Engine Remote Code Execution Vulnerability
Unknown 10112
Yes No
2004-04-13 12:00:00 2009-07-12 04:06:00
Discovery is credited to Matt Thompson of Aberdeen IT <http://www.aberdeenit.com/>.

- 受影响的程序版本

Microsoft Windows XP Professional SP1
Microsoft Windows XP Home SP1
Microsoft Windows XP 64-bit Edition Version 2003 SP1
Microsoft Windows XP 64-bit Edition Version 2003
Microsoft Windows XP 64-bit Edition SP1
Microsoft Windows Server 2003 Web Edition
Microsoft Windows Server 2003 Standard Edition
Microsoft Windows Server 2003 Enterprise Edition Itanium 0
Microsoft Windows Server 2003 Enterprise Edition
Microsoft Windows Server 2003 Datacenter Edition Itanium 0
Microsoft Windows Server 2003 Datacenter Edition
Microsoft Windows NT Workstation 4.0 SP6a
Microsoft Windows NT Terminal Server 4.0 SP6
Microsoft Windows NT Server 4.0 SP6a
+ Avaya DefinityOne Media Servers
+ Avaya DefinityOne Media Servers
+ Avaya IP600 Media Servers
+ Avaya IP600 Media Servers
+ Avaya S3400 Message Application Server 0
+ Avaya S8100 Media Servers 0
+ Avaya S8100 Media Servers 0
Microsoft Windows 2000 Server SP4
Microsoft Windows 2000 Server SP3
Microsoft Windows 2000 Server SP2
Microsoft Windows 2000 Professional SP4
Microsoft Windows 2000 Professional SP3
Microsoft Windows 2000 Professional SP2
Microsoft Windows 2000 Datacenter Server SP4
Microsoft Windows 2000 Datacenter Server SP3
Microsoft Windows 2000 Datacenter Server SP2
Microsoft Windows 2000 Advanced Server SP4
Microsoft Windows 2000 Advanced Server SP3
Microsoft Windows 2000 Advanced Server SP2
Avaya S8100 Media Servers 0
+ Microsoft Windows 2000 Server
+ Microsoft Windows NT Server 4.0 SP6a
Avaya S3400 Message Application Server 0
+ Microsoft Windows 2000 Server
Avaya IP600 Media Servers
Avaya DefinityOne Media Servers

- 漏洞讨论

It has been reported that Microsoft Jet Database Engine (Jet) is prone to a remote code execution vulnerability that that may allow remote attackers to execute arbitrary code in order to gain unauthorized access to a vulnerable system. This issue presents itself when a specially crafted database query is sent by an attacker to be interpreted by Jet. A successful attack may allow the attacker to gain complete control of the affected system.

Microsoft Jet Database Engine version 4.0 running on various Microsoft operating systems is reported to be vulnerable to this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

Avaya has released an advisory to announce that Avaya System Products shipping on Microsoft platforms are also affected by this vulnerability. Avaya advise that customers follow the Microsoft recommendations for the resolution of this issue. The aforementioned advisory can be viewed at the following location:
http://support.avaya.com/japple/css/japple?temp.groupID=&temp.selectedFamily=128451&temp.selectedProduct=154235&temp.selectedBucket=126655&temp.feedbackState=askForFeedback&temp.documentID=161384&PAGE=avaya.css.CSSLvl1Detail&executeTransaction=avaya.css.UsageUpdate()

Microsoft has released a security bulletin MS04-014 with fixes to address this issue. Please see the referenced bulletin for more information.

Users are advised to consider the following requirements before installing the updates:

-For Windows 2000, the security update requires Service Pack 2 (SP2), Service Pack 3 (SP3), or Service Pack 4 (SP4).

-For Windows NT, the security update requires Windows NT Workstation 4.0 Service Pack 6a (SP6a), Windows NT Server 4.0 Service Pack 6a (SP6a), or Windows NT Server 4.0 Terminal Server Edition Service Pack 6 (SP6).

US-CERT has released an advisory TA04-104A to address this and other issues. Please see the referenced advisory for more information.

Microsoft has revised their security bulletin to provide updated fixes for localized versions of Microsoft Windows XP. This corrects an error with displaying localized Jet optional text error information. Please see the attached advisory for further information.


Microsoft Windows 2000 Server SP2

Microsoft Windows Server 2003 Web Edition

Microsoft Windows 2000 Advanced Server SP3

Microsoft Windows XP Home SP1

Microsoft Windows 2000 Advanced Server SP2

Microsoft Windows NT Workstation 4.0 SP6a

Microsoft Windows 2000 Datacenter Server SP3

Microsoft Windows XP 64-bit Edition Version 2003 SP1

Microsoft Windows Server 2003 Enterprise Edition Itanium 0

Microsoft Windows Server 2003 Datacenter Edition

Microsoft Windows XP 64-bit Edition SP1

Microsoft Windows 2000 Advanced Server SP4

Microsoft Windows NT Terminal Server 4.0 SP6

Microsoft Windows 2000 Server SP3

Microsoft Windows Server 2003 Standard Edition

Microsoft Windows XP 64-bit Edition Version 2003

Microsoft Windows 2000 Datacenter Server SP2

Microsoft Windows 2000 Server SP4

Microsoft Windows 2000 Professional SP3

Microsoft Windows Server 2003 Enterprise Edition

Microsoft Windows NT Server 4.0 SP6a

Microsoft Windows 2000 Professional SP2

Microsoft Windows 2000 Professional SP4

Microsoft Windows XP Professional SP1

Microsoft Windows 2000 Datacenter Server SP4

Microsoft Windows Server 2003 Datacenter Edition Itanium 0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站