CVE-2004-0182
CVSS5.0
发布时间 :2004-06-01 00:00:00
修订时间 :2008-09-05 16:37:44
NMCOS    

[原文]Mailman before 2.0.13 allows remote attackers to cause a denial of service (crash) via an email message with an empty subject field.


[CNNVD]Red Hat Linux GNU Mailman远程拒绝服务漏洞(CNNVD-200406-019)

        
        RedHat Mailman是由Python开发的共享软件,利用它可以管理邮件列表。
        RedHat Mailman对部分畸形消息处理不正确,远程攻击者可以利用这个漏洞对服务程序进行拒绝服务攻击。
        如果邮件列表中包含空的Subject字段,接收到此类EMAIL时可造成Mailman崩溃。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0182
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0182
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200406-019
(官方数据源) CNNVD

- 其它链接及资源

http://www.redhat.com/support/errata/RHSA-2004-156.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2004:156
ftp://patches.sgi.com/support/free/security/advisories/20040404-01-U.asc
(VENDOR_ADVISORY)  SGI  20040404-01-U

- 漏洞信息

Red Hat Linux GNU Mailman远程拒绝服务漏洞
中危 设计错误
2004-06-01 00:00:00 2005-10-20 00:00:00
远程  
        
        RedHat Mailman是由Python开发的共享软件,利用它可以管理邮件列表。
        RedHat Mailman对部分畸形消息处理不正确,远程攻击者可以利用这个漏洞对服务程序进行拒绝服务攻击。
        如果邮件列表中包含空的Subject字段,接收到此类EMAIL时可造成Mailman崩溃。
        

- 公告与补丁

        厂商补丁:
        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2004:156-07)以及相应补丁:
        RHSA-2004:156-07:Updated mailman package closes DoS vulnerability
        链接:
        http://rhn.redhat.com/errata/RHSA-2004-156.html

        Redhat系统可使用Red Hat Update Agent (up2date)工具进行升级:
        Red Hat Enterprise Linux AS (v. 2.1)
        --------------------------------------------------------------------------------
        
        SRPMS:
        mailman-2.0.13-6.src.rpm a3e21d6a121d92d2efcef4076faa0e16
        
        i386:
        mailman-2.0.13-6.i386.rpm 74f69c7c5af328c581d053502e6b2465
        
        ia64:
        mailman-2.0.13-6.ia64.rpm 027475a9d95a44f8a8c263f30b854902
        
        Red Hat Enterprise Linux ES (v. 2.1)
        --------------------------------------------------------------------------------
        
        SRPMS:
        mailman-2.0.13-6.src.rpm a3e21d6a121d92d2efcef4076faa0e16
        
        i386:
        mailman-2.0.13-6.i386.rpm 74f69c7c5af328c581d053502e6b2465
        
        Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor
        --------------------------------------------------------------------------------
        
        SRPMS:
        mailman-2.0.13-6.src.rpm a3e21d6a121d92d2efcef4076faa0e16
        
        ia64:
        mailman-2.0.13-6.ia64.rpm 027475a9d95a44f8a8c263f30b854902

- 漏洞信息

15973
Mailman Email Empty Subject Field Remote DoS
Remote / Network Access Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-14 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Red Hat Linux GNU Mailman Remote Denial Of Service Vulnerability
Design Error 10147
Yes No
2004-04-14 12:00:00 2009-07-12 04:06:00
Discovery of this vulnerability is credited to Matthew Saltzman.

- 受影响的程序版本

SGI ProPack 2.4
SGI ProPack 2.3
RedHat Enterprise Linux ES 2.1
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 2.1

- 漏洞讨论

An update that was released by Red Hat(RHSA-2004:019) to address the issue described in BID 9620 (GNU Mailman Malformed Message Remote Denial Of Service Vulnerability), is reported to introduce a denial of service vulnerability.

A remote attacker may exploit this vulnerability to cause the mailman to crash, effectively denying service to legitimate users.

- 漏洞利用

There is no exploit required.

- 解决方案

SGI has released an advisory 20040404-01-U and fixes to address this issue. Please see referenced advisory for further details regarding obtaining and applying appropriate fixes. Fixes are linked below.

Red Hat has released an advisory (RHSA-2004:156-07) and fixes to address this issue on Red Hat Linux Enterprise platforms. Customers who are affected by this issue are advised to apply the appropriate updates. Customers subscribed to the Red Hat Network may apply the appropriate fixes using the Red Hat Update Agent (up2date). Please see referenced advisory for additional information.


SGI ProPack 2.3

SGI ProPack 2.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站