CVE-2004-0152
CVSS7.5
发布时间 :2004-04-15 00:00:00
修订时间 :2016-10-17 22:41:10
NMCO    

[原文]Multiple stack-based buffer overflows in (1) the encode_mime function, (2) the encode_uuencode function, (3) or the decode_uuencode function for emil 2.1.0 and earlier allow remote attackers to execute arbitrary code via e-mail messages containing attachments with filenames.


[CNNVD]Emil多个缓冲区溢出格式串漏洞(CNNVD-200404-056)

        
        emil是一款转换Internet邮件消息的过滤器。
        emil存在多个缓冲区溢出和格式串问题,远程攻击者可以利用这个漏洞以软件进程权限在系统上执行任意指令。
        具体问题如下:
        CAN-2004-0152 - encode_mime、encode_uuencoden、decode_uuencode函数存在缓冲区溢出,这些漏洞允许构建特殊EMAIL消息,当emil进行处理时可能导致任意指令执行。
        CAN-2004-0153 - 当打印各种错误消息时存在格式串问题,可造成拒绝服务,存在执行任意指令的可能。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:emil:emil:2.1.0_beta9
cpe:/a:emil:emil:2.0.5
cpe:/a:emil:emil:2.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0152
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0152
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200404-056
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=108024939827236&w=2
(UNKNOWN)  BUGTRAQ  20040325 Re: [SECURITY] [DSA 468-1] New emil packages fix multiple vulnerabilities
http://www.debian.org/security/2004/dsa-468
(VENDOR_ADVISORY)  DEBIAN  DSA-468
http://xforce.iss.net/xforce/xfdb/15601
(VENDOR_ADVISORY)  XF  emil-email-bo(15601)

- 漏洞信息

Emil多个缓冲区溢出格式串漏洞
高危 未知
2004-04-15 00:00:00 2005-10-20 00:00:00
远程  
        
        emil是一款转换Internet邮件消息的过滤器。
        emil存在多个缓冲区溢出和格式串问题,远程攻击者可以利用这个漏洞以软件进程权限在系统上执行任意指令。
        具体问题如下:
        CAN-2004-0152 - encode_mime、encode_uuencoden、decode_uuencode函数存在缓冲区溢出,这些漏洞允许构建特殊EMAIL消息,当emil进行处理时可能导致任意指令执行。
        CAN-2004-0153 - 当打印各种错误消息时存在格式串问题,可造成拒绝服务,存在执行任意指令的可能。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 第三方补丁可采用如下程序:
        emil 2.1.0-beta9:
        
        http://downloads.securityfocus.com/vulnerabilities/patches/emil.patch

        厂商补丁:
        Debian
        ------
        
        http://www.debian.org/security/2004/dsa-468

- 漏洞信息

4561
Emil Email Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-03-25 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站