CVE-2004-0127
CVSS7.5
发布时间 :2004-03-03 00:00:00
修订时间 :2017-07-10 21:29:55
NMCO    

[原文]Directory traversal vulnerability in editconfig_gedcom.php for phpGedView 2.65.1 and earlier allows remote attackers to read arbitrary files or execute arbitrary PHP programs on the server via .. (dot dot) sequences in the gedcom_config parameter.


[CNNVD]phpGedView editconfig_gedcom.php 目录遍历漏洞(CNNVD-200403-036)

        phpGedView 2.65.1以及之前版本的editconfig_gedcom.php存在目录遍历漏洞。远程攻击者借助gedcom_config参数中的..(点 点)序列在服务器上读取任意文件或执行任意PHP程序。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:phpgedview:phpgedview:2.52.3
cpe:/a:phpgedview:phpgedview:2.61.1
cpe:/a:phpgedview:phpgedview:2.60
cpe:/a:phpgedview:phpgedview:2.61
cpe:/a:phpgedview:phpgedview:2.65.1
cpe:/a:phpgedview:phpgedview:2.65

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0127
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0127
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-036
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/352355
(VENDOR_ADVISORY)  BUGTRAQ  20040129 PHP Code Injection Vulnerabilities in phpGedView 2.65.1 and prior
http://www.securityfocus.com/bid/9529
(VENDOR_ADVISORY)  BID  9529
http://www.securitytracker.com/id?1008892
(UNKNOWN)  SECTRACK  1008892
https://exchange.xforce.ibmcloud.com/vulnerabilities/15129
(UNKNOWN)  XF  phpgedview-editconfig-directory-traversal(15129)

- 漏洞信息

phpGedView editconfig_gedcom.php 目录遍历漏洞
高危 路径遍历
2004-03-03 00:00:00 2005-10-20 00:00:00
远程  
        phpGedView 2.65.1以及之前版本的editconfig_gedcom.php存在目录遍历漏洞。远程攻击者借助gedcom_config参数中的..(点 点)序列在服务器上读取任意文件或执行任意PHP程序。
        

- 公告与补丁

        

- 漏洞信息

3768
PhpGedView editconfig_gedcom.php gedcom_config Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

PhpGedView contains a flaw that may allow a malicious user with administrative rights to include malicious PHP files. The issue is triggered when an attacker sends a specially-crafted URL request to the editconfig_gedcom.php script to specify a malicious file from a remote system. It is possible that the flaw may allow arbitrary code execution resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2004-01-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.65.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站