CVE-2004-0089
CVSS4.6
发布时间 :2004-03-03 00:00:00
修订时间 :2008-09-10 15:25:06
NMCOS    

[原文]Buffer overflow in TruBlueEnvironment in Mac OS X 10.3.x and 10.2.x allows local users to gain privileges via a long environment variable.


[CNNVD]Apple Mac OS X TruBlueEnvironment本地缓冲区溢出漏洞(CNNVD-200403-015)

        
        Mac OS X是一款使用在Mac机器上的操作系统,基于BSD系统。
        Mac OS X包含的TruBlueEnvironment模拟器缺少正确边界缓冲区检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以ROOT权限在系统上执行任意指令。
        TruBlueEnvironment默认以setuid root属性安装,TruBlueEnvironment接收环境变量并没有进行任意边界检查拷贝数据到缓冲区中,可导致覆盖堆栈中返回地址而以root用户权限执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.3.9Apple Mac OS X 10.3.9
cpe:/o:apple:mac_os_x:10.2.8Apple Mac OS X 10.2.8

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0089
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0089
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-015
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/902374
(UNKNOWN)  CERT-VN  VU#902374
http://www.securityfocus.com/bid/9509
(VENDOR_ADVISORY)  BID  9509
http://xforce.iss.net/xforce/xfdb/14968
(UNKNOWN)  XF  macosx-trublue-environmentvariable-bo(14968)
http://www.osvdb.org/6821
(UNKNOWN)  OSVDB  6821
http://www.atstake.com/research/advisories/2004/a012704-1.txt
(UNKNOWN)  ATSTAKE  A012704-1
http://lists.apple.com/archives/security-announce/2004/Jan/msg00000.html
(UNKNOWN)  APPLE  APPLE-SA-2004-01-26

- 漏洞信息

Apple Mac OS X TruBlueEnvironment本地缓冲区溢出漏洞
中危 边界条件错误
2004-03-03 00:00:00 2005-05-13 00:00:00
本地  
        
        Mac OS X是一款使用在Mac机器上的操作系统,基于BSD系统。
        Mac OS X包含的TruBlueEnvironment模拟器缺少正确边界缓冲区检查,本地攻击者可以利用这个漏洞进行缓冲区溢出攻击,可能以ROOT权限在系统上执行任意指令。
        TruBlueEnvironment默认以setuid root属性安装,TruBlueEnvironment接收环境变量并没有进行任意边界检查拷贝数据到缓冲区中,可导致覆盖堆栈中返回地址而以root用户权限执行任意指令。
        

- 公告与补丁

        厂商补丁:
        Apple
        -----
        用户可以通过软件升级参考或者通过如下地址获得升级程序:
        
        http://www.apple.com/swupdates/

- 漏洞信息

6821
Apple Mac OS X TruBlueEnvironment Environment Variable Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A local overflow exists in Mac OS X. The TruBlueEnvironment fails to validate environment variables resulting in a buffer overflow. With a specially crafted request, an attacker can escalate to root privileges resulting in a loss of integrity.

- 时间线

2004-01-26 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Apple has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Multiple Apple Mac OS X Local And Remote Vulnerabilities
Unknown 9731
Yes Yes
2004-02-24 12:00:00 2009-07-12 03:06:00
The vendor has credited multiple sources with discovery of these issues, including Dave G. of @stake and iDEFENSE Labs.

- 受影响的程序版本

Apple Mac OS X Server 10.3.2
Apple Mac OS X Server 10.3.1
Apple Mac OS X Server 10.3
Apple Mac OS X Server 10.2.8
Apple Mac OS X Server 10.2.7
Apple Mac OS X Server 10.2.6
Apple Mac OS X Server 10.2.5
Apple Mac OS X Server 10.2.4
Apple Mac OS X Server 10.2.3
Apple Mac OS X Server 10.2.2
Apple Mac OS X Server 10.2.1
Apple Mac OS X Server 10.2
Apple Mac OS X Server 10.1.5
Apple Mac OS X Server 10.1.4
Apple Mac OS X Server 10.1.3
Apple Mac OS X Server 10.1.2
Apple Mac OS X Server 10.1.1
Apple Mac OS X Server 10.1
Apple Mac OS X Server 10.0
Apple Mac OS X 10.3.2
Apple Mac OS X 10.3.1
Apple Mac OS X 10.3
Apple Mac OS X 10.2.8
Apple Mac OS X 10.2.7
Apple Mac OS X 10.2.6
Apple Mac OS X 10.2.5
Apple Mac OS X 10.2.4
Apple Mac OS X 10.2.3
Apple Mac OS X 10.2.2
Apple Mac OS X 10.2.1
Apple Mac OS X 10.2
Apple Mac OS X 10.1.5
Apple Mac OS X 10.1.4
Apple Mac OS X 10.1.3
Apple Mac OS X 10.1.2
Apple Mac OS X 10.1.1
Apple Mac OS X 10.1
Apple Mac OS X 10.1
Apple Mac OS X 10.0.4
Apple Mac OS X 10.0.3
Apple Mac OS X 10.0.2
Apple Mac OS X 10.0.1
Apple Mac OS X 10.0 3
Apple Mac OS X 10.0

- 漏洞讨论

Apple has reported multiple previously known and newly discovered security vulnerabilities in Mac OS X (Client and Server).

The individual security issues include:

Improved notification logging (CAN-2004-0168).

Undisclosed DiskArbitration security improvements for handling writeable removable media (CAN-2004-0167).

Undisclosed IPSec key exchange issue (CAN-2004-0164).

pppd daemon format string vulnerability described in BID 9730(Apple Mac OS X PPPD Format String Memory Disclosure Vulnerability) (CAN-2004-0165).

Unspecified security vulnerability (CAN-2004-0089) in QuickTime Streaming Server that is related to handling of request data.

URI display issue (CAN-2004-0166) in the Safari web browser.

Finally 3 vulnerabilities in tcpdump. These issues are described in BID 9507(TCPDump ISAKMP Decoding Routines Denial Of Service Vulnerability), BID 7090(TCPDump Malformed RADIUS Packet Denial Of Service Vulnerability) and BID 9423(TCPDump ISAKMP Decoding Routines Multiple Remote Buffer Overflow Vulnerabilities).

These issues are currently undergoing further analysis. Where it is appropriate, each individual issue will be assigned a unique BID and any existing BIDs will be updated accordingly to reflect the release of this Security Update.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Apple has released a Security Update to address these issues in various versions of Mac OS X. These fixes may be applied manually or via the Software Update pane in System Preferences.


Apple Mac OS X 10.2.8

Apple Mac OS X Server 10.2.8

Apple Mac OS X 10.3.2

Apple Mac OS X Server 10.3.2

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站