CVE-2004-0082
CVSS7.5
发布时间 :2004-03-03 00:00:00
修订时间 :2008-09-05 16:37:29
NMCO    

[原文]The mksmbpasswd shell script (mksmbpasswd.sh) in Samba 3.0.0 and 3.0.1, when creating an account but marking it as disabled, may overwrite the user password with an uninitialized buffer, which could enable the account with a more easily guessable password.


[CNNVD]Samba Mksmbpasswd.sh以不安全方式创建用户帐户漏洞(CNNVD-200403-003)

        
        Samba是一套实现SMB(Server Messages Block)协议,跨平台进行文件共享和打印共享服务的程序。
        Samba mksmbpasswd.sh shell脚本存在安全问题,本地攻击者可以利用这个漏洞建立用户帐户。
        攻击者可以利用这个脚本建立的不安全帐户访问Samba共享资源。目前没有详细漏洞细节提供。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:samba:samba:3.0.1Samba 3.0.1
cpe:/a:samba:samba:3.0.0Samba 3.0.0
cpe:/a:samba:samba:3.0Samba 3.0

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:827Samba mksmboasswd Disabled Account Creation Vulnerability
oval:org.mitre.oval:def:10675The mksmbpasswd shell script (mksmbpasswd.sh) in Samba 3.0.0 and 3.0.1, when creating an account but marking it as disabled, may overwrite t...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-0082
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-0082
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200403-003
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/9637
(VENDOR_ADVISORY)  BID  9637
http://www.redhat.com/support/errata/RHSA-2004-064.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2004:064
http://xforce.iss.net/xforce/xfdb/15132
(VENDOR_ADVISORY)  XF  samba-mksmbpasswd-gain-access(15132)
http://www.vuxml.org/freebsd/3388eff9-5d6e-11d8-80e3-0020ed76ef5a.html
(UNKNOWN)  CONFIRM  http://www.vuxml.org/freebsd/3388eff9-5d6e-11d8-80e3-0020ed76ef5a.html
http://us1.samba.org/samba/ftp/WHATSNEW-3.0.2a.txt
(UNKNOWN)  CONFIRM  http://us1.samba.org/samba/ftp/WHATSNEW-3.0.2a.txt
http://www.osvdb.org/3919
(UNKNOWN)  OSVDB  3919
http://www.ciac.org/ciac/bulletins/o-078.shtml
(UNKNOWN)  CIAC  O-078

- 漏洞信息

Samba Mksmbpasswd.sh以不安全方式创建用户帐户漏洞
高危 设计错误
2004-03-03 00:00:00 2005-05-13 00:00:00
远程  
        
        Samba是一套实现SMB(Server Messages Block)协议,跨平台进行文件共享和打印共享服务的程序。
        Samba mksmbpasswd.sh shell脚本存在安全问题,本地攻击者可以利用这个漏洞建立用户帐户。
        攻击者可以利用这个脚本建立的不安全帐户访问Samba共享资源。目前没有详细漏洞细节提供。
        

- 公告与补丁

        厂商补丁:
        RedHat
        ------
        RedHat已经为此发布了一个安全公告(RHSA-2004:064-10)以及相应补丁:
        RHSA-2004:064-10:Updated samba packages fix security vulnerability
        链接:https://rhn.redhat.com/errata/RHSA-2004-064.html
        补丁下载:
        Fedora Upgrade samba-3.0.2-7.FC1.i386.rpm
        
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/samba-3.0.2-7.FC1.i386.rpm

        Fedora Upgrade samba-client-3.0.2-7.FC1.i386.rpm
        
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/samba-client-3.0.2-7.FC1.i386.rpm

        Fedora Upgrade samba-common-3.0.2-7.FC1.i386.rpm
        
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/samba-common-3.0.2-7.FC1.i386.rpm

        Fedora Upgrade samba-swat-3.0.2-7.FC1.i386.rpm
        
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/samba-swat-3.0.2-7.FC1.i386.rpm

        Fedora Upgrade samba-debuginfo-3.0.2-7.FC1.i386.rpm
        
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/1/i386/debug/samba-debuginfo-3.0.2-7.FC1.i386.rpm

        Samba
        -----
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        Samba Upgrade Samba 3.0.2
        
        http://samba.org/samba/whatsnew/samba-3.0.2.html

- 漏洞信息

3919
Samba mksmbpasswd.sh Uninitialized Passwords
Remote / Network Access Authentication Management
Loss of Integrity

- 漏洞描述

Samba contains a flaw that may allow a malicious user to gain access. The issue is triggered when mksmbpasswd.sh is used to create accounts, and does not initialize passwords. It is possible that the flaw may allow unauthorized access resulting in a loss of confidentiality and integrity.

- 时间线

2004-02-09 2004-02-09
Unknow Unknow

- 解决方案

Upgrade to version 3.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站